summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Michaël Dupont <milka@konstelacioj.info>2010-05-11 20:02:13 +0200
committer Robby Workman <rworkman@slackbuilds.org>2010-05-11 20:02:13 +0200
commit6a49b9e7fc137c37ecac9ef0454c43f9241a556a (patch)
tree2cce98c78153d043aa3b32a73fb60c2209660f81
parent22e03450da16c784e6ffd4769e75844253d5577a (diff)
downloadslackbuilds-6a49b9e7fc137c37ecac9ef0454c43f9241a556a.tar.gz
slackbuilds-6a49b9e7fc137c37ecac9ef0454c43f9241a556a.tar.xz
system/zeroinstall-injector: Added to 12.0 repository
-rw-r--r--system/zeroinstall-injector/README13
-rw-r--r--system/zeroinstall-injector/doinst.sh5
-rw-r--r--system/zeroinstall-injector/slack-desc19
-rw-r--r--system/zeroinstall-injector/zeroinstall-injector.SlackBuild45
-rw-r--r--system/zeroinstall-injector/zeroinstall-injector.info8
5 files changed, 90 insertions, 0 deletions
diff --git a/system/zeroinstall-injector/README b/system/zeroinstall-injector/README
new file mode 100644
index 0000000000..933c126126
--- /dev/null
+++ b/system/zeroinstall-injector/README
@@ -0,0 +1,13 @@
+The Zero Install Injector
+
+A running process is created by combining many different libraries
+(and other components). In the Zero Install world, we have
+all versions of each library available at all times. The problem is
+then how to choose which versions to use.
+
+The injector solves this problem by selecting components to meet
+a program's requirements, according to a policy you give it.
+The injector finds out which versions are available, and downloads
+and runs the ones you choose.
+
+NOTE: You'll need PyGTK (available at SlackBuilds.org) to run this.
diff --git a/system/zeroinstall-injector/doinst.sh b/system/zeroinstall-injector/doinst.sh
new file mode 100644
index 0000000000..22d4849bce
--- /dev/null
+++ b/system/zeroinstall-injector/doinst.sh
@@ -0,0 +1,5 @@
+
+if [ -x usr/bin/update-desktop-database ]; then
+ usr/bin/update-desktop-database usr/share/applications >/dev/null 2>&1
+fi
+
diff --git a/system/zeroinstall-injector/slack-desc b/system/zeroinstall-injector/slack-desc
new file mode 100644
index 0000000000..1063c5404e
--- /dev/null
+++ b/system/zeroinstall-injector/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|'
+# on the right side marks the last column you can put a character in. You must
+# make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------|
+zeroinstall-injector: zeroinstall-injector (The Zero Install Injector)
+zeroinstall-injector:
+zeroinstall-injector: A running process is created by combining many different
+zeroinstall-injector: libraries (and other components). In the Zero Install
+zeroinstall-injector: world, we have all versions of each library available at
+zeroinstall-injector: all times. The problem is then choosing which to use.
+zeroinstall-injector:
+zeroinstall-injector: The injector solves this problem by selecting components
+zeroinstall-injector: to meet a program's requirements according to user policy.
+zeroinstall-injector: The injector finds out which versions are available and
+zeroinstall-injector: downloads and runs the ones you choose.
diff --git a/system/zeroinstall-injector/zeroinstall-injector.SlackBuild b/system/zeroinstall-injector/zeroinstall-injector.SlackBuild
new file mode 100644
index 0000000000..5ccfa224c2
--- /dev/null
+++ b/system/zeroinstall-injector/zeroinstall-injector.SlackBuild
@@ -0,0 +1,45 @@
+#!/bin/sh
+
+# Slackware build script for zeroinstall-injector
+
+PRGNAM=zeroinstall-injector
+VERSION=0.32
+ARCH=${ARCH:-$(uname -m)}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e # Exit on most errors
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
+chown -R root:root .
+chmod -R u+w,go+r-w,a-s .
+
+python setup.py install \
+ --root=$PKG \
+ --prefix=/usr \
+
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $(find . -type l) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/system/zeroinstall-injector/zeroinstall-injector.info b/system/zeroinstall-injector/zeroinstall-injector.info
new file mode 100644
index 0000000000..1c37ad66c7
--- /dev/null
+++ b/system/zeroinstall-injector/zeroinstall-injector.info
@@ -0,0 +1,8 @@
+PRGNAM="zeroinstall-injector"
+VERSION="0.32"
+HOMEPAGE="http://0install.net"
+DOWNLOAD="http://downloads.sourceforge.net/zero-install/zeroinstall-injector-0.32.tar.bz2"
+MD5SUM="865025e25c2d9c0154d886c47fe7de63"
+MAINTAINER="Michaël Dupont"
+EMAIL="milka@konstelacioj.info"
+APPROVED="rworkman"