summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Audrius Kažukauskas <audrius@neutrino.lt>2010-05-12 23:33:38 +0200
committer David Somero <xgizzmo@slackbuilds.org>2010-05-12 23:33:38 +0200
commit86940cc1a6c2bb311952262ad867f6f14d8dbecf (patch)
treec9a630a9453968baccff182a88614143e2be4018
parent22596a070d19cc197f88d17d8ad02dd25cccf4fc (diff)
downloadslackbuilds-86940cc1a6c2bb311952262ad867f6f14d8dbecf.tar.gz
slackbuilds-86940cc1a6c2bb311952262ad867f6f14d8dbecf.tar.xz
system/iotop: Added to 12.2 repository
-rw-r--r--system/iotop/README7
-rw-r--r--system/iotop/iotop.SlackBuild50
-rw-r--r--system/iotop/iotop.info8
-rw-r--r--system/iotop/slack-desc20
4 files changed, 85 insertions, 0 deletions
diff --git a/system/iotop/README b/system/iotop/README
new file mode 100644
index 0000000000..8e7d6d8d42
--- /dev/null
+++ b/system/iotop/README
@@ -0,0 +1,7 @@
+iotop is a Python program with a top-like UI used to show of behalf of which
+process is the I/O going on.
+
+For iotop to work you need to have kernel with at least these options enabled:
+
+CONFIG_TASKSTATS=y
+CONFIG_TASK_IO_ACCOUNTING=y
diff --git a/system/iotop/iotop.SlackBuild b/system/iotop/iotop.SlackBuild
new file mode 100644
index 0000000000..ff725dee7a
--- /dev/null
+++ b/system/iotop/iotop.SlackBuild
@@ -0,0 +1,50 @@
+#!/bin/sh
+
+# Slackware build script for iotop
+# Written by Audrius Kažukauskas <audrius@neutrino.lt>
+
+PRGNAM=iotop
+VERSION=${VERSION:-0.3}
+ARCH=${ARCH:-i486}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+set -eu
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find . \
+ \( -perm 777 -o -perm 775 -o -perm 711 -o -perm 555 -o -perm 511 \) \
+ -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
+ -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+mv $PKG/usr/share/man $PKG/usr
+rm -rf $PKG/usr/share
+
+( cd $PKG/usr/man
+ find . -type f -exec gzip -9 {} \;
+ for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING NEWS THANKS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.tgz
diff --git a/system/iotop/iotop.info b/system/iotop/iotop.info
new file mode 100644
index 0000000000..78eecd4c32
--- /dev/null
+++ b/system/iotop/iotop.info
@@ -0,0 +1,8 @@
+PRGNAM="iotop"
+VERSION="0.3"
+HOMEPAGE="http://guichaz.free.fr/iotop/"
+DOWNLOAD="http://guichaz.free.fr/iotop/files/iotop-0.3.tar.bz2"
+MD5SUM="4b6979b7ee8e667c222abbd9b75dd7d1"
+MAINTAINER="Audrius Kazukauskas"
+EMAIL="audrius@neutrino.lt"
+APPROVED="dsomero"
diff --git a/system/iotop/slack-desc b/system/iotop/slack-desc
new file mode 100644
index 0000000000..0f4d01fba1
--- /dev/null
+++ b/system/iotop/slack-desc
@@ -0,0 +1,20 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description. Line
+# up the first '|' above the ':' following the base package name, and the '|' on
+# the right side marks the last column you can put a character in. You must make
+# exactly 11 lines for the formatting to be correct. It's also customary to
+# leave one space after the ':'.
+
+ |-----handy-ruler------------------------------------------------------|
+iotop: iotop (top-like I/O monitor)
+iotop:
+iotop: iotop is a Python program with a top-like UI used to show of behalf of
+iotop: which process is the I/O going on.
+iotop:
+iotop: Homepage: http://guichaz.free.fr/iotop/
+iotop:
+iotop:
+iotop:
+iotop:
+iotop:
+