summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Mario Preksavec <mario@slackware.hr>2015-04-26 07:55:08 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-04-26 07:55:08 +0700
commit31a3d2deb9c9caf10807358c113d31bca77e1a4d (patch)
treec44c572e010bd1ea081b2d72965f8ea1c0c587f8
parentbd3bd2e2e21f994a4d1a2233b491122d5854b910 (diff)
downloadslackbuilds-31a3d2deb9c9caf10807358c113d31bca77e1a4d.tar.gz
slackbuilds-31a3d2deb9c9caf10807358c113d31bca77e1a4d.tar.xz
network/wireshark: Force to use Qt4.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--network/wireshark/README6
-rw-r--r--network/wireshark/wireshark.SlackBuild11
2 files changed, 8 insertions, 9 deletions
diff --git a/network/wireshark/README b/network/wireshark/README
index a690d6e480..df4dae5664 100644
--- a/network/wireshark/README
+++ b/network/wireshark/README
@@ -22,9 +22,3 @@ You will need to remove any already-installed wireshark package before
building this one or else the new one will not work (the new build will
link libraries present in the old package, which will then be removed
when upgrading).
-
-WARNING: Wireshark will not compile currently on a sysytem that has QT4 AND
-QT5 installed. The easiest way to fix this is to either 1) Build in a clean
-enviroment or 2) Remove QT5 temporarily while building Wirehark so it links
-properly against Slackware's own QT4.
-
diff --git a/network/wireshark/wireshark.SlackBuild b/network/wireshark/wireshark.SlackBuild
index 58e1da659a..8bbee5a50b 100644
--- a/network/wireshark/wireshark.SlackBuild
+++ b/network/wireshark/wireshark.SlackBuild
@@ -25,6 +25,8 @@
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# Modified by Mario Preksavec <mario@slackware.hr>
+
PRGNAM=wireshark
VERSION=${VERSION:-1.12.2}
BUILD=${BUILD:-1}
@@ -64,15 +66,18 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Ammend hardcoded paths to /usr/lib/ which will give a problem when compiling on
# systems with 32bit compat libs install. Thanks to Heinz Wiesinger.
sed -i "s|/lib)|/lib$LIBDIRSUFFIX)|g" configure.ac
+# Force use of qt4 libs
+sed -i 's/for modprefix in Qt5 Qt/for modprefix in Qt/' acinclude.m4
+
# run autoreconf so it'll use the correct automake version.
autoreconf -f -i