summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2014-09-12 01:52:37 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-09-12 01:52:37 +0700
commitc72b72b44666df5ec83bbe9b3abf15f097d45c6f (patch)
treed7087bf40fc6fda3b16377e10b70015a6b4933c0
parenta690951e27063ddd2135f01155ca4923832f4b4d (diff)
downloadslackbuilds-c72b72b44666df5ec83bbe9b3abf15f097d45c6f.tar.gz
slackbuilds-c72b72b44666df5ec83bbe9b3abf15f097d45c6f.tar.xz
python/path.py: Added (A module wrapper for os.path).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/path.py/README3
-rw-r--r--python/path.py/path.py.SlackBuild90
-rw-r--r--python/path.py/path.py.info10
-rw-r--r--python/path.py/slack-desc19
4 files changed, 122 insertions, 0 deletions
diff --git a/python/path.py/README b/python/path.py/README
new file mode 100644
index 0000000000..6d8a3a2c3b
--- /dev/null
+++ b/python/path.py/README
@@ -0,0 +1,3 @@
+path.py implements a path objects as first-class entities,
+allowing common operations on files to be invoked on those
+path objects directly.
diff --git a/python/path.py/path.py.SlackBuild b/python/path.py/path.py.SlackBuild
new file mode 100644
index 0000000000..bd38034a43
--- /dev/null
+++ b/python/path.py/path.py.SlackBuild
@@ -0,0 +1,90 @@
+#!/bin/sh
+
+# Slackware build script for path.py
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=path.py
+VERSION=${VERSION:-5.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst CHANGES.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/path.py/path.py.info b/python/path.py/path.py.info
new file mode 100644
index 0000000000..b00323ab09
--- /dev/null
+++ b/python/path.py/path.py.info
@@ -0,0 +1,10 @@
+PRGNAM="path.py"
+VERSION="5.2"
+HOMEPAGE="https://github.com/jaraco/path.py"
+DOWNLOAD="https://github.com/jaraco/path.py/archive/5.2.tar.gz"
+MD5SUM="c0f9b0a65812113c8467aeb3b1b3335f"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/path.py/slack-desc b/python/path.py/slack-desc
new file mode 100644
index 0000000000..c85172b889
--- /dev/null
+++ b/python/path.py/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+path.py: path.py (A module wrapper for os.path)
+path.py:
+path.py: path.py implements a path objects as first-class entities,
+path.py: allowing common operations on files to be invoked on those
+path.py: path objects directly.
+path.py:
+path.py: Homepage: https://github.com/jaraco/path.py
+path.py:
+path.py:
+path.py:
+path.py: