summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2014-09-08 22:29:02 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-09-08 22:29:02 +0700
commitf411e995c7c30c59c2c7ca8db9b3dfef074a6183 (patch)
tree18ae90ad7fa7dd03f633a4d23fb570386b56faec
parentbb3e9088e5451fc966754cf01a8fec250af613ca (diff)
downloadslackbuilds-f411e995c7c30c59c2c7ca8db9b3dfef074a6183.tar.gz
slackbuilds-f411e995c7c30c59c2c7ca8db9b3dfef074a6183.tar.xz
games/supermariowar: Fix broken patch.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--games/supermariowar/compilefixes.diff67
-rw-r--r--games/supermariowar/compilefixes.diff.gzbin0 -> 1003 bytes
-rw-r--r--games/supermariowar/supermariowar.SlackBuild4
3 files changed, 2 insertions, 69 deletions
diff --git a/games/supermariowar/compilefixes.diff b/games/supermariowar/compilefixes.diff
deleted file mode 100644
index 4a36c52c34..0000000000
--- a/games/supermariowar/compilefixes.diff
+++ /dev/null
@@ -1,67 +0,0 @@
-diff -Naur supermariowar-r16/Makefile supermariowar-r16.patched/Makefile
---- supermariowar-r16/Makefile 2014-04-08 14:07:20.000000000 -0400
-+++ supermariowar-r16.patched/Makefile 2014-04-08 14:09:00.000000000 -0400
-@@ -8,9 +8,9 @@
- build/savepng.o build/sfx.o
- SMW_OBJS:= build/HashTable.o build/ai.o build/gamemodes.o build/main.o \
- build/map.o build/menu.o build/object.o build/player.o \
-- build/splash.o build/uicontrol.o build/uimenu.o build/world.o
-+ build/splash.o build/uicontrol.o build/uimenu.o build/world.o build/objecthazard.o build/objectgame.o build/modeoptionsmenu.o build/uicustomcontrol.o
- LEVELEDIT_OBJS:=build/leveleditor.o
--WORLDEDIT_OBJS:=build/sfx.o build/world.o build/worldeditor.o
-+WORLDEDIT_OBJS:=build/dirlist.o build/eyecandy.o build/FileIO.o build/FileList.o build/global.o build/input.o build/map.o build/MapList.o build/modeoptionsmenu.o build/movingplatform.o build/object.o build/objecthazard.o build/path.o build/savepng.o build/TilesetManager.o build/uicontrol.o build/uimenu.o build/world.o build/worldeditor.o build/gfx.o build/SFont.o build/sfx.o build/linfunc.o
-
- include configuration
- #here because of one .c file among a .cpp project (o_O)
-@@ -24,7 +24,7 @@
- leveledit : $(COMMON_OBJS) $(LEVELEDIT_OBJS)
- $(CXX) $(CFLAGS) $^ $(LDFLAGS) -o $@
-
--worldedit : $(COMMON_OBJS) $(WORLDEDIT_OBJS)
-+worldedit : $(WORLDEDIT_OBJS)
- $(CXX) $(CFLAGS) $^ $(LDFLAGS) -o $@
-
- build/SFont.o : _src/SFont.c
-diff -Naur supermariowar-r16/_src/FileList.cpp supermariowar-r16.patched/_src/FileList.cpp
---- supermariowar-r16/_src/FileList.cpp 2010-01-06 14:33:55.000000000 -0500
-+++ supermariowar-r16.patched/_src/FileList.cpp 2014-03-27 15:06:03.000000000 -0400
-@@ -16,6 +16,7 @@
- #include "dirlist.h"
- #include <ctype.h>
- #include <iostream>
-+#include <algorithm>
- using std::cout;
- using std::endl;
- using std::string;
-diff -Naur supermariowar-r16/_src/ai.cpp supermariowar-r16.patched/_src/ai.cpp
---- supermariowar-r16/_src/ai.cpp 2010-01-06 14:33:55.000000000 -0500
-+++ supermariowar-r16.patched/_src/ai.cpp 2014-03-27 15:43:02.000000000 -0400
-@@ -345,7 +345,8 @@
- {
- delete itr->second;
-
-- itr = attentionObjects.erase(itr);
-+ attentionObjects.erase(itr);
-+ itr = attentionObjects.begin();
- lim = attentionObjects.end();
- }
- }
-diff -Naur supermariowar-r16/_src/path.cpp supermariowar-r16.patched/_src/path.cpp
---- supermariowar-r16/_src/path.cpp 2010-01-06 14:33:55.000000000 -0500
-+++ supermariowar-r16.patched/_src/path.cpp 2014-03-27 15:07:56.000000000 -0400
-@@ -1,3 +1,4 @@
-+#include <string.h>
- #include <string>
- #include <iostream>
- #include <sys/stat.h>
-diff -Naur supermariowar-r16/_src/uicontrol.cpp supermariowar-r16.patched/_src/uicontrol.cpp
---- supermariowar-r16/_src/uicontrol.cpp 2010-01-06 14:33:55.000000000 -0500
-+++ supermariowar-r16.patched/_src/uicontrol.cpp 2014-03-27 15:45:58.000000000 -0400
-@@ -2,6 +2,7 @@
- #include <math.h>
-
- extern void LoadCurrentMapBackground();
-+extern void LoadMapHazards(bool fPreview);
-
- UI_Control::UI_Control(short x, short y)
- {
diff --git a/games/supermariowar/compilefixes.diff.gz b/games/supermariowar/compilefixes.diff.gz
new file mode 100644
index 0000000000..96d6f2f543
--- /dev/null
+++ b/games/supermariowar/compilefixes.diff.gz
Binary files differ
diff --git a/games/supermariowar/supermariowar.SlackBuild b/games/supermariowar/supermariowar.SlackBuild
index c0c290fbd0..37d84ea39c 100644
--- a/games/supermariowar/supermariowar.SlackBuild
+++ b/games/supermariowar/supermariowar.SlackBuild
@@ -8,7 +8,7 @@
PRGNAM=supermariowar
VERSION=${VERSION:-r16}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -56,7 +56,7 @@ find -L . \
# C++ is a fast-moving target, code from 2009, compiler from 2014 or so.
# Also, the code got refactored and the VC++ projects updated, but the
# Makefile hadn't been (so I had to parse the VC++ project file, ugh).
-patch -p1 < $CWD/compilefixes.diff
+zcat $CWD/compilefixes.diff.gz | patch -p1
# the configure script isn't autoconf (yay), but it has CRLFs (boo)
sed -i 's,\r,,g' configure