summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Serban Udrea <S.Udrea@gsi.de>2014-10-29 00:10:31 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-10-30 20:27:32 +0700
commit19958c04c5a0edf363c8981b24edb422430d3a38 (patch)
tree9ce739e6ce19cecf02d00a50da50107a629fcfd1
parent21415395bbd3eff845ce883adb41b495bab2ef11 (diff)
downloadslackbuilds-19958c04c5a0edf363c8981b24edb422430d3a38.tar.gz
slackbuilds-19958c04c5a0edf363c8981b24edb422430d3a38.tar.xz
development/numpy-legacy: Added (Python extension).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--development/numpy-legacy/README24
-rw-r--r--development/numpy-legacy/numpy-legacy.SlackBuild101
-rw-r--r--development/numpy-legacy/numpy-legacy.info10
-rw-r--r--development/numpy-legacy/slack-desc21
4 files changed, 156 insertions, 0 deletions
diff --git a/development/numpy-legacy/README b/development/numpy-legacy/README
new file mode 100644
index 0000000000..ace9230ef8
--- /dev/null
+++ b/development/numpy-legacy/README
@@ -0,0 +1,24 @@
+NumPy is a general-purpose array-processing package designed to
+efficiently manipulate large multi-dimensional arrays of arbitrary
+records without sacrificing too much speed for small multi-dimensional
+arrays. NumPy is built on the Numeric code base and adds features
+introduced by numarray as well as an extended C-API and the ability to
+create arrays of arbitrary type which also makes NumPy suitable for
+interfacing with general-purpose data-base applications.
+
+There are also basic facilities for discrete fourier transform, basic
+linear algebra and random number generation.
+
+If you need to build numpy for debugging, set DEBUG=y. If software
+depending on numpy is having problems with the new relaxed strides
+checking, set NPY_RSC=0.
+
+It is highly recommended to install optimized BLAS and LAPACK libs
+before installing numpy. You may choose between ATLAS+LAPACK and
+OpenBLAS.
+
+IMPORTANT: This version, 1.8.2, is the latest to include the oldnumeric
+ and numarray compatibility modules. Starting with version
+ 1.9.0 these modules got removed by the numpy developers.
+ THUS: This SlackBuild conflicts with the numpy SlackBuild
+ which installs versions >= 1.9.0!
diff --git a/development/numpy-legacy/numpy-legacy.SlackBuild b/development/numpy-legacy/numpy-legacy.SlackBuild
new file mode 100644
index 0000000000..e90665c675
--- /dev/null
+++ b/development/numpy-legacy/numpy-legacy.SlackBuild
@@ -0,0 +1,101 @@
+#!/bin/sh
+
+# Slackware build script for the latest version of NumPy to include
+# the compatibility layer with numeric and numarray
+
+# Written by Aleksandar Samardzic <asamardzic@gmail.com>
+# Updated up to 1.8.2 by Serban Udrea <S.Udrea@gsi.de>
+# Added support for building with debugging symbols (S. Udrea)
+# LIBDIRSUFFIX is now needed to set the proper path for
+# UMFPACK (S. Udrea)
+
+PRGNAM="numpy-legacy"
+VERSION=${VERSION:-1.8.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+TARBALL_NAME=numpy # This is actually what we are going to install
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=${PKG:-$TMP/package-$PRGNAM}
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $TARBALL_NAME-$VERSION
+tar xvf $CWD/$TARBALL_NAME-$VERSION.tar.gz
+cd $TARBALL_NAME-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+cat > site.cfg <<EOF
+[amd]
+library_dirs = /usr/lib${LIBDIRSUFFIX}
+include_dirs = /usr/include/amd
+amd_libs = amd
+
+[umfpack]
+library_dirs = /usr/lib${LIBDIRSUFFIX}
+include_dirs = /usr/include/umfpack
+umfpack_libs = umfpack
+EOF
+
+DEBUG=${DEBUG:-no}
+
+case "$DEBUG" in
+ [yY]|[yY][eE][sS]) DEBUG="y" ;;
+ *) DEBUG="" ;;
+esac
+
+if [ ! "$DEBUG" ]; then
+ NPY_RELAXED_STRIDES_CHECKING=${NPY_RSC:-1} python setup.py install --root $PKG
+
+ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+else
+ NPY_RELAXED_STRIDES_CHECKING=${NPY_RSC:-1} python setup.py build --debug
+ python setup.py install --root $PKG
+fi
+
+mkdir -p $PKG/usr/doc/$TARBALL_NAME-$VERSION
+cp -a COMPATIBILITY DEV_README.txt LICENSE.txt README.txt THANKS.txt\
+ $PKG/usr/doc/$TARBALL_NAME-$VERSION
+cat $CWD/${PRGNAM}.SlackBuild > \
+$PKG/usr/doc/$TARBALL_NAME-$VERSION/${PRGNAM}.SlackBuild
+find $PKG/usr/doc -type f -exec chmod 0644 {} \;
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/numpy-legacy/numpy-legacy.info b/development/numpy-legacy/numpy-legacy.info
new file mode 100644
index 0000000000..296007f2eb
--- /dev/null
+++ b/development/numpy-legacy/numpy-legacy.info
@@ -0,0 +1,10 @@
+PRGNAM="numpy-legacy"
+VERSION="1.8.2"
+HOMEPAGE="http://numpy.scipy.org/"
+DOWNLOAD="http://download.sourceforge.net/project/numpy/NumPy/1.8.2/numpy-1.8.2.tar.gz"
+MD5SUM="dd8eece8f6fda3a13836de4adbafb0cb"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Serban Udrea"
+EMAIL="S.Udrea@gsi.de"
diff --git a/development/numpy-legacy/slack-desc b/development/numpy-legacy/slack-desc
new file mode 100644
index 0000000000..bea8ea1273
--- /dev/null
+++ b/development/numpy-legacy/slack-desc
@@ -0,0 +1,21 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+numpy-legacy: NumPy (a Python extension for scientific computing)
+numpy-legacy:
+numpy-legacy: NumPy is an extension to the Python programming language, adding
+numpy-legacy: support for large, multi-dimensional arrays and matrices along
+numpy-legacy: with a large library of high-level mathematical functions to
+numpy-legacy: operate on these arrays.
+numpy-legacy: This package installs the last version of NumPy known to offer the
+numpy-legacy: compatibility layer with its predecessors numeric and numarray.
+numpy-legacy:
+numpy-legacy: Homepage: http://numpy.scipy.org/
+numpy-legacy:
+numpy-legacy:
+numpy-legacy: