summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2015-11-22 07:04:57 -0500
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-11-28 07:26:17 +0700
commit6b480b2a6cb1b16cd4bfafa5f415758c6746e2f7 (patch)
tree72109d26d51fa000656554a3ea5c3e629c205320
parent93306c05d436a75b53b3297f6a4e5e931a8c4766 (diff)
downloadslackbuilds-6b480b2a6cb1b16cd4bfafa5f415758c6746e2f7.tar.gz
slackbuilds-6b480b2a6cb1b16cd4bfafa5f415758c6746e2f7.tar.xz
system/fsviewer: Fix compile issue.
-rw-r--r--system/fsviewer/fsviewer.SlackBuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/system/fsviewer/fsviewer.SlackBuild b/system/fsviewer/fsviewer.SlackBuild
index ca710c0d98..a28386494d 100644
--- a/system/fsviewer/fsviewer.SlackBuild
+++ b/system/fsviewer/fsviewer.SlackBuild
@@ -61,8 +61,8 @@ if [ "${TITLEBAR:-no}" = "yes" ]; then
patch -p1 < $CWD/titlebar.diff
fi
-LIBS="-lWUtil" \
-CFLAGS="$SLKCFLAGS" \
+LIBS="-lWUtil -lX11 -lm -lXpm" \
+CFLAGS="$SLKCFLAGS -std=gnu89" \
CXXFLAGS="$SLKCFLAGS" \
./configure \
--prefix=/usr \
@@ -73,6 +73,11 @@ CXXFLAGS="$SLKCFLAGS" \
--docdir=/usr/doc/$PRGNAM-$VERSION \
--build=$ARCH-slackware-linux
+# fix broken gobbledegook emitted by autoconf. Life is too short
+# to spend time fixing it 'correctly'.
+GCCMAJVER=$( gcc --version | head -1 | cut -d' ' -f3 | cut -d. -f1 )
+[ "$GCCMAJVER" -ge 5 ] && sed -i 's,-MT *\$@,-M,' */Makefile */*/Makefile
+
make
make install-strip DESTDIR=$PKG