summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2015-05-21 16:11:26 -0400
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-05-24 13:26:29 +0700
commit787b13f4041fa4eb0bef2e0aabb740f0b3979221 (patch)
tree2229c2a60464ff47cf653cfe4ea4a122a03d2772
parent45739b3117feeead1cd5b037edbc800e520d3c9d (diff)
downloadslackbuilds-787b13f4041fa4eb0bef2e0aabb740f0b3979221.tar.gz
slackbuilds-787b13f4041fa4eb0bef2e0aabb740f0b3979221.tar.xz
system/lbzip2: Updated for version 2.5.
-rw-r--r--system/lbzip2/lbzip2.SlackBuild52
-rw-r--r--system/lbzip2/lbzip2.info14
-rw-r--r--system/lbzip2/slack-desc2
3 files changed, 47 insertions, 21 deletions
diff --git a/system/lbzip2/lbzip2.SlackBuild b/system/lbzip2/lbzip2.SlackBuild
index bce8868465..bdf68f7820 100644
--- a/system/lbzip2/lbzip2.SlackBuild
+++ b/system/lbzip2/lbzip2.SlackBuild
@@ -22,8 +22,17 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# Modified by B. Watson <yalhcru@gmail.com>.
+
+# 20150519 bkw:
+# - took over maintenance
+# - bump VERSION to 2.5
+# - add gnulib dependency
+# - make VERSION respect environment
+# - clean up slack-desc
+
PRGNAM=lbzip2
-VERSION=0.23
+VERSION=${VERSION:-2.5}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -59,9 +68,9 @@ set -eu
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/v$VERSION.tar.gz
+cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -69,21 +78,38 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Swap in our CFLAGS
-sed -i "s/-O2/$SLKCFLAGS/" Makefile
+# Upstream says automake-1.14 is required, but our
+# 1.11.5 works fine if we change the version check.
+sed -i '/^AM_INIT_AUTOMAKE/s,1\.14,1.11.5,' configure.ac
+
+sh build-aux/autogen.sh
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux
-# Build
make
+make install-strip DESTDIR=$PKG
-# Manual install
-install -D -s lbzip2 $PKG/usr/bin/lbzip2
-install -D lbzip2.1 $PKG/usr/man/man1/lbzip2.1
-gzip -9 $PKG/usr/man/man1/lbzip2.1
+gzip $PKG/usr/man/man1/$PRGNAM.1
-( cd $PKG/usr/bin ; ln -s lbzip2 lbunzip2 ; ln -s lbzip2 lbzcat )
+# The other man pages just source lbzip2.1. Make them
+# symlinks instead (easier to deal with).
+for i in lbunzip2 lbzcat; do
+ rm -f $PKG/usr/man/man1/$i.1
+ ln -s $PRGNAM.1.gz $PKG/usr/man/man1/$i.1.gz
+done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a ChangeLog GPL-2.0 GPL-3.0 README $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a ALGORITHM AUTHORS COPYING ChangeLog* NEWS README THANKS \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/system/lbzip2/lbzip2.info b/system/lbzip2/lbzip2.info
index af327cb756..d0fa7c19c1 100644
--- a/system/lbzip2/lbzip2.info
+++ b/system/lbzip2/lbzip2.info
@@ -1,10 +1,10 @@
PRGNAM="lbzip2"
-VERSION="0.23"
-HOMEPAGE="http://phptest11.atw.hu/"
-DOWNLOAD="http://lacos.web.elte.hu/pub/lbzip2/lbzip2-0.23.tar.gz"
-MD5SUM="72ab7fbfd3804e4ef1a2030f51ac3825"
+VERSION="2.5"
+HOMEPAGE="http://lacos.hu/"
+DOWNLOAD="https://github.com/kjn/lbzip2/archive/v2.5.tar.gz"
+MD5SUM="288e404f325d9073bdc80759cae30adc"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Erik Hanson"
-EMAIL="erik@slackbuilds.org"
+REQUIRES="gnulib"
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"
diff --git a/system/lbzip2/slack-desc b/system/lbzip2/slack-desc
index 5710909a88..fb3286dd7e 100644
--- a/system/lbzip2/slack-desc
+++ b/system/lbzip2/slack-desc
@@ -6,7 +6,7 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-lbzip2: Lbzip2 (a Pthreads-based parallel bzip2/bunzip2)
+lbzip2: lbzip2 (a pthreads-based parallel bzip2/bunzip2)
lbzip2:
lbzip2: Lbzip2 is a Pthreads-based parallel bzip2/bunzip2 filter passable to
lbzip2: GNU tar with the --use-compress-program option. It isn't restricted