summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2015-04-08 12:32:48 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-04-08 12:32:48 +0700
commit0dda45a171a939d22a0bc56c9e0957781fcd7d74 (patch)
tree7a906088291a9c734d66ffa990cfbdf14a8ad399
parentd25250cb4cdb5865ebaee62eeb77e94cf861d868 (diff)
downloadslackbuilds-0dda45a171a939d22a0bc56c9e0957781fcd7d74.tar.gz
slackbuilds-0dda45a171a939d22a0bc56c9e0957781fcd7d74.tar.xz
python/prompt_toolkit: Added (interactive command lines).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/prompt_toolkit/README3
-rw-r--r--python/prompt_toolkit/prompt_toolkit.SlackBuild85
-rw-r--r--python/prompt_toolkit/prompt_toolkit.info10
-rw-r--r--python/prompt_toolkit/slack-desc19
4 files changed, 117 insertions, 0 deletions
diff --git a/python/prompt_toolkit/README b/python/prompt_toolkit/README
new file mode 100644
index 0000000000..091a6ae71c
--- /dev/null
+++ b/python/prompt_toolkit/README
@@ -0,0 +1,3 @@
+Library for building powerful interactive command lines in Python.
+prompt_toolkit could be a replacement for GNU readline, but it can
+be much more than that.
diff --git a/python/prompt_toolkit/prompt_toolkit.SlackBuild b/python/prompt_toolkit/prompt_toolkit.SlackBuild
new file mode 100644
index 0000000000..36cdfe8455
--- /dev/null
+++ b/python/prompt_toolkit/prompt_toolkit.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for prompt_toolkit
+
+# Copyright 2015 Dimitris Zlatanidis Orestiada, Greece
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=prompt_toolkit
+VERSION=${VERSION:-0.31}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst PKG-INFO $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/python/prompt_toolkit/prompt_toolkit.info b/python/prompt_toolkit/prompt_toolkit.info
new file mode 100644
index 0000000000..9bba65ce65
--- /dev/null
+++ b/python/prompt_toolkit/prompt_toolkit.info
@@ -0,0 +1,10 @@
+PRGNAM="prompt_toolkit"
+VERSION="0.31"
+HOMEPAGE="https://github.com/jonathanslenders/python-prompt-toolkit"
+DOWNLOAD="https://pypi.python.org/packages/source/p/prompt_toolkit/prompt_toolkit-0.31.tar.gz"
+MD5SUM="56c553ba7a07c3f86af14faac26b85fd"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="wcwidth Pygments six"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/python/prompt_toolkit/slack-desc b/python/prompt_toolkit/slack-desc
new file mode 100644
index 0000000000..f415e8f935
--- /dev/null
+++ b/python/prompt_toolkit/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+prompt_toolkit: prompt_toolkit (interactive command lines)
+prompt_toolkit:
+prompt_toolkit: Library for building powerful interactive command lines in Python.
+prompt_toolkit: prompt_toolkit could be a replacement for GNU readline, but it can be
+prompt_toolkit: much more than that.
+prompt_toolkit:
+prompt_toolkit: Homepage: https://github.com/jonathanslenders/python-prompt-toolkit
+prompt_toolkit:
+prompt_toolkit:
+prompt_toolkit:
+prompt_toolkit: