summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Audrius Kažukauskas <audrius@neutrino.lt>2014-10-09 22:26:44 +0300
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-10-11 18:18:43 +0700
commit208917a22e109c34001f90727d969df019e62421 (patch)
treeacbd70f53e747019a5a207c4c5c90f158c49651a
parentece37efc9970a40a8f1e0e42b660d9fe34796a01 (diff)
downloadslackbuilds-208917a22e109c34001f90727d969df019e62421.tar.gz
slackbuilds-208917a22e109c34001f90727d969df019e62421.tar.xz
python/python3: Updated for version 3.4.2.
Signed-off-by: Audrius Kažukauskas <audrius@neutrino.lt>
-rw-r--r--python/python3/patches/python3.no-static-library.diff14
-rw-r--r--python/python3/patches/python3.x86_64.diff60
-rw-r--r--python/python3/python3.SlackBuild4
-rw-r--r--python/python3/python3.info8
4 files changed, 43 insertions, 43 deletions
diff --git a/python/python3/patches/python3.no-static-library.diff b/python/python3/patches/python3.no-static-library.diff
index bbc0e3a817..442373021c 100644
--- a/python/python3/patches/python3.no-static-library.diff
+++ b/python/python3/patches/python3.no-static-library.diff
@@ -1,7 +1,7 @@
-diff -uar Python-3.4.0.orig/Makefile.pre.in Python-3.4.0/Makefile.pre.in
---- Python-3.4.0.orig/Makefile.pre.in 2014-03-17 04:31:30.000000000 +0200
-+++ Python-3.4.0/Makefile.pre.in 2014-03-29 12:27:38.788419450 +0200
-@@ -532,7 +532,7 @@
+diff -uar Python-3.4.2.orig/Makefile.pre.in Python-3.4.2/Makefile.pre.in
+--- Python-3.4.2.orig/Makefile.pre.in 2014-10-08 11:18:14.000000000 +0300
++++ Python-3.4.2/Makefile.pre.in 2014-10-09 21:12:08.504150485 +0300
+@@ -537,7 +537,7 @@
$(RUNSHARED) $(PYTHON_FOR_BUILD) ./Tools/clinic/clinic.py --make
# Build the interpreter
@@ -10,7 +10,7 @@ diff -uar Python-3.4.0.orig/Makefile.pre.in Python-3.4.0/Makefile.pre.in
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Modules/python.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
platform: $(BUILDPYTHON) pybuilddir.txt
-@@ -557,18 +557,6 @@
+@@ -572,18 +572,6 @@
_TCLTK_INCLUDES='$(TCLTK_INCLUDES)' _TCLTK_LIBS='$(TCLTK_LIBS)' \
$(PYTHON_FOR_BUILD) $(srcdir)/setup.py $$quiet build
@@ -29,7 +29,7 @@ diff -uar Python-3.4.0.orig/Makefile.pre.in Python-3.4.0/Makefile.pre.in
libpython$(LDVERSION).so: $(LIBRARY_OBJS)
if test $(INSTSONAME) != $(LDLIBRARY); then \
$(BLDSHARED) -Wl,-h$(INSTSONAME) -o $(INSTSONAME) $(LIBRARY_OBJS) $(MODLIBS) $(SHLIBS) $(LIBC) $(LIBM) $(LDLAST); \
-@@ -658,7 +646,7 @@
+@@ -673,7 +661,7 @@
echo "-----------------------------------------------"; \
fi
@@ -38,7 +38,7 @@ diff -uar Python-3.4.0.orig/Makefile.pre.in Python-3.4.0/Makefile.pre.in
$(LINKCC) $(PY_LDFLAGS) $(LINKFORSHARED) -o $@ Modules/_testembed.o $(BLDLIBRARY) $(LIBS) $(MODLIBS) $(SYSLIBS) $(LDLAST)
############################################################################
-@@ -1309,18 +1297,6 @@
+@@ -1324,18 +1312,6 @@
else true; \
fi; \
done
diff --git a/python/python3/patches/python3.x86_64.diff b/python/python3/patches/python3.x86_64.diff
index 1c4aa6e0ef..0f144044e3 100644
--- a/python/python3/patches/python3.x86_64.diff
+++ b/python/python3/patches/python3.x86_64.diff
@@ -1,7 +1,7 @@
-diff -uar Python-3.4.1.orig/Lib/distutils/command/install.py Python-3.4.1/Lib/distutils/command/install.py
---- Python-3.4.1.orig/Lib/distutils/command/install.py 2014-05-19 08:19:37.000000000 +0300
-+++ Python-3.4.1/Lib/distutils/command/install.py 2014-05-25 16:53:03.729600470 +0300
-@@ -44,15 +44,15 @@
+diff -uar Python-3.4.2.orig/Lib/distutils/command/install.py Python-3.4.2/Lib/distutils/command/install.py
+--- Python-3.4.2.orig/Lib/distutils/command/install.py 2014-10-08 11:18:12.000000000 +0300
++++ Python-3.4.2/Lib/distutils/command/install.py 2014-10-09 21:15:42.705228065 +0300
+@@ -29,15 +29,15 @@
INSTALL_SCHEMES = {
'unix_prefix': {
@@ -21,9 +21,9 @@ diff -uar Python-3.4.1.orig/Lib/distutils/command/install.py Python-3.4.1/Lib/di
'headers': '$base/include/python/$dist_name',
'scripts': '$base/bin',
'data' : '$base',
-diff -uar Python-3.4.1.orig/Lib/distutils/sysconfig.py Python-3.4.1/Lib/distutils/sysconfig.py
---- Python-3.4.1.orig/Lib/distutils/sysconfig.py 2014-05-19 08:19:38.000000000 +0300
-+++ Python-3.4.1/Lib/distutils/sysconfig.py 2014-05-25 16:53:03.729600470 +0300
+diff -uar Python-3.4.2.orig/Lib/distutils/sysconfig.py Python-3.4.2/Lib/distutils/sysconfig.py
+--- Python-3.4.2.orig/Lib/distutils/sysconfig.py 2014-10-08 11:18:12.000000000 +0300
++++ Python-3.4.2/Lib/distutils/sysconfig.py 2014-10-09 21:15:42.705228065 +0300
@@ -142,7 +142,7 @@
if os.name == "posix":
@@ -33,9 +33,9 @@ diff -uar Python-3.4.1.orig/Lib/distutils/sysconfig.py Python-3.4.1/Lib/distutil
if standard_lib:
return libpython
else:
-diff -uar Python-3.4.1.orig/Lib/site.py Python-3.4.1/Lib/site.py
---- Python-3.4.1.orig/Lib/site.py 2014-05-19 08:19:38.000000000 +0300
-+++ Python-3.4.1/Lib/site.py 2014-05-25 16:53:03.729600470 +0300
+diff -uar Python-3.4.2.orig/Lib/site.py Python-3.4.2/Lib/site.py
+--- Python-3.4.2.orig/Lib/site.py 2014-10-08 11:18:12.000000000 +0300
++++ Python-3.4.2/Lib/site.py 2014-10-09 21:15:42.706228092 +0300
@@ -304,13 +304,13 @@
seen.add(prefix)
@@ -52,9 +52,9 @@ diff -uar Python-3.4.1.orig/Lib/site.py Python-3.4.1/Lib/site.py
if sys.platform == "darwin":
# for framework builds *only* we add the standard Apple
# locations.
-diff -uar Python-3.4.1.orig/Lib/sysconfig.py Python-3.4.1/Lib/sysconfig.py
---- Python-3.4.1.orig/Lib/sysconfig.py 2014-05-19 08:19:38.000000000 +0300
-+++ Python-3.4.1/Lib/sysconfig.py 2014-05-25 16:53:03.729600470 +0300
+diff -uar Python-3.4.2.orig/Lib/sysconfig.py Python-3.4.2/Lib/sysconfig.py
+--- Python-3.4.2.orig/Lib/sysconfig.py 2014-10-08 11:18:12.000000000 +0300
++++ Python-3.4.2/Lib/sysconfig.py 2014-10-09 21:15:42.706228092 +0300
@@ -20,10 +20,10 @@
_INSTALL_SCHEMES = {
@@ -100,10 +100,10 @@ diff -uar Python-3.4.1.orig/Lib/sysconfig.py Python-3.4.1/Lib/sysconfig.py
'include': '{userbase}/include/python{py_version_short}',
'scripts': '{userbase}/bin',
'data': '{userbase}',
-diff -uar Python-3.4.1.orig/Makefile.pre.in Python-3.4.1/Makefile.pre.in
---- Python-3.4.1.orig/Makefile.pre.in 2014-05-19 08:19:39.000000000 +0300
-+++ Python-3.4.1/Makefile.pre.in 2014-05-25 16:53:03.729600470 +0300
-@@ -115,7 +115,7 @@
+diff -uar Python-3.4.2.orig/Makefile.pre.in Python-3.4.2/Makefile.pre.in
+--- Python-3.4.2.orig/Makefile.pre.in 2014-10-08 11:18:14.000000000 +0300
++++ Python-3.4.2/Makefile.pre.in 2014-10-09 21:15:42.707228121 +0300
+@@ -120,7 +120,7 @@
MANDIR= @mandir@
INCLUDEDIR= @includedir@
CONFINCLUDEDIR= $(exec_prefix)/include
@@ -112,9 +112,9 @@ diff -uar Python-3.4.1.orig/Makefile.pre.in Python-3.4.1/Makefile.pre.in
ABIFLAGS= @ABIFLAGS@
# Detailed destination directories
-diff -uar Python-3.4.1.orig/Modules/getpath.c Python-3.4.1/Modules/getpath.c
---- Python-3.4.1.orig/Modules/getpath.c 2014-05-19 08:19:39.000000000 +0300
-+++ Python-3.4.1/Modules/getpath.c 2014-05-25 16:53:03.730600494 +0300
+diff -uar Python-3.4.2.orig/Modules/getpath.c Python-3.4.2/Modules/getpath.c
+--- Python-3.4.2.orig/Modules/getpath.c 2014-10-08 11:18:15.000000000 +0300
++++ Python-3.4.2/Modules/getpath.c 2014-10-09 21:15:42.707228121 +0300
@@ -118,8 +118,8 @@
#endif
@@ -153,10 +153,10 @@ diff -uar Python-3.4.1.orig/Modules/getpath.c Python-3.4.1/Modules/getpath.c
}
/* If we found EXEC_PREFIX do *not* reduce it! (Yet.) */
-diff -uar Python-3.4.1.orig/configure Python-3.4.1/configure
---- Python-3.4.1.orig/configure 2014-05-19 08:19:40.000000000 +0300
-+++ Python-3.4.1/configure 2014-05-25 16:53:03.731600519 +0300
-@@ -13930,7 +13930,7 @@
+diff -uar Python-3.4.2.orig/configure Python-3.4.2/configure
+--- Python-3.4.2.orig/configure 2014-10-08 11:18:16.000000000 +0300
++++ Python-3.4.2/configure 2014-10-09 21:15:42.711228262 +0300
+@@ -13948,7 +13948,7 @@
$as_echo "$LDVERSION" >&6; }
@@ -165,10 +165,10 @@ diff -uar Python-3.4.1.orig/configure Python-3.4.1/configure
# Check whether right shifting a negative integer extends the sign bit
-diff -uar Python-3.4.1.orig/setup.py Python-3.4.1/setup.py
---- Python-3.4.1.orig/setup.py 2014-05-19 08:19:40.000000000 +0300
-+++ Python-3.4.1/setup.py 2014-05-25 16:53:03.732600546 +0300
-@@ -445,7 +445,7 @@
+diff -uar Python-3.4.2.orig/setup.py Python-3.4.2/setup.py
+--- Python-3.4.2.orig/setup.py 2014-10-08 11:18:16.000000000 +0300
++++ Python-3.4.2/setup.py 2014-10-09 21:15:42.712228293 +0300
+@@ -451,7 +451,7 @@
# directories (i.e. '.' and 'Include') must be first. See issue
# 10520.
if not cross_compiling:
@@ -177,7 +177,7 @@ diff -uar Python-3.4.1.orig/setup.py Python-3.4.1/setup.py
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
# only change this for cross builds for 3.3, issues on Mageia
if cross_compiling:
-@@ -722,11 +722,11 @@
+@@ -730,11 +730,11 @@
elif curses_library:
readline_libs.append(curses_library)
elif self.compiler.find_library_file(lib_dirs +
@@ -191,7 +191,7 @@ diff -uar Python-3.4.1.orig/setup.py Python-3.4.1/setup.py
extra_link_args=readline_extra_link_args,
libraries=readline_libs) )
else:
-@@ -763,8 +763,8 @@
+@@ -771,8 +771,8 @@
if krb5_h:
ssl_incs += krb5_h
ssl_libs = find_library_file(self.compiler, 'ssl',lib_dirs,
diff --git a/python/python3/python3.SlackBuild b/python/python3/python3.SlackBuild
index 02c865df24..4a49154681 100644
--- a/python/python3/python3.SlackBuild
+++ b/python/python3/python3.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=python3
-VERSION=${VERSION:-3.4.1}
+VERSION=${VERSION:-3.4.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -89,7 +89,7 @@ find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
./configure \
--prefix=/usr \
diff --git a/python/python3/python3.info b/python/python3/python3.info
index d581df6a2f..8c55727427 100644
--- a/python/python3/python3.info
+++ b/python/python3/python3.info
@@ -1,8 +1,8 @@
PRGNAM="python3"
-VERSION="3.4.1"
-HOMEPAGE="http://python.org/"
-DOWNLOAD="https://python.org/ftp/python/3.4.1/Python-3.4.1.tar.xz"
-MD5SUM="6cafc183b4106476dd73d5738d7f616a"
+VERSION="3.4.2"
+HOMEPAGE="https://www.python.org/"
+DOWNLOAD="https://www.python.org/ftp/python/3.4.2/Python-3.4.2.tar.xz"
+MD5SUM="36fc7327c02c6f12fa24fc9ba78039e3"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""