summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Donald Cooley <dfc@warpmail.net>2014-10-12 11:35:07 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-10-12 11:35:07 +0700
commit22141e8f2519f09a153c6c1280d26c355a1fd278 (patch)
tree395d928fc0ab292c67379d52a5cb8be1b16a56c7
parent8e79325562a7a97d61b78512cf40c345e8c87cc9 (diff)
downloadslackbuilds-22141e8f2519f09a153c6c1280d26c355a1fd278.tar.gz
slackbuilds-22141e8f2519f09a153c6c1280d26c355a1fd278.tar.xz
system/trash-cli: Updated for version 0.12.9.14.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--system/trash-cli/slack-desc20
-rw-r--r--system/trash-cli/trash-cli.SlackBuild18
-rw-r--r--system/trash-cli/trash-cli.info8
3 files changed, 25 insertions, 21 deletions
diff --git a/system/trash-cli/slack-desc b/system/trash-cli/slack-desc
index 27e2e26ee8..a6594df733 100644
--- a/system/trash-cli/slack-desc
+++ b/system/trash-cli/slack-desc
@@ -6,14 +6,14 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-trash-cli: trash-cli (command line interface to the FreeDesktop.org trashcan)
-trash-cli:
-trash-cli: * Command line interface compatible with the rm command. You can
-trash-cli: alias rm with trash.
-trash-cli: * Remembers original path, deletion time and file permissions of
-trash-cli: each trashed file.
-trash-cli: * Compatible with the KDE trash.
-trash-cli: * Implements the FreeDesktop.org Trash Specification
-trash-cli: * Works with volume other than the home volume (e.g. USB pen or
-trash-cli: another partition).
+trash-cli: trash-cli (command line interface to the FreeDesktop.org trash)
trash-cli:
+trash-cli: trash-cli trashes files recording the original path, deletion date,
+trash-cli: and permissions. It uses the same trashcan used by KDE, GNOME, and
+trash-cli: XFCE, but you can invoke it from the command line (and scripts).
+trash-cli: It provides these commands:
+trash-cli: trash-put trashes files and directories.
+trash-cli: trash-empty empty the trashcan(s).
+trash-cli: trash-list list trashed files.
+trash-cli: trash-restore restore a trashed file.
+trash-cli: trash-rm remove individual files from trash can.
diff --git a/system/trash-cli/trash-cli.SlackBuild b/system/trash-cli/trash-cli.SlackBuild
index 0aaa0132c7..8a3d03f900 100644
--- a/system/trash-cli/trash-cli.SlackBuild
+++ b/system/trash-cli/trash-cli.SlackBuild
@@ -22,13 +22,13 @@
# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+# Updated and reworked by Donald Cooley <dfc@warpmail.net>
+
PRGNAM=trash-cli
-VERSION=${VERSION:-0.11.3_r315}
+VERSION=${VERSION:-0.12.9.14}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-SRCVER=$(printf $VERSION | tr _ -)
-
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
@@ -62,22 +62,26 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$SRCVER
-tar xvf $CWD/$PRGNAM-$SRCVER.tar.gz
-cd $PRGNAM-$SRCVER
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/$VERSION.tar.gz
+cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --root=$PKG
+mkdir $PKG/usr/man
+mv $PKG/usr/share/man/ $PKG/usr/
+rmdir $PKG/usr/share
+
find $PKG/usr/man -type f -exec gzip -9 {} \;
for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS COPYING HISTORY.txt INSTALL.txt PKG-INFO README.txt THANKS \
+cp -a COPYING CREDITS.txt DONE.txt HISTORY.txt MANIFEST.in README.rst TODO.txt bugs.txt requirements-dev.txt \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
cat $CWD/README > $PKG/usr/doc/$PRGNAM-$VERSION/README$TAG
diff --git a/system/trash-cli/trash-cli.info b/system/trash-cli/trash-cli.info
index 278ad4c90a..31e9dcc8b4 100644
--- a/system/trash-cli/trash-cli.info
+++ b/system/trash-cli/trash-cli.info
@@ -1,8 +1,8 @@
PRGNAM="trash-cli"
-VERSION="0.11.3_r315"
-HOMEPAGE="https://code.google.com/p/trash-cli/"
-DOWNLOAD="http://trash-cli.googlecode.com/files/trash-cli-0.11.3-r315.tar.gz"
-MD5SUM="00654c149108fc4c522b5b008e9b8468"
+VERSION="0.12.9.14"
+HOMEPAGE="https://github.com/andreafrancia/trash-cli"
+DOWNLOAD="https://github.com/andreafrancia/trash-cli/archive/0.12.9.14.tar.gz"
+MD5SUM="53d6b696b7241b89216d520db7aa4c54"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""