summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Thomas Morper <thomas@beingboiled.info>2012-09-10 18:31:31 +0200
committer Robby Workman <rworkman@slackbuilds.org>2012-09-10 16:35:39 -0500
commit2363cc0c653f736f138d9930bcaf7f40824e3b48 (patch)
tree2ad693af3f17929c5f129e4151fc356040735ddd
parent787bcff8069e23f11ebb5f2ec4cb640ab1734223 (diff)
downloadslackbuilds-2363cc0c653f736f138d9930bcaf7f40824e3b48.tar.gz
slackbuilds-2363cc0c653f736f138d9930bcaf7f40824e3b48.tar.xz
network/exim: Fixed argument and linked to liblber when using LDAP.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--network/exim/README2
-rw-r--r--network/exim/exim.Makefile2
-rw-r--r--network/exim/exim.SlackBuild4
3 files changed, 4 insertions, 4 deletions
diff --git a/network/exim/README b/network/exim/README
index 42cf5ce76b..58c1319e80 100644
--- a/network/exim/README
+++ b/network/exim/README
@@ -32,5 +32,5 @@ but you can enable them easily by passing the directives
on the command line when calling this script, e.g.
LOOKUP_LDAP=yes LOOKUP_SQLITE=yes \
- LOOKUP_MYSQL=yes LOOKUP_POSTGRES=yes \
+ LOOKUP_MYSQL=yes LOOKUP_PGSQL=yes \
sh exim.SlackBuild
diff --git a/network/exim/exim.Makefile b/network/exim/exim.Makefile
index 97c90e5b59..132ee5eebf 100644
--- a/network/exim/exim.Makefile
+++ b/network/exim/exim.Makefile
@@ -367,7 +367,7 @@ PCRE_CONFIG=yes
# ...or just enable your favourite lookups and let GNUmake handle the rest
ifeq ($(LOOKUP_LDAP),yes)
-LOOKUP_LIBS+=-lldap
+LOOKUP_LIBS+=-lldap -llber
endif
ifeq ($(LOOKUP_MYSQL),yes)
diff --git a/network/exim/exim.SlackBuild b/network/exim/exim.SlackBuild
index ad974a6555..2d8e4b4e50 100644
--- a/network/exim/exim.SlackBuild
+++ b/network/exim/exim.SlackBuild
@@ -25,7 +25,7 @@
PRGNAM=exim
VERSION=${VERSION:-4.80}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -81,7 +81,7 @@ find . \
# on the command line when calling this script, e.g.
#
# LOOKUP_LDAP=yes LOOKUP_SQLITE=yes \
-# LOOKUP_MYSQL=yes LOOKUP_POSTGRES=yes \
+# LOOKUP_MYSQL=yes LOOKUP_PGSQL=yes \
# sh exim.SlackBuild
#
cat $CWD/exim.Makefile > Local/Makefile