summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2014-10-10 21:36:46 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-10-11 00:14:51 +0700
commit4955b97caf189be065b5f76318c3b0613032e8d6 (patch)
treeb646b5f33a9334f8b161eab7760c559ab0a2c310
parentb6c0e909de34949d6f51d880d4f209f8796712e1 (diff)
downloadslackbuilds-4955b97caf189be065b5f76318c3b0613032e8d6.tar.gz
slackbuilds-4955b97caf189be065b5f76318c3b0613032e8d6.tar.xz
games/znake: Added (Snake game clone).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--games/znake/README3
-rw-r--r--games/znake/doinst.sh3
-rw-r--r--games/znake/slack-desc19
-rw-r--r--games/znake/znake.SlackBuild89
-rw-r--r--games/znake/znake.info10
5 files changed, 124 insertions, 0 deletions
diff --git a/games/znake/README b/games/znake/README
new file mode 100644
index 0000000000..cefa345a49
--- /dev/null
+++ b/games/znake/README
@@ -0,0 +1,3 @@
+Just a simple colorful clone of the famous game "Snake" but with an
+extraordinary feature. Do you know the Soviet Russia meme by Smirnoff?
+Try to imagine if you don't eat the food but the food eats you.
diff --git a/games/znake/doinst.sh b/games/znake/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/games/znake/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/games/znake/slack-desc b/games/znake/slack-desc
new file mode 100644
index 0000000000..cb02a5e909
--- /dev/null
+++ b/games/znake/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+znake: znake (Snake game clone)
+znake:
+znake: Just a simple colorful clone of the famous game "Snake" but with an
+znake: an extraordinary feature. Do you know the Soviet Russia meme by
+znake: Smirnoff? Try to imagine if you don't eat the food but the food eats
+znake: you.
+znake:
+znake: Homepage: https://sourceforge.net/projects/znake-ulven/
+znake:
+znake:
+znake:
diff --git a/games/znake/znake.SlackBuild b/games/znake/znake.SlackBuild
new file mode 100644
index 0000000000..88d8826d78
--- /dev/null
+++ b/games/znake/znake.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/sh
+
+# Slackware build script for znake
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=znake
+VERSION=${VERSION:-1.18}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+mkdir -p $PKG/usr/bin
+sed -i "s/usr\/local/usr/" src/Makefile
+make
+make install PREFIX=$PKG/usr/bin/
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHOR COPYING ChangeLog $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/games/znake/znake.info b/games/znake/znake.info
new file mode 100644
index 0000000000..1c679ac52e
--- /dev/null
+++ b/games/znake/znake.info
@@ -0,0 +1,10 @@
+PRGNAM="znake"
+VERSION="1.18"
+HOMEPAGE="https://sourceforge.net/projects/znake-ulven/"
+DOWNLOAD="http://sourceforge.net/projects/znake-ulven/files/znake-1.18/znake-1.18.tar.gz"
+MD5SUM="d98ddd294ad0d6f2a558f9a8bcb9525d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"