summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Matteo Bernardini <ponce@slackbuilds.org>2014-09-02 16:13:04 +0200
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-09-05 23:21:10 +0700
commit4b20e518b6a4dc99b2efd44136bc7bb9118b73ad (patch)
tree9c11adb70b49e40301414414c1609901490b28f0
parentd4682fa8524e7ec6c0e2f150aac9ba8ab450fe0e (diff)
downloadslackbuilds-4b20e518b6a4dc99b2efd44136bc7bb9118b73ad.tar.gz
slackbuilds-4b20e518b6a4dc99b2efd44136bc7bb9118b73ad.tar.xz
desktop/lxde-common: Updated for version 0.5.6.
Signed-off-by: Matteo Bernardini <ponce@slackbuilds.org>
-rw-r--r--desktop/lxde-common/config/panel8
-rw-r--r--desktop/lxde-common/doinst.sh2
-rw-r--r--desktop/lxde-common/lxde-common.SlackBuild18
-rw-r--r--desktop/lxde-common/lxde-common.info6
4 files changed, 20 insertions, 14 deletions
diff --git a/desktop/lxde-common/config/panel b/desktop/lxde-common/config/panel
index 0ff574412e..c2c4d8846c 100644
--- a/desktop/lxde-common/config/panel
+++ b/desktop/lxde-common/config/panel
@@ -53,13 +53,13 @@ Plugin {
id=pcmanfm.desktop
}
Button {
- id=mozilla-firefox.desktop
+ id=menu://applications/Internet/mozilla-firefox.desktop
}
Button {
- id=mozilla-thunderbird.desktop
+ id=menu://applications/Internet/mozilla-thunderbird.desktop
}
Button {
- id=lxterminal.desktop
+ id=menu://applications/System/lxterminal.desktop
}
}
}
@@ -130,7 +130,7 @@ Plugin {
type = netstatus
Config {
iface=eth0
- configtool=network-admin --configure %i
+ configtool=netconfig
}
}
diff --git a/desktop/lxde-common/doinst.sh b/desktop/lxde-common/doinst.sh
index 98f0e082df..558bc15c75 100644
--- a/desktop/lxde-common/doinst.sh
+++ b/desktop/lxde-common/doinst.sh
@@ -14,6 +14,8 @@ config() {
config etc/xdg/lxsession/LXDE/desktop.conf.new
config etc/xdg/lxsession/LXDE/autostart.new
config etc/xdg/pcmanfm/LXDE/pcmanfm.conf.new
+config etc/xdg/lxpanel/LXDE/panels/panel.new
+config etc/xdg/lxpanel/LXDE/config.new
if [ -x /usr/bin/update-desktop-database ]; then
/usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
diff --git a/desktop/lxde-common/lxde-common.SlackBuild b/desktop/lxde-common/lxde-common.SlackBuild
index 66e30884fd..b562be4b26 100644
--- a/desktop/lxde-common/lxde-common.SlackBuild
+++ b/desktop/lxde-common/lxde-common.SlackBuild
@@ -50,6 +50,8 @@
# 0.5.5-4: 14/nov/2013 by Matteo Bernardini <ponce@slackbuilds.org>
# * Removed the option to switch to root completely
# (see http://bit.ly/no-more-su-pcmanfm)
+# 0.5.6-1: 02/sep/2014 by Matteo Bernardini <ponce@slackbuilds.org>
+# * Update.
#
# Run 'sh lxde-common.SlackBuild' to build a Slackware package.
# The package is created in /tmp .
@@ -58,8 +60,8 @@
# -----------------------------------------------------------------------------
PRGNAM=lxde-common
-VERSION=${VERSION:-0.5.5}
-BUILD=${BUILD:-4}
+VERSION=${VERSION:-0.5.6}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -108,7 +110,7 @@ find -L . \
-exec chmod 644 {} \;
# look for a renamed file
-sed -i -e 's|lxde\.conf|LXDE.conf|' Makefile.am
+sed -i -e 's|lxde\.conf|LXDE.conf|' Makefile.am || exit 1
sh autogen.sh || true
@@ -142,11 +144,11 @@ mkdir -p $PKG/usr/share/apps/kdm/sessions
for i in $(ls ../../../xsessions/*.desktop) ; do ln -sf $i ; done )
# patch desktop.conf to use the Tango icon theme
-sed -i -e 's#nuoveXT2#Tango#' $PKG/etc/xdg/lxsession/LXDE/desktop.conf
+sed -i -e 's#nuoveXT2#Tango#' $PKG/etc/xdg/lxsession/LXDE/desktop.conf || exit 1
# this option is deprecated upstream
sed -i -e 's#^su_cmd.*$##' \
- $PKG/etc/xdg/pcmanfm/LXDE/pcmanfm.conf
+ $PKG/etc/xdg/pcmanfm/LXDE/pcmanfm.conf || exit 1
# preserve modified config files
mv $PKG/etc/xdg/lxsession/LXDE/desktop.conf \
@@ -157,10 +159,12 @@ mv $PKG/etc/xdg/pcmanfm/LXDE/pcmanfm.conf \
$PKG/etc/xdg/pcmanfm/LXDE/pcmanfm.conf.new
# use some sane defaults for lxpanel
+rm -fr $PKG/etc/xdg/lxpanel/profile
+mkdir -p $PKG/etc/xdg/lxpanel/LXDE/panels
install -m 0644 $CWD/config/panel \
- $PKG/usr/share/lxpanel/profile/LXDE/panels/panel
+ $PKG/etc/xdg/lxpanel/LXDE/panels/panel.new
install -m 0644 $CWD/config/config \
- $PKG/usr/share/lxpanel/profile/LXDE/config
+ $PKG/etc/xdg/lxpanel/LXDE/config.new
# add documentation:
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/desktop/lxde-common/lxde-common.info b/desktop/lxde-common/lxde-common.info
index 08d606fa01..edb4482e54 100644
--- a/desktop/lxde-common/lxde-common.info
+++ b/desktop/lxde-common/lxde-common.info
@@ -1,8 +1,8 @@
PRGNAM="lxde-common"
-VERSION="0.5.5"
+VERSION="0.5.6"
HOMEPAGE="http://www.lxde.org/"
-DOWNLOAD="http://downloads.sourceforge.net/lxde/lxde-common-0.5.5.tar.gz"
-MD5SUM="e51a6b2a815a89fda1f497b509465a97"
+DOWNLOAD="http://downloads.sourceforge.net/lxde/lxde-common-0.5.6.tar.xz"
+MD5SUM="259b4a2db50117e632e34912251cfcb9"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""