summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2014-10-21 22:43:54 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-10-22 08:33:55 +0700
commit775386cee456962cde3c54e51984510e99ed428b (patch)
tree5ceeb9a2e7a25caa7a931177f4414a0aabca38ea
parentefb267ab9c721966778f9b3871f9df982009cd1d (diff)
downloadslackbuilds-775386cee.tar.gz
slackbuilds-775386cee.tar.xz
development/wheel: Added (built-package format).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--development/wheel/README4
-rw-r--r--development/wheel/doinst.sh3
-rw-r--r--development/wheel/slack-desc19
-rw-r--r--development/wheel/wheel.SlackBuild86
-rw-r--r--development/wheel/wheel.info10
5 files changed, 122 insertions, 0 deletions
diff --git a/development/wheel/README b/development/wheel/README
new file mode 100644
index 0000000000..afc6d2862f
--- /dev/null
+++ b/development/wheel/README
@@ -0,0 +1,4 @@
+A wheel is a ZIP-format archive with a specially formatted
+filename and the .whl extension. It is designed to contain
+all the files for a PEP 376 compatible install in a way
+that is very close to the on-disk format.
diff --git a/development/wheel/doinst.sh b/development/wheel/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/development/wheel/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/development/wheel/slack-desc b/development/wheel/slack-desc
new file mode 100644
index 0000000000..3c0ab68ef2
--- /dev/null
+++ b/development/wheel/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+wheel: wheel (A built-package format for Python)
+wheel:
+wheel: A wheel is a ZIP-format archive with a specially formatted filename
+wheel: and the .whl extension. It is designed to contain all the files for
+wheel: a PEP 376 compatible install in a way that is very close to the
+wheel: on-disk format.
+wheel:
+wheel: Homepage: http://bitbucket.org/pypa/wheel/
+wheel:
+wheel:
+wheel:
diff --git a/development/wheel/wheel.SlackBuild b/development/wheel/wheel.SlackBuild
new file mode 100644
index 0000000000..f3bc985acc
--- /dev/null
+++ b/development/wheel/wheel.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+
+# Slackware build script for wheel
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=wheel
+VERSION=${VERSION:-0.24.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a *.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/wheel/wheel.info b/development/wheel/wheel.info
new file mode 100644
index 0000000000..ed86235b09
--- /dev/null
+++ b/development/wheel/wheel.info
@@ -0,0 +1,10 @@
+PRGNAM="wheel"
+VERSION="0.24.0"
+HOMEPAGE="http://bitbucket.org/pypa/wheel/"
+DOWNLOAD="https://pypi.python.org/packages/source/w/wheel/wheel-0.24.0.tar.gz"
+MD5SUM="3b0d66f0d127ea8befaa5d11453107fd"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"