summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Ryan P.C. McQuen <ryan.q@linux.com>2015-01-25 09:44:42 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-01-27 06:42:41 +0700
commit89cda4f7dab9d8ceba60c948d8475ed896f39277 (patch)
tree3fa9ed37c5c83ad99d7378a44f53dfa248249091
parentd4ff4587e6e7af4db0fb537f67f1ff3713902bef (diff)
downloadslackbuilds-89cda4f7d.tar.gz
slackbuilds-89cda4f7d.tar.xz
libraries/qutepart: Added (core editor component).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--libraries/qutepart/README1
-rw-r--r--libraries/qutepart/qutepart.SlackBuild89
-rw-r--r--libraries/qutepart/qutepart.info10
-rw-r--r--libraries/qutepart/slack-desc19
4 files changed, 119 insertions, 0 deletions
diff --git a/libraries/qutepart/README b/libraries/qutepart/README
new file mode 100644
index 0000000000..2b1226eb77
--- /dev/null
+++ b/libraries/qutepart/README
@@ -0,0 +1 @@
+Code editor component for PyQt and PySide.
diff --git a/libraries/qutepart/qutepart.SlackBuild b/libraries/qutepart/qutepart.SlackBuild
new file mode 100644
index 0000000000..faa978c04d
--- /dev/null
+++ b/libraries/qutepart/qutepart.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/sh
+# Slackware build script for qutepart
+# Ryan P.C. McQuen | Everett, WA | ryan.q@linux.com
+
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version, with the following exception:
+# the text of the GPL license may be omitted.
+
+# This program is distributed in the hope that it will be useful, but
+# without any warranty; without even the implied warranty of
+# merchantability or fitness for a particular purpose. Compiling,
+# interpreting, executing or merely reading the text of the program
+# may result in lapses of consciousness and/or very being, up to and
+# including the end of all existence and the Universe as we know it.
+# See the GNU General Public License for more details.
+
+# You may have received a copy of the GNU General Public License along
+# with this program (most likely, a file named COPYING). If not, see
+# <http://www.gnu.org/licenses/>.
+
+PRGNAM=qutepart
+VERSION=${VERSION:-2.1.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+DOCS="ChangeLog LICENSE README.md doc/"
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+if [ -e $CWD/v$VERSION.tar.gz ]; then
+ tar xvf $CWD/v$VERSION.tar.gz
+else
+ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+fi
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/qutepart/qutepart.info b/libraries/qutepart/qutepart.info
new file mode 100644
index 0000000000..34c37cd335
--- /dev/null
+++ b/libraries/qutepart/qutepart.info
@@ -0,0 +1,10 @@
+PRGNAM="qutepart"
+VERSION="2.1.2"
+HOMEPAGE="https://github.com/hlamer/qutepart"
+DOWNLOAD="https://github.com/hlamer/qutepart/archive/v2.1.2.tar.gz"
+MD5SUM="650499c5c73d93ece9c9bf17cab4436e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Ryan P.C. McQuen"
+EMAIL="ryan.q@linux.com"
diff --git a/libraries/qutepart/slack-desc b/libraries/qutepart/slack-desc
new file mode 100644
index 0000000000..f09565c174
--- /dev/null
+++ b/libraries/qutepart/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+qutepart: qutepart (code editor component)
+qutepart:
+qutepart: Code editor component for PyQt and PySide.
+qutepart:
+qutepart:
+qutepart:
+qutepart:
+qutepart:
+qutepart: https://github.com/hlamer/qutepart
+qutepart:
+qutepart: