summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <bosth@alumni.sfu.ca>2014-12-11 21:58:57 -0800
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-12-13 10:35:44 +0700
commita191ee7a224be315f27e4f8b165e4d280dc28c80 (patch)
tree26be3aaccb5dbd0c7d31c2ac6b125b0bf58527db
parent9cde5d83dba4018eb82502061c2066f5b4637595 (diff)
downloadslackbuilds-a191ee7a224be315f27e4f8b165e4d280dc28c80.tar.gz
slackbuilds-a191ee7a224be315f27e4f8b165e4d280dc28c80.tar.xz
gis/Shapely: Prevent creation of unnecessary .pxi file in package.
Signed-off-by: Benjamin Trigona-Harany <bosth@alumni.sfu.ca>
-rw-r--r--gis/Shapely/Shapely.SlackBuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/gis/Shapely/Shapely.SlackBuild b/gis/Shapely/Shapely.SlackBuild
index 86ff49cd6f..82c0dc046d 100644
--- a/gis/Shapely/Shapely.SlackBuild
+++ b/gis/Shapely/Shapely.SlackBuild
@@ -24,7 +24,7 @@
PRGNAM=Shapely
VERSION=${VERSION:-1.5.1}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -69,6 +69,9 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
+# remove unnecessary .pxi file
+sed -i "s/data_files\s*=.*/data_files = []/g" setup.py
+
python setup.py install --root=$PKG
find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \