summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2015-09-30 08:28:00 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-10-01 20:09:42 +0700
commitbd54b85517a424ca13c4688f6ed75dfd0724cb89 (patch)
tree07f889607ba81708308be4fdda79c5d14471e7ea
parentccacaac11688407224af7ffff3ad3a4c0d6d7977 (diff)
downloadslackbuilds-bd54b85517a424ca13c4688f6ed75dfd0724cb89.tar.gz
slackbuilds-bd54b85517a424ca13c4688f6ed75dfd0724cb89.tar.xz
network/python-onedrive: Added (CLI interface for MS OneDrive).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--network/python-onedrive/README3
-rw-r--r--network/python-onedrive/python-onedrive.SlackBuild85
-rw-r--r--network/python-onedrive/python-onedrive.info10
-rw-r--r--network/python-onedrive/slack-desc19
4 files changed, 117 insertions, 0 deletions
diff --git a/network/python-onedrive/README b/network/python-onedrive/README
new file mode 100644
index 0000000000..769adb38b5
--- /dev/null
+++ b/network/python-onedrive/README
@@ -0,0 +1,3 @@
+Python and command-line interface for MS OneDrive (formerly known as SkyDrive) API v5.0.
+
+Optional dependencies: PyYAML, python-requests
diff --git a/network/python-onedrive/python-onedrive.SlackBuild b/network/python-onedrive/python-onedrive.SlackBuild
new file mode 100644
index 0000000000..c0bc372edb
--- /dev/null
+++ b/network/python-onedrive/python-onedrive.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for python-onedrive
+
+# Copyright 2015 Dimitris Zlatanidis Orestiada, Greece
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=python-onedrive
+VERSION=${VERSION:-15.9.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.txt $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/network/python-onedrive/python-onedrive.info b/network/python-onedrive/python-onedrive.info
new file mode 100644
index 0000000000..5ba00160c2
--- /dev/null
+++ b/network/python-onedrive/python-onedrive.info
@@ -0,0 +1,10 @@
+PRGNAM="python-onedrive"
+VERSION="15.9.2"
+HOMEPAGE="https://github.com/mk-fg/python-onedrive"
+DOWNLOAD="https://pypi.python.org/packages/source/p/python-onedrive/python-onedrive-15.9.2.tar.gz"
+MD5SUM="5f44e0f17c476b7991fd5fee6c73fe6d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/network/python-onedrive/slack-desc b/network/python-onedrive/slack-desc
new file mode 100644
index 0000000000..e1a24d85ef
--- /dev/null
+++ b/network/python-onedrive/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python-onedrive: python-onedrive (CLI interface for MS OneDrive)
+python-onedrive:
+python-onedrive: Python and command-line interface for Microsoft LiveConnect
+python-onedrive: OneDrive REST API v5.0 (formerly known as SkyDrive).
+python-onedrive:
+python-onedrive: Homepage: https://github.com/mk-fg/python-onedrive
+python-onedrive:
+python-onedrive:
+python-onedrive:
+python-onedrive:
+python-onedrive: