summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Thomas Morper <thomas@beingboiled.info>2015-07-28 23:11:12 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-07-28 23:12:03 +0700
commitc6f8078c1b8c92b345bec3617007205e56521496 (patch)
treed2c05c7e9f311555267286701fa05d1f822673c9
parent1c0a9d208699e93a07b6d203fe1d306f3263fff7 (diff)
downloadslackbuilds-c6f8078c1.tar.gz
slackbuilds-c6f8078c1.tar.xz
network/exim: Updated for version 4.86.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--network/exim/exim.Makefile38
-rw-r--r--network/exim/exim.SlackBuild12
-rw-r--r--network/exim/exim.info6
3 files changed, 36 insertions, 20 deletions
diff --git a/network/exim/exim.Makefile b/network/exim/exim.Makefile
index bf195578f3..3cacc2d8c4 100644
--- a/network/exim/exim.Makefile
+++ b/network/exim/exim.Makefile
@@ -336,7 +336,7 @@ LDAP_LIB_TYPE=OPENLDAP2
#------------------------------------------------------------------------------
-# The PCRE library is required for exim. There is no longer an embedded
+# The PCRE library is required for Exim. There is no longer an embedded
# version of the PCRE library included with the source code, instead you
# must use a system library or build your own copy of PCRE.
# In either case you must specify the library link info here. If the
@@ -441,6 +441,7 @@ WITH_CONTENT_SCAN=yes
# By default, Exim has support for checking the AD bit in a DNS response, to
# determine if DNSSEC validation was successful. If your system libraries
# do not support that bit, then set DISABLE_DNSSEC to "yes"
+# Note: Enabling EXPERIMENTAL_DANE unconditionally overrides this setting.
# DISABLE_DNSSEC=yes
@@ -502,16 +503,22 @@ WITH_CONTENT_SCAN=yes
# Uncomment the following line to enable Experimental Proxy Protocol
# EXPERIMENTAL_PROXY=yes
-# Uncomment the following line to enable support for checking certiticate
+# Uncomment the following line to enable support for checking certificate
# ownership
# EXPERIMENTAL_CERTNAMES=yes
-# Uncomment the following line to add DSN support
-# EXPERIMENTAL_DSN=yes
-
# Uncomment the following line to add DANE support
+# Note: Enabling this unconditionally overrides DISABLE_DNSSEC
# EXPERIMENTAL_DANE=yes
+# Uncomment the following line to add SOCKS support
+# EXPERIMENTAL_SOCKS=yes
+
+# Uncomment the following to add Internationalisation features. You need to
+# have the IDN library installed.
+# EXPERIMENTAL_INTERNATIONAL=yes
+# LDFLAGS += -lidn
+
###############################################################################
# THESE ARE THINGS YOU MIGHT WANT TO SPECIFY #
###############################################################################
@@ -645,6 +652,7 @@ AUTH_DOVECOT=yes
# AUTH_HEIMDAL_GSSAPI_PC=heimdal-gssapi
AUTH_PLAINTEXT=yes
AUTH_SPA=yes
+AUTH_TLS=yes
#------------------------------------------------------------------------------
@@ -801,7 +809,7 @@ USE_OPENSSL_PC=openssl
# with the extension "texinfo" in the doc directory. You may find that the
# version number of the texinfo files is different to your Exim version number,
# because the main documentation isn't updated as often as the code. For
-# example, if you have Exim version 4.43, the source tarball upacks into a
+# example, if you have Exim version 4.43, the source tarball unpacks into a
# directory called exim-4.43, but the texinfo tarball unpacks into exim-4.40.
# In this case, move the contents of exim-4.40/doc into exim-4.43/doc after you
# have unpacked them. Then set INFO_DIRECTORY to the location of your info
@@ -879,9 +887,15 @@ COMPRESS_SUFFIX=gz
# If the exigrep utility is fed compressed log files, it tries to uncompress
# them using this command.
+# Leave it empty to enforce autodetection at runtime:
+# ZCAT_COMMAND=
+#
+# Omit the path if you want to use your system's PATH:
+# ZCAT_COMMAND=zcat
+#
+# Or specify the full pathname:
ZCAT_COMMAND=/usr/bin/zcat
-
#------------------------------------------------------------------------------
# Compiling in support for embedded Perl: If you want to be able to
# use Perl code in Exim's string manipulation language and you have Perl
@@ -957,7 +971,7 @@ EXTRALIBS += -ldl
# There is no need to install all of SASL on your system. You just need to run
# ./configure --with-pwcheck, cd to the pwcheck directory within the sources,
# make and make install. You must create the socket directory (default
-# /var/pwcheck) and chown it to exim's user and group. Once you have installed
+# /var/pwcheck) and chown it to Exim's user and group. Once you have installed
# pwcheck, you should arrange for it to be started by root at boot time.
# CYRUS_PWCHECK_SOCKET=/var/pwcheck/pwcheck
@@ -965,7 +979,7 @@ EXTRALIBS += -ldl
#------------------------------------------------------------------------------
# Support for authentication via the Cyrus SASL saslauthd daemon is available.
-# The Exim support, which is intented for use in conjunction with the SMTP AUTH
+# The Exim support, which is intended for use in conjunction with the SMTP AUTH
# facilities, is included only when requested by setting the following
# parameter to the location of the saslauthd daemon's socket.
#
@@ -973,7 +987,7 @@ EXTRALIBS += -ldl
# ./configure --with-saslauthd (and any other options you need, for example, to
# select or deselect authentication mechanisms), cd to the saslauthd directory
# within the sources, make and make install. You must create the socket
-# directory (default /var/state/saslauthd) and chown it to exim's user and
+# directory (default /var/state/saslauthd) and chown it to Exim's user and
# group. Once you have installed saslauthd, you should arrange for it to be
# started by root at boot time.
@@ -1134,7 +1148,7 @@ TMPDIR="/tmp"
# to handle the different cases. If CONFIGURE_FILE_USE_EUID is defined, then
# Exim will first look for a configuration file whose name is that defined
# by CONFIGURE_FILE, with the effective uid tacked on the end, separated by
-# a period (for eximple, /usr/exim/configure.0). If this file does not exist,
+# a period (for example, /usr/exim/configure.0). If this file does not exist,
# then the bare configuration file name is tried. In the case when both
# CONFIGURE_FILE_USE_EUID and CONFIGURE_FILE_USE_NODE are set, four files
# are tried: <name>.<euid>.<node>, <name>.<node>, <name>.<euid>, and <name>.
@@ -1318,7 +1332,7 @@ PID_FILE_PATH=/var/run/exim.pid
#------------------------------------------------------------------------------
-# Expanding match_* second paramters: BE CAREFUL IF ENABLING THIS!
+# Expanding match_* second parameters: BE CAREFUL IF ENABLING THIS!
# It has proven too easy in practice for administrators to configure security
# problems into their Exim install, by treating match_domain{}{} and friends
# as a form of string comparison, where the second string comes from untrusted
diff --git a/network/exim/exim.SlackBuild b/network/exim/exim.SlackBuild
index ded13e2889..6afeb8c932 100644
--- a/network/exim/exim.SlackBuild
+++ b/network/exim/exim.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for Exim
-# Copyright 2012-2014 Thomas Morper, Augsburg, Germany
+# Copyright 2012-2015 Thomas Morper, Augsburg, Germany
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=exim
-VERSION=${VERSION:-4.85}
+VERSION=${VERSION:-4.86}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -49,6 +49,9 @@ elif [ "$ARCH" = "i686" ]; then
elif [ "$ARCH" = "x86_64" ]; then
SLKCFLAGS="-O2 -fPIC"
LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
fi
set -e
@@ -91,9 +94,8 @@ cat exim_monitor/EDITME > Local/eximon.conf
# Use the Exim build system to set the architecture-specific CFLAGS.
# This requires "make" to run twice, in case you wonder. If you want
# to use your own CFLAGS in exim.Makefile, you should put a '#' in
-# front of the next 4 lines.
-echo "CFLAGS=$SLKCFLAGS" > Local/Makefile-Linux
-echo "CFLAGS+=-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE" > Local/Makefile-Linux-i386
+# front of the next 3 lines.
+echo "CFLAGS=$SLKCFLAGS -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE" > Local/Makefile-Linux
FULLECHO="" LIBDIRSUFFIX=$LIBDIRSUFFIX DESTDIR=$PKG make -e || true
FULLECHO="" LIBDIRSUFFIX=$LIBDIRSUFFIX DESTDIR=$PKG make -e makefile
diff --git a/network/exim/exim.info b/network/exim/exim.info
index 3c906cf0f8..7285f4a1c1 100644
--- a/network/exim/exim.info
+++ b/network/exim/exim.info
@@ -1,8 +1,8 @@
PRGNAM="exim"
-VERSION="4.85"
+VERSION="4.86"
HOMEPAGE="http://www.exim.org/"
-DOWNLOAD="ftp://ftp.exim.org/pub/exim/exim4/exim-4.85.tar.bz2"
-MD5SUM="ebae28762b6f125726283dc9434e8709"
+DOWNLOAD="ftp://ftp.exim.org/pub/exim/exim4/exim-4.86.tar.bz2"
+MD5SUM="797f248ef3e0c0e2f178e915f88fc4e9"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="%README%"