summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Adis Nezirovic <adis@linux.org.ba>2015-01-22 06:50:24 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-01-22 06:50:24 +0700
commitcf2825c2fc5367e683a3798d287ddab05eb1c508 (patch)
treee1b5553b8341faf06902c851f99890430e837cec
parent83652b4a697905c0f20e7bcd20cf9c18e2a908e1 (diff)
downloadslackbuilds-cf2825c2fc5367e683a3798d287ddab05eb1c508.tar.gz
slackbuilds-cf2825c2fc5367e683a3798d287ddab05eb1c508.tar.xz
network/mod_wsgi: Updated for version 4.4.6.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--network/mod_wsgi/README24
-rw-r--r--network/mod_wsgi/mod_wsgi.SlackBuild42
-rw-r--r--network/mod_wsgi/mod_wsgi.info6
3 files changed, 55 insertions, 17 deletions
diff --git a/network/mod_wsgi/README b/network/mod_wsgi/README
index e2188db7ea..e2df1bbde7 100644
--- a/network/mod_wsgi/README
+++ b/network/mod_wsgi/README
@@ -1,11 +1,21 @@
-mod_wsgi is a simple to use Apache module which can host any
-Python application which supports the Python WSGI interface.
-The module would be suitable for use in hosting high performance
-production web sites as well as your average personal sites
-running on commodity web hosting services.
+mod_wsgi is a simple to use Apache module which can host any Python
+application which supports the Python WSGI interface. The module
+would be suitable for use in hosting high performance production
+web sites as well as your average personal sites running on commodity
+web hosting services.
-All major Python web frameworks/applications support mod_wsgi;
-that means Django, Pylons, Turbogears, etcetera...
+All major Python web frameworks/applications support mod_wsgi,
+including Django, Flask, Pyramid, TurboGears, ...
You'll need to add the following line to your /etc/httpd/httpd.conf file:
Include /etc/httpd/extra/mod_wsgi.conf
+
+From version 4.2, mod_wsgi ships with additional helper program for
+developers, mod_wsgi-express, which enables easier development and
+debugging with mod_wsgi and Apache.
+
+If you are a developer, you can enable the helper with:
+ ENABLE_EXPRESS=1 ./mod_wsgi.SlackBuild
+
+For express functionality you'll need to install 'pysetuptools' and
+'mod-wsgi-metrics' (both available from SBo).
diff --git a/network/mod_wsgi/mod_wsgi.SlackBuild b/network/mod_wsgi/mod_wsgi.SlackBuild
index 2ec5084e98..cabcb80395 100644
--- a/network/mod_wsgi/mod_wsgi.SlackBuild
+++ b/network/mod_wsgi/mod_wsgi.SlackBuild
@@ -1,12 +1,32 @@
#!/bin/sh
-## Slackware build script for mod_wsgi
-##
-## Copyright 2008 Adis Nezirovic <adis _at_ linux.org.ba>
-## Licensed under GNU GPL v2
+# Slackware build script for mod_wsgi
+#
+# $Revision: f05ce16331b4 $
+# $Date: 2015/01/21 22:51:37 $
+#
+# Copyright 2008-2015 Adis Nezirovic <adis_at_linux.org.ba>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=mod_wsgi
-VERSION=${VERSION:-3.4}
+VERSION=${VERSION:-4.4.6}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -36,7 +56,8 @@ rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+# Note: 4.x versions only have $VERSION in archive name
+tar xvf $CWD/$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
@@ -49,6 +70,13 @@ find -L . \
make
make install DESTDIR=$PKG
+# Enable EXPRESS builds using 'ENABLE_EXPRESS=1 ./mod_wsgi.SlackBuild'
+# For this you need pysetuptools and mod_wsgi-metrics, available from SBo
+# The express build creates it's own Apache module
+if [ ! -z $ENABLE_EXPRESS ];then
+ python setup.py install --root=$PKG
+fi
+
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
@@ -57,7 +85,7 @@ sed "s%@baselibdir@%lib${LIBDIRSUFFIX}%" $CWD/mod_wsgi.conf > \
$PKG/etc/httpd/extra/mod_wsgi.conf.new
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a LICENCE README $PKG/usr/doc/$PRGNAM-$VERSION/
+cp -a LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION/
cat $CWD/README > $PKG/usr/doc/$PRGNAM-$VERSION/README.Slackware
mkdir -p $PKG/install
diff --git a/network/mod_wsgi/mod_wsgi.info b/network/mod_wsgi/mod_wsgi.info
index 4b6cf5230b..764760eb90 100644
--- a/network/mod_wsgi/mod_wsgi.info
+++ b/network/mod_wsgi/mod_wsgi.info
@@ -1,8 +1,8 @@
PRGNAM="mod_wsgi"
-VERSION="3.4"
+VERSION="4.4.6"
HOMEPAGE="http://www.modwsgi.org"
-DOWNLOAD="http://modwsgi.googlecode.com/files/mod_wsgi-3.4.tar.gz"
-MD5SUM="f42d69190ea0c337ef259cbe8d94d985"
+DOWNLOAD="https://github.com/GrahamDumpleton/mod_wsgi/archive/4.4.6.tar.gz"
+MD5SUM="bab68899e92a6ee328a02954a0818022"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""