summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author Jostein Berntsen <jbernts@broadpark.no>2014-08-19 23:46:13 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-08-20 01:40:57 +0700
commite68a0b7b99ceb5d6a05a333049b29959fcdb4c14 (patch)
tree20b09069a1c9ffbf6e502027839bc30c6551c98b
parent198aba61b1d0dd0f5cf228aab21172fea98fa7d7 (diff)
downloadslackbuilds-e68a0b7b99ceb5d6a05a333049b29959fcdb4c14.tar.gz
slackbuilds-e68a0b7b99ceb5d6a05a333049b29959fcdb4c14.tar.xz
office/task: Updated for version 2.3.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--office/task/task.SlackBuild27
-rw-r--r--office/task/task.info6
2 files changed, 15 insertions, 18 deletions
diff --git a/office/task/task.SlackBuild b/office/task/task.SlackBuild
index 1ce9f56970..0c36a39769 100644
--- a/office/task/task.SlackBuild
+++ b/office/task/task.SlackBuild
@@ -4,9 +4,8 @@
# Written by Jostein Berntsen <jbernts@broadpark.no>
-
PRGNAM=task
-VERSION=${VERSION:-2.2.0}
+VERSION=${VERSION:-2.3.0}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -47,16 +46,12 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-sed -i CMakeLists.txt \
- -e "s,share/man/man1,man/man1," \
- -e "s,share/man/man5,man/man5," \
- -e "s,share/doc/task,doc/$PRGNAM-$VERSION,"
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+# Build
cmake \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
@@ -66,15 +61,17 @@ make clean
make
make install DESTDIR=$PKG
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+mv $PKG/usr/share/man $PKG/usr
find $PKG/usr/man -type f -exec gzip -9 {} \;
+for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
+
+find $PKG -depth -type d -empty -delete || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS COPYING INSTALL NEWS README \
- $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING INSTALL NEWS README $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/office/task/task.info b/office/task/task.info
index 859673132f..e1244fc8a3 100644
--- a/office/task/task.info
+++ b/office/task/task.info
@@ -1,8 +1,8 @@
PRGNAM="task"
-VERSION="2.2.0"
+VERSION="2.3.0"
HOMEPAGE="http://www.taskwarrior.org"
-DOWNLOAD="http://www.taskwarrior.org/download/task-2.2.0.tar.gz"
-MD5SUM="eb5af01b51b90e01b574464a5d11d4e9"
+DOWNLOAD="http://www.taskwarrior.org/download/task-2.3.0.tar.gz"
+MD5SUM="2c1d2c64311855f3519ad038ebd372ac"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="lua"