summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
author LukenShiro <lukenshiro@ngi.it>2015-09-27 21:25:53 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-09-27 21:25:53 +0700
commitfbe1488b8de6c53d18151f565600b86639ebb820 (patch)
tree134f60700610ea6082d8324401046a6c2a91c19b
parentc8306e04ddde7d7962f593190339d9cd5ec9b7f0 (diff)
downloadslackbuilds-fbe1488b8de6c53d18151f565600b86639ebb820.tar.gz
slackbuilds-fbe1488b8de6c53d18151f565600b86639ebb820.tar.xz
python/Pygments: Updated for version 2.0.2.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
-rw-r--r--python/Pygments/Pygments.SlackBuild24
-rw-r--r--python/Pygments/Pygments.info8
-rw-r--r--python/Pygments/README3
3 files changed, 22 insertions, 13 deletions
diff --git a/python/Pygments/Pygments.SlackBuild b/python/Pygments/Pygments.SlackBuild
index 2f558875dd..45a4d1b4d7 100644
--- a/python/Pygments/Pygments.SlackBuild
+++ b/python/Pygments/Pygments.SlackBuild
@@ -3,7 +3,7 @@
# Slackware build script for Pygments
# Copyright 2009 Grissiom <chaos.proton@gmail.com>
-# Copyright 2009-2013 LukenShiro, Italy
+# Copyright 2009-2015 LukenShiro, Italy
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,8 +24,8 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=Pygments
-VERSION=${VERSION:-1.6}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-2.0.2}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -41,7 +41,9 @@ TMP=${TMP:-/tmp/SBo}
PKG=$TMP/package-$PRGNAM
OUTPUT=${OUTPUT:-/tmp}
-DOCFILES="LICENSE TODO AUTHORS CHANGES docs/build/*.html"
+DOCFILES="LICENSE TODO AUTHORS CHANGES README.rst"
+# html documentation is not built by default
+HTML=${HTML:-0}
set -e
@@ -53,15 +55,15 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
python setup.py install --prefix=/usr --root=$PKG
mkdir -p $PKG/usr/man/man1
-cp -a docs/pygmentize.1 $PKG/usr/man/man1
+cp -a doc/pygmentize.1 $PKG/usr/man/man1
# Adapting to Slackware's directory layout
sed -i "s|share/doc/python-pygments|doc/${PRGNAM}-${VERSION}|" \
$PKG/usr/man/man1/pygmentize.1
@@ -69,6 +71,11 @@ sed -i "s|share/doc/python-pygments|doc/${PRGNAM}-${VERSION}|" \
find $PKG/usr/man -type f -exec gzip -9 {} \;
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+# building html documentation
+case "$HTML" in
+ 0) ;;
+ *) cd doc ; make html && cp -R _build/html $PKG/usr/doc/$PRGNAM-$VERSION ; cd - ;;
+esac
cp -a $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
@@ -77,4 +84,3 @@ cat $CWD/slack-desc > $PKG/install/slack-desc
cd $PKG
/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
-
diff --git a/python/Pygments/Pygments.info b/python/Pygments/Pygments.info
index b6696debb3..c7c672e214 100644
--- a/python/Pygments/Pygments.info
+++ b/python/Pygments/Pygments.info
@@ -1,10 +1,10 @@
PRGNAM="Pygments"
-VERSION="1.6"
+VERSION="2.0.2"
HOMEPAGE="http://pygments.org/"
-DOWNLOAD="http://pypi.python.org/packages/source/P/Pygments/Pygments-1.6.tar.gz"
-MD5SUM="a18feedf6ffd0b0cc8c8b0fbdb2027b1"
+DOWNLOAD="http://pypi.python.org/packages/source/P/Pygments/Pygments-2.0.2.tar.gz"
+MD5SUM="238587a1370d62405edabd0794b3ec4a"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES=""
+REQUIRES="pysetuptools"
MAINTAINER="LukenShiro"
EMAIL="lukenshiro@ngi.it"
diff --git a/python/Pygments/README b/python/Pygments/README
index 975ce911d5..4e7391ba6f 100644
--- a/python/Pygments/README
+++ b/python/Pygments/README
@@ -9,3 +9,6 @@ Highlights are:
* A number of output formats, presently HTML, LaTeX, RTF, SVG and ANSI
sequences.
* It is usable as a command-line tool and as a library.
+
+In order to build pygments' html documentation files you must install Sphinx
+and you need to use "HTML=1 ./Pygments.SlackBuild".