summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <slackbuilds@jaxartes.net>2014-02-02 06:41:19 +0700
committer Robby Workman <rworkman@slackbuilds.org>2014-02-02 02:09:49 -0600
commit3b3a793f974097bcf9baf45f64fb7191eb79084b (patch)
tree27ea8e9448b7bfd4d23e9a8112d5f7a1223716a1 /academic
parent8e68364dbb16ce0bca716d05a47b44a6dee6c419 (diff)
downloadslackbuilds-3b3a793f974097bcf9baf45f64fb7191eb79084b.tar.gz
slackbuilds-3b3a793f974097bcf9baf45f64fb7191eb79084b.tar.xz
gis/rasterio: Moved from Academic category.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/rasterio/README7
-rw-r--r--academic/rasterio/rasterio.SlackBuild91
-rw-r--r--academic/rasterio/rasterio.info10
-rw-r--r--academic/rasterio/slack-desc19
4 files changed, 0 insertions, 127 deletions
diff --git a/academic/rasterio/README b/academic/rasterio/README
deleted file mode 100644
index 66dd4a646a..0000000000
--- a/academic/rasterio/README
+++ /dev/null
@@ -1,7 +0,0 @@
-Fast and direct geospatial raster I/O for Python programmers who use Numpy.
-
-This package is aimed at developers who want little more than to read raster
-images into Numpy arrays or buffers, operate on them in Python (or Cython), and
-write the results out to new GeoTIFF files.
-
-Rasterio employs GDAL under the hood for file I/O and raster formatting.
diff --git a/academic/rasterio/rasterio.SlackBuild b/academic/rasterio/rasterio.SlackBuild
deleted file mode 100644
index a56f8358b2..0000000000
--- a/academic/rasterio/rasterio.SlackBuild
+++ /dev/null
@@ -1,91 +0,0 @@
-#!/bin/sh
-
-# SlackBuild script for rasterio
-
-# Copyright 2013 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# All rights reserved.
-#
-# Redistribution and use in source and binary forms, with or without
-# modification, are permitted provided that the following conditions are
-# met:
-#
-# * Redistributions of source code must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
-# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
-# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
-# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
-# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
-# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
-# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
-# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
-# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
-# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=rasterio
-VERSION=${VERSION:-0.5}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-if [ -e $CWD/$VERSION.tar.gz ]; then
- tar xvf $CWD/$VERSION.tar.gz
-else
- tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-fi
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS.txt CHANGES.txt LICENSE.txt README.rst $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/rasterio/rasterio.info b/academic/rasterio/rasterio.info
deleted file mode 100644
index 9b5c8bb05b..0000000000
--- a/academic/rasterio/rasterio.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="rasterio"
-VERSION="0.5"
-HOMEPAGE="https://github.com/sgillies/rasterio"
-DOWNLOAD="https://github.com/sgillies/rasterio/archive/0.5.tar.gz"
-MD5SUM="2b7e2c5fd72f37651c61c0bc66bd4c4f"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="Cython gdal numpy pysetuptools"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
diff --git a/academic/rasterio/slack-desc b/academic/rasterio/slack-desc
deleted file mode 100644
index 9f77ed6fa1..0000000000
--- a/academic/rasterio/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-rasterio: rasterio (direct raster I/O for programmers who use Numpy)
-rasterio:
-rasterio: Fast and direct geospatial raster I/O for Python programmers. This
-rasterio: package is aimed at developers who want little more than to read
-rasterio: raster images into Numpy arrays or buffers, operate on them in
-rasterio: Python, and write the results out to new GeoTIFF files.
-rasterio:
-rasterio: Rasterio employs GDAL under the hood for file I/O and formatting.
-rasterio:
-rasterio: homepage: https://github.com/sgillies/rasterio
-rasterio: