summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Benjamin Trigona-Harany <slackbuilds@jaxartes.net>2014-02-02 06:39:07 +0700
committer Robby Workman <rworkman@slackbuilds.org>2014-02-02 02:09:48 -0600
commit7afc69b6bb3b209021e789e2dea75914089a3b92 (patch)
tree9fcc41eb9a25381dea5c8826d45b5f32afb30b70 /academic
parentb655b74928f32574b7549f521d08e9fd198ed4dc (diff)
downloadslackbuilds-7afc69b6bb3b209021e789e2dea75914089a3b92.tar.gz
slackbuilds-7afc69b6bb3b209021e789e2dea75914089a3b92.tar.xz
gis/osm2pgrouting: Moved from Academic category.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/osm2pgrouting/README2
-rw-r--r--academic/osm2pgrouting/osm2pgrouting.SlackBuild101
-rw-r--r--academic/osm2pgrouting/osm2pgrouting.info10
-rw-r--r--academic/osm2pgrouting/slack-desc19
4 files changed, 0 insertions, 132 deletions
diff --git a/academic/osm2pgrouting/README b/academic/osm2pgrouting/README
deleted file mode 100644
index 17da7e7304..0000000000
--- a/academic/osm2pgrouting/README
+++ /dev/null
@@ -1,2 +0,0 @@
-osm2pgrouting is a tool for importing OpenStreetMap data into a PostGIS
-database for use with pgRouting.
diff --git a/academic/osm2pgrouting/osm2pgrouting.SlackBuild b/academic/osm2pgrouting/osm2pgrouting.SlackBuild
deleted file mode 100644
index 5abb5e0a6d..0000000000
--- a/academic/osm2pgrouting/osm2pgrouting.SlackBuild
+++ /dev/null
@@ -1,101 +0,0 @@
-#!/bin/sh
-
-# SlackBuild script for osm2pgrouting
-
-# Copyright 2013 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=osm2pgrouting
-VERSION=${VERSION:-2.0.0}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-rm -rf $TMP/$PRGNAM-$VERSION
-cd $TMP
-if [ -e $CWD/v$VERSION.tar.gz ]; then
- tar xvf $CWD/v$VERSION.tar.gz
-else
- tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-fi
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-sed -i "s_/usr/share/bin_/usr/bin_" CMakeLists.txt
-mkdir -p build
-cd build
- cmake \
- -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
- -DCMAKE_ISNTALL_FULL_BINDIR=/xxxx \
- -DWITH_DOC=$WITH_DOC \
- ..
-
- make VERBOSE=1
- make install VERBOSE=1 DESTDIR=$PKG
-cd ..
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS.txt COPYING Readme.md $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/osm2pgrouting/osm2pgrouting.info b/academic/osm2pgrouting/osm2pgrouting.info
deleted file mode 100644
index 3bab742317..0000000000
--- a/academic/osm2pgrouting/osm2pgrouting.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="osm2pgrouting"
-VERSION="2.0.0"
-HOMEPAGE="http://pgrouting.org"
-DOWNLOAD="https://github.com/pgRouting/osm2pgrouting/archive/v2.0.0.tar.gz"
-MD5SUM="ee7a9e5caa0a40511b8210f9581e9e9a"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="pgrouting"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
diff --git a/academic/osm2pgrouting/slack-desc b/academic/osm2pgrouting/slack-desc
deleted file mode 100644
index 4e9aae020c..0000000000
--- a/academic/osm2pgrouting/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-osm2pgrouting: osm2pgrouting (import OSM data into pgRouting database)
-osm2pgrouting:
-osm2pgrouting: osm2pgrouting is a tool for importing OpenStreetMap data into a
-osm2pgrouting: PostGIS database for use with pgRouting.
-osm2pgrouting:
-osm2pgrouting: Homepage: http://pgrouting.org
-osm2pgrouting:
-osm2pgrouting:
-osm2pgrouting:
-osm2pgrouting:
-osm2pgrouting: