summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Fellype do Nascimento <fellype@gmail.com>2014-12-13 01:47:39 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-12-13 01:47:39 +0700
commitaeb6675140426e0035434358dfb3bc5093f2a522 (patch)
tree3c8a9201ef65cbf5091a04f88e8c907f40e0d2fe /academic
parent7db5892290482a42e9247f17c542e220793068fc (diff)
downloadslackbuilds-aeb6675140426e0035434358dfb3bc5093f2a522.tar.gz
slackbuilds-aeb6675140426e0035434358dfb3bc5093f2a522.tar.xz
academic/labplot2: Added (graph and scientific data analaysis).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/labplot2/README12
-rw-r--r--academic/labplot2/doinst.sh13
-rw-r--r--academic/labplot2/labplot2.SlackBuild72
-rw-r--r--academic/labplot2/labplot2.info10
-rw-r--r--academic/labplot2/slack-desc19
5 files changed, 126 insertions, 0 deletions
diff --git a/academic/labplot2/README b/academic/labplot2/README
new file mode 100644
index 0000000000..8c301eb1eb
--- /dev/null
+++ b/academic/labplot2/README
@@ -0,0 +1,12 @@
+LabPlot2 - (interactive graphing and analysis of scientific data)
+
+LabPlot is a KDE-application for interactive graphing and analysis of scientific data.
+LabPlot provides an easy way to create, manage and edit plots.
+It allows you to produce plots based on data from a spreadsheet or on data imported from external files.
+Plots can be exported to several pixmap and vector graphic formats.
+
+LabPlot2 is a complete rewrite of LabPlot1 and lacks in the first release a lot of features available
+in the predecessor. On the other hand, the GUI and the usability is more superior as compared to LabPlot1
+and there are several new features that were not available in LabPlot1.
+
+gsl is an optional dependency.
diff --git a/academic/labplot2/doinst.sh b/academic/labplot2/doinst.sh
new file mode 100644
index 0000000000..9424ce43ff
--- /dev/null
+++ b/academic/labplot2/doinst.sh
@@ -0,0 +1,13 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
+
+if [ -x /usr/bin/update-mime-database ]; then
+ /usr/bin/update-mime-database usr/share/mime >/dev/null 2>&1
+fi
+
+if [ -e usr/share/icons/hicolor/icon-theme.cache ]; then
+ if [ -x /usr/bin/gtk-update-icon-cache ]; then
+ /usr/bin/gtk-update-icon-cache usr/share/icons/hicolor >/dev/null 2>&1
+ fi
+fi
diff --git a/academic/labplot2/labplot2.SlackBuild b/academic/labplot2/labplot2.SlackBuild
new file mode 100644
index 0000000000..052e3324cf
--- /dev/null
+++ b/academic/labplot2/labplot2.SlackBuild
@@ -0,0 +1,72 @@
+#!/bin/sh
+# Slackware build script for LabPlot
+# Based on the Slackware 14.1 SlackBuild and AUR PKGBUILD for labplot
+# Written by Fellype do Nascimento <fellype(at)gmail.com>
+#last modification of this build script: 2014/12/12
+
+NAME=labplot
+PRGNAM=labplot2
+VERSION=${VERSION:-2.0.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i686 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"; SLKLDFLAGS=""; LIBDIRSUFFIX=""; CHOST=i486
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"; SLKLDFLAGS=""; LIBDIRSUFFIX=""; CHOST=i486
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"; SLKLDFLAGS="-L/usr/lib64"; LIBDIRSUFFIX="64"
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $NAME-$VERSION
+tar xvf $CWD/$NAME-$VERSION.tar.bz2
+cd $NAME-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+./compile
+
+( cd build/
+cmake ./ -DCMAKE_INSTALL_PREFIX=/usr
+cmake ./ -DCMAKE_BUILD_TYPE=Release
+make install DESTDIR=$PKG
+)
+
+( cd $PKG
+find . | xargs file | grep "executable" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+find . | xargs file | grep "shared object" | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+find . | xargs file | grep "current ar archive" | cut -f 1 -d : | xargs strip -g 2> /dev/null || true
+)
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS ChangeLog COPYING INSTALL README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/labplot2/labplot2.info b/academic/labplot2/labplot2.info
new file mode 100644
index 0000000000..77d35a3271
--- /dev/null
+++ b/academic/labplot2/labplot2.info
@@ -0,0 +1,10 @@
+PRGNAM="labplot2"
+VERSION="2.0.1"
+HOMEPAGE="http://labplot.sourceforge.net/"
+DOWNLOAD="http://hivelocity.dl.sourceforge.net/project/labplot/labplot/2.0.0/labplot-2.0.1.tar.bz2"
+MD5SUM="f01a5a6a796429e8a45805cb611e25f2"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Fellype do Nascimento"
+EMAIL="fellype(at)gmail.com"
diff --git a/academic/labplot2/slack-desc b/academic/labplot2/slack-desc
new file mode 100644
index 0000000000..50672662f5
--- /dev/null
+++ b/academic/labplot2/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+labplot2: labplot2 - (interactive graphing and analysis of scientific data)
+labplot2:
+labplot2: LabPlot is a KDE-application for interactive graphing and analysis of
+labplot2: scientific data. LabPlot provides an easy way to create, manage and
+labplot2: edit plots.
+labplot2: LabPlot2 is a complete rewrite of LabPlot1 and lacks in the first
+labplot2: release a lot of features available in the predecessor. On the other
+labplot2: hand, the GUI and the usability is more superior as compared to
+labplot2: LabPlot1 and there are several new features that were not available
+labplot2: in LabPlot1.
+labplot2: