summaryrefslogtreecommitdiffstats
path: root/academic
diff options
context:
space:
mode:
author Petar Petrov <petar.petrov@student.oulu.fi>2015-03-27 07:54:43 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-03-27 07:54:43 +0700
commitb58f460047df0774b19d1308131523aaa520cfa2 (patch)
tree2737877323102c17de8f844d007d0c2692070651 /academic
parent519760e55e83c4dbaa276128c55715f01d449a98 (diff)
downloadslackbuilds-b58f460047df0774b19d1308131523aaa520cfa2.tar.gz
slackbuilds-b58f460047df0774b19d1308131523aaa520cfa2.tar.xz
academic/cutadapt: Added (Trim adapters).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'academic')
-rw-r--r--academic/cutadapt/README26
-rw-r--r--academic/cutadapt/cutadapt.SlackBuild85
-rw-r--r--academic/cutadapt/cutadapt.info10
-rw-r--r--academic/cutadapt/slack-desc19
4 files changed, 140 insertions, 0 deletions
diff --git a/academic/cutadapt/README b/academic/cutadapt/README
new file mode 100644
index 0000000000..a558d53867
--- /dev/null
+++ b/academic/cutadapt/README
@@ -0,0 +1,26 @@
+Cutadapt: trim adapters from high-throughput sequencing reads
+
+Cutadapt finds and removes adapter sequences, primers, poly-A tails
+and other types of unwanted sequence from your high-throughput
+sequencing reads.
+
+Cleaning your data in this way is often required: Reads from small-RNA
+sequencing contain the 3’ sequencing adapter because the read is
+longer than the molecule that is sequenced. Amplicon reads start with
+a primer sequence. Poly-A tails are useful for pulling out RNA from
+your sample, but often you don’t want them to be in your reads.
+
+Cutadapt helps with these trimming tasks by finding the adapter or
+primer sequences in an error-tolerant way. It can also modify and
+filter reads in various ways. Adapter sequences can contain IUPAC
+wildcard characters. Also, paired-end reads and even colorspace data
+is supported. If you want, you can also just demultiplex your input
+data, without removing adapter sequences at all.
+
+Cutadapt comes with an extensive suite of automated tests and is
+available under the terms of the MIT license.
+
+If you use cutadapt, please cite:
+Marcel Martin. Cutadapt removes adapter sequences from high-throughput
+sequencing reads. EMBnet.journal, 17(1):10-12, May 2011. DOI:
+http://dx.doi.org/10.14806/ej.17.1.200
diff --git a/academic/cutadapt/cutadapt.SlackBuild b/academic/cutadapt/cutadapt.SlackBuild
new file mode 100644
index 0000000000..8837ae02c4
--- /dev/null
+++ b/academic/cutadapt/cutadapt.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for cutadapt
+
+# Copyright 2015 Petar Petrov petar.petrov@student.oulu.fi
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=cutadapt
+VERSION=${VERSION:-1.8}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES.rst CITATION LICENSE README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/academic/cutadapt/cutadapt.info b/academic/cutadapt/cutadapt.info
new file mode 100644
index 0000000000..115c60b2f5
--- /dev/null
+++ b/academic/cutadapt/cutadapt.info
@@ -0,0 +1,10 @@
+PRGNAM="cutadapt"
+VERSION="1.8"
+HOMEPAGE="https://pypi.python.org/pypi/cutadapt/"
+DOWNLOAD="https://pypi.python.org/packages/source/c/cutadapt/cutadapt-1.8.tar.gz"
+MD5SUM="73cc9c52d1b14883c24a4c29b16e0b61"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Petar Petrov"
+EMAIL="petar.petrov@student.oulu.fi"
diff --git a/academic/cutadapt/slack-desc b/academic/cutadapt/slack-desc
new file mode 100644
index 0000000000..b4a0da5f16
--- /dev/null
+++ b/academic/cutadapt/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+cutadapt: cutadapt (Trim adapters from high-throughput sequencing reads)
+cutadapt:
+cutadapt: Cutadapt finds and removes adapter sequences, primers, poly-A
+cutadapt: tails and other types of unwanted sequence from your high-
+cutadapt: throughput sequencing reads.
+cutadapt:
+cutadapt: Home: https://pypi.python.org/pypi/cutadapt/
+cutadapt: Reference: /usr/doc/cutadapt-1.8/CITATION
+cutadapt:
+cutadapt:
+cutadapt: