summaryrefslogtreecommitdiffstats
path: root/accessibility
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2010-12-27 00:58:28 -0200
committer Niels Horn <niels.horn@slackbuilds.org>2010-12-27 19:22:54 -0200
commit60b9b3b9cb72833a0c5bc8b15a5ee1687f3c53d9 (patch)
tree47dc6dba49786be4ae19c5aef188d5d0bb751d01 /accessibility
parent5fb9bd4c7dbb1b9f64a74cd40cf7b74d3a6e0116 (diff)
downloadslackbuilds-60b9b3b9cb72833a0c5bc8b15a5ee1687f3c53d9.tar.gz
slackbuilds-60b9b3b9cb72833a0c5bc8b15a5ee1687f3c53d9.tar.xz
accessibility/espeak: Updated for version 1.44.05.
Signed-off-by: Niels Horn <niels.horn@slackbuilds.org>
Diffstat (limited to 'accessibility')
-rw-r--r--accessibility/espeak/espeak.SlackBuild20
-rw-r--r--accessibility/espeak/espeak.info8
-rw-r--r--accessibility/espeak/makefile.patch17
-rw-r--r--accessibility/espeak/slack-desc2
4 files changed, 34 insertions, 13 deletions
diff --git a/accessibility/espeak/espeak.SlackBuild b/accessibility/espeak/espeak.SlackBuild
index ef56293444..e642695de0 100644
--- a/accessibility/espeak/espeak.SlackBuild
+++ b/accessibility/espeak/espeak.SlackBuild
@@ -5,16 +5,14 @@
# Written by B. Watson (yalhcru@gmail.com)
PRGNAM=espeak
-VERSION=${VERSION:-1.42.04}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-1.44.05}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
-# Automatically determine the architecture we're building on:
if [ -z "$ARCH" ]; then
case "$( uname -m )" in
i?86) ARCH=i486 ;;
arm*) ARCH=arm ;;
- # Unless $ARCH is already set, use uname -m for all other archs:
*) ARCH=$( uname -m ) ;;
esac
fi
@@ -54,7 +52,14 @@ find . \
-exec chmod 644 {} \;
# Cruft...
-rm -rf docs/images/.svn
+find . -type d -a -name .svn -print0 | xargs -0 rm -rf
+
+# Make the Makefile install everything stripped
+patch -p1 < $CWD/makefile.patch
+
+# Note: there are two executables (speak and espeak). They seem to do the same
+# thing, except "speak" doesn't use libespeak.so at runtime. This package only
+# installs "espeak" (which is how other distros do it, too).
cd src
@@ -70,16 +75,15 @@ fi
make LIBDIR=/usr/lib$LIBDIRSUFFIX CXXFLAGS="$SLKCFLAGS" $EXTRAMAKEFLAGS
make install LIBDIR=/usr/lib$LIBDIRSUFFIX DESTDIR=$PKG $EXTRAMAKEFLAGS
-strip $PKG/usr/bin/$PRGNAM $PKG/usr/lib$LIBDIRSUFFIX/lib$PRGNAM.so.*.*.*
rm -f $PKG/usr/lib$LIBDIRSUFFIX/*.a # guidelines say no static libs
find $PKG/usr/share -type f -print0 | xargs -0 chmod 644
cd ..
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -r ChangeLog ReadMe *.txt docs/* $PKG/usr/doc/$PRGNAM-$VERSION
+cp -r ReadMe *.txt docs/* $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-# Man page from Ubuntu
+# Man page from Debian
mkdir -p $PKG/usr/man/man1
gzip -9c $CWD/$PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
diff --git a/accessibility/espeak/espeak.info b/accessibility/espeak/espeak.info
index 31e3134735..40ada2360a 100644
--- a/accessibility/espeak/espeak.info
+++ b/accessibility/espeak/espeak.info
@@ -1,10 +1,10 @@
PRGNAM="espeak"
-VERSION="1.42.04"
+VERSION="1.44.05"
HOMEPAGE="http://espeak.sourceforge.net/"
-DOWNLOAD="http://downloads.sourceforge.net/sourceforge/espeak/espeak-1.42.04-source.zip"
-MD5SUM="a4cbbe5f2e2a37ccc0aa1a687a6e4c11"
+DOWNLOAD="http://downloads.sourceforge.net/espeak/espeak-1.44.05-source.zip"
+MD5SUM="603b3e5fc8510a82b76f51a94cb3c7a1"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
MAINTAINER="B. Watson"
EMAIL="yalhcru@gmail.com"
-APPROVED="Erik Hanson"
+APPROVED="Erik Hanson,Niels Horn"
diff --git a/accessibility/espeak/makefile.patch b/accessibility/espeak/makefile.patch
new file mode 100644
index 0000000000..ce3f2e7679
--- /dev/null
+++ b/accessibility/espeak/makefile.patch
@@ -0,0 +1,17 @@
+diff -Naur espeak-1.44.05-source/src/Makefile espeak-1.44.05-source.patched/src/Makefile
+--- espeak-1.44.05-source/src/Makefile 2010-08-13 17:35:09.000000000 -0400
++++ espeak-1.44.05-source.patched/src/Makefile 2010-12-26 19:31:55.000000000 -0500
+@@ -113,11 +113,9 @@
+ $(MKDIR) $(DESTDIR)$(INCDIR)
+ $(MKDIR) $(DESTDIR)$(DATADIR)
+ # Install espeak executable
+- $(INSTALL) -m 755 $(BIN2_NAME) $(DESTDIR)$(BINDIR)
++ $(INSTALL) -s -m 755 $(BIN2_NAME) $(DESTDIR)$(BINDIR)
+ # Install shared library
+- $(INSTALL) -m 755 $(LIB_NAME).$(LIBTAG) $(DESTDIR)$(LIBDIR)
+- # Install static library
+- $(INSTALL) -m 755 $(STATIC_LIB_NAME) $(DESTDIR)$(LIBDIR)
++ $(INSTALL) -s -m 755 $(LIB_NAME).$(LIBTAG) $(DESTDIR)$(LIBDIR)
+ $(LN_SF) $(LIB_NAME).$(LIBTAG) $(DESTDIR)$(LIBDIR)/$(LIB_NAME).$(LIB_VERSION)
+ $(LN_SF) $(LIB_NAME).$(LIB_VERSION) $(DESTDIR)$(LIBDIR)/$(LIB_NAME)
+ # Install development headers
diff --git a/accessibility/espeak/slack-desc b/accessibility/espeak/slack-desc
index b55ff39004..344a5757fe 100644
--- a/accessibility/espeak/slack-desc
+++ b/accessibility/espeak/slack-desc
@@ -7,7 +7,7 @@
|-----handy-ruler------------------------------------------------------|
espeak: eSpeak (a compact open source software speech synthesizer)
-espeak:
+espeak:
espeak: eSpeak produces good quality English speech. It uses a different
espeak: synthesis method from other open source text to speech (TTS) engines,
espeak: and sounds quite different. It's perhaps not as natural or "smooth",