summaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
author Ryan P.C. McQuen <ryanpcmcquen@gmail.com>2014-09-21 09:24:19 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-09-22 08:23:37 +0700
commit23cd68c251ae891e56cab56de86545d5608f4eb3 (patch)
tree6241c4dbe22b5e8c32a44fc92bbff8ace5ec10e2 /audio
parenta366f3c7261eacb14ca6897c5ff2904de59cf0b6 (diff)
downloadslackbuilds-23cd68c251ae891e56cab56de86545d5608f4eb3.tar.gz
slackbuilds-23cd68c251ae891e56cab56de86545d5608f4eb3.tar.xz
audio/apulse: Added (pulseaudio emulation for ALSA).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'audio')
-rw-r--r--audio/apulse/README12
-rw-r--r--audio/apulse/apulse.SlackBuild112
-rw-r--r--audio/apulse/apulse.info10
-rw-r--r--audio/apulse/slack-desc19
4 files changed, 153 insertions, 0 deletions
diff --git a/audio/apulse/README b/audio/apulse/README
new file mode 100644
index 0000000000..3dd8d7d9c5
--- /dev/null
+++ b/audio/apulse/README
@@ -0,0 +1,12 @@
+PulseAudio emulation for ALSA.
+
+Any app that requires pulseaudio can be run as such:
+
+ $ apulse <program> [parameters]
+
+PulseAudio is not required.
+
+To install this on a multilib machine with 32-bit compatibility
+libraries, run the SlackBuild preceded by COMPAT32=yes, like so:
+
+ # COMPAT32=yes sh apulse.SlackBuild
diff --git a/audio/apulse/apulse.SlackBuild b/audio/apulse/apulse.SlackBuild
new file mode 100644
index 0000000000..d35bafbd6e
--- /dev/null
+++ b/audio/apulse/apulse.SlackBuild
@@ -0,0 +1,112 @@
+#!/bin/sh
+
+# Slackware build script for apulse
+
+# Ryan P.C. McQuen | Everett, WA | ryan.q@linux.com
+
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version, with the following exception:
+# the text of the GPL license may be omitted.
+
+# This program is distributed in the hope that it will be useful, but
+# without any warranty; without even the implied warranty of
+# merchantability or fitness for a particular purpose. Compiling,
+# interpreting, executing or merely reading the text of the program
+# may result in lapses of consciousness and/or very being, up to and
+# including the end of all existence and the Universe as we know it.
+# See the GNU General Public License for more details.
+
+# You may have received a copy of the GNU General Public License along
+# with this program (most likely, a file named COPYING). If not, see
+# <http://www.gnu.org/licenses/>.
+
+PRGNAM=apulse
+VERSION=${VERSION:-20140920}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ TARGET="x86"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ TARGET="x86"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ TARGET="x86_64"
+ LIBDIRSUFFIX="64"
+ # set 32-bit compatibility flag default
+ COMPAT32=${COMPAT32:-no}
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+rm -fr $PRGNAM-master
+unzip $CWD/$PRGNAM-$VERSION.zip
+cd $PRGNAM-master
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+if [ "$COMPAT32" = "no" ]; then
+ sed -i "s|lib/apulse|lib${LIBDIRSUFFIX}/apulse|" CMakeLists.txt
+fi
+
+mkdir -p build
+cd build
+ if [ "$COMPAT32" = "yes" ]; then
+ CFLAGS=-m32 \
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..
+ else
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ..
+ fi
+ make VERBOSE=1
+ make install DESTDIR=$PKG
+cd ..
+
+if [ "$COMPAT32" = "yes" ]; then
+ mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}/apulse/
+ cp $PKG/usr/lib/apulse/* $PKG/usr/lib${LIBDIRSUFFIX}/apulse/
+fi
+
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/
+cp -a LICENSE.MIT README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/audio/apulse/apulse.info b/audio/apulse/apulse.info
new file mode 100644
index 0000000000..4a50521adc
--- /dev/null
+++ b/audio/apulse/apulse.info
@@ -0,0 +1,10 @@
+PRGNAM="apulse"
+VERSION="20140920"
+HOMEPAGE="https://github.com/i-rinat/apulse"
+DOWNLOAD="http://sourceforge.net/projects/slackbuildsdirectlinks/files/apulse/apulse-20140920.zip"
+MD5SUM="a2cb98067775bdb73c47c59f9437cff5"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Ryan P.C. McQuen"
+EMAIL="ryan.q@linux.com"
diff --git a/audio/apulse/slack-desc b/audio/apulse/slack-desc
new file mode 100644
index 0000000000..8365093622
--- /dev/null
+++ b/audio/apulse/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+apulse: apulse (pulseaudio emulation for ALSA)
+apulse:
+apulse: Run any program that requires pulseaudio simply by preceding it
+apulse: with 'apulse'.
+apulse:
+apulse: $ apulse <program> [parameters]
+apulse:
+apulse:
+apulse:
+apulse: https://github.com/i-rinat/apulse
+apulse: