summaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
author Marcel Saegebarth <marc@mos6581.de>2015-01-08 07:19:56 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-01-08 07:19:56 +0700
commitebd9442ef5a4d28f21d2fbaf091dc0405ea6fffc (patch)
tree1c7921a3c534bcb59e37115ed5ca88366db0ce33 /audio
parent8d4123ded114f6e1a04bfd70b2c456ea3bc879b4 (diff)
downloadslackbuilds-ebd9442ef5a4d28f21d2fbaf091dc0405ea6fffc.tar.gz
slackbuilds-ebd9442ef5a4d28f21d2fbaf091dc0405ea6fffc.tar.xz
audio/acousticbrainz-client: Added (Acoustic Music Scanner).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'audio')
-rw-r--r--audio/acousticbrainz-client/README4
-rw-r--r--audio/acousticbrainz-client/acousticbrainz-client.SlackBuild94
-rw-r--r--audio/acousticbrainz-client/acousticbrainz-client.info10
-rw-r--r--audio/acousticbrainz-client/slack-desc19
4 files changed, 127 insertions, 0 deletions
diff --git a/audio/acousticbrainz-client/README b/audio/acousticbrainz-client/README
new file mode 100644
index 0000000000..198a492168
--- /dev/null
+++ b/audio/acousticbrainz-client/README
@@ -0,0 +1,4 @@
+This client lets you submit your own audio features to the
+AcousticBrainz project.
+
+This is the CLI version.
diff --git a/audio/acousticbrainz-client/acousticbrainz-client.SlackBuild b/audio/acousticbrainz-client/acousticbrainz-client.SlackBuild
new file mode 100644
index 0000000000..99b16a134b
--- /dev/null
+++ b/audio/acousticbrainz-client/acousticbrainz-client.SlackBuild
@@ -0,0 +1,94 @@
+#!/bin/sh
+
+# Slackware build script for "acousticbrainz-client".
+
+# Copyright 2015 Marcel Saegebarth <marc@mos6581.de>
+# All rights reserved.
+#
+# Redistribution and use in source and binary forms, with or without
+# modification, are permitted provided that the following conditions are
+# met:
+#
+# * Redistributions of source code must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=acousticbrainz-client
+VERSION=${VERSION:-0.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$VERSION.tar.gz || tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# don't try to find and install the `streaming_extractor_music` binary as it is
+# already installed with package `acousticbrainz-music-extractor'
+sed -i '/data_files/d' setup.py
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+python setup.py build
+python setup.py install --root $PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COPYING README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/audio/acousticbrainz-client/acousticbrainz-client.info b/audio/acousticbrainz-client/acousticbrainz-client.info
new file mode 100644
index 0000000000..eb4d51a800
--- /dev/null
+++ b/audio/acousticbrainz-client/acousticbrainz-client.info
@@ -0,0 +1,10 @@
+PRGNAM="acousticbrainz-client"
+VERSION="0.1"
+HOMEPAGE="http://acousticbrainz.org/"
+DOWNLOAD="https://github.com/MTG/acousticbrainz-client/archive/0.1.tar.gz"
+MD5SUM="7565d115c04db46e394f05eb12109519"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="acousticbrainz-music-extractor"
+MAINTAINER="Marcel Saegebarth"
+EMAIL="marc@mos6581.de"
diff --git a/audio/acousticbrainz-client/slack-desc b/audio/acousticbrainz-client/slack-desc
new file mode 100644
index 0000000000..3f2f3d97ee
--- /dev/null
+++ b/audio/acousticbrainz-client/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+acousticbrainz-client: acousticbrainz-client (Acoustic Music Scanner)
+acousticbrainz-client:
+acousticbrainz-client: This client lets you submit your own audio features to the
+acousticbrainz-client: AcousticBrainz project.
+acousticbrainz-client:
+acousticbrainz-client: This is the CLI version.
+acousticbrainz-client:
+acousticbrainz-client: Homepage: http://acousticbrainz.org/
+acousticbrainz-client:
+acousticbrainz-client:
+acousticbrainz-client: