summaryrefslogtreecommitdiffstats
path: root/desktop
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2015-03-12 22:05:02 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-03-12 22:05:02 +0700
commite380924bb886aa0afa2ab995c796a5f1655121fb (patch)
treed12d11bb61bfef8bd2d7265966b6863c4807f26f /desktop
parent9f094957fa4f72980a145c9127502e87140a1b9b (diff)
downloadslackbuilds-e380924bb886aa0afa2ab995c796a5f1655121fb.tar.gz
slackbuilds-e380924bb886aa0afa2ab995c796a5f1655121fb.tar.xz
desktop/sun: Added (Slackware Update Notifier).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'desktop')
-rw-r--r--desktop/sun/README3
-rw-r--r--desktop/sun/doinst.sh3
-rw-r--r--desktop/sun/slack-desc19
-rw-r--r--desktop/sun/sun.SlackBuild101
-rw-r--r--desktop/sun/sun.info10
5 files changed, 136 insertions, 0 deletions
diff --git a/desktop/sun/README b/desktop/sun/README
new file mode 100644
index 0000000000..b3e8ea9ab8
--- /dev/null
+++ b/desktop/sun/README
@@ -0,0 +1,3 @@
+Slackware Update Notifier is a tray notification applet for informing
+about package updates in Slackware and CLI tool for monitoring upgraded
+packages.
diff --git a/desktop/sun/doinst.sh b/desktop/sun/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/desktop/sun/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/desktop/sun/slack-desc b/desktop/sun/slack-desc
new file mode 100644
index 0000000000..b2d270b6fe
--- /dev/null
+++ b/desktop/sun/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+sun: sun (Slackware Update Notifier)
+sun:
+sun: Slackware Update Notifier is a tray notification applet for informing
+sun: about package updates in Slackware and CLI tool for monitoring
+sun: upgraded packages.
+sun:
+sun: Homepage: https://github.com/dslackw/sun
+sun:
+sun:
+sun:
+sun:
diff --git a/desktop/sun/sun.SlackBuild b/desktop/sun/sun.SlackBuild
new file mode 100644
index 0000000000..4f666cb17d
--- /dev/null
+++ b/desktop/sun/sun.SlackBuild
@@ -0,0 +1,101 @@
+#!/bin/sh
+
+# Slackware build script for sun
+
+# Copyright 2015 Dimitris Zlatanidis Orestiada, Greece
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=sun
+VERSION=${VERSION:-1.0.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/v$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# avoid install configuration files over setup.py
+sed -i 's/if "install"/if ""/' setup.py
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/etc/$PRGNAM $PKG/etc/rc.d/ $PKG/usr/share/pixmaps
+
+# install configurations files
+install -D -m0644 conf/${PRGNAM}.conf $PKG/etc/$PRGNAM/${PRGNAM}.conf
+install -D -m0644 conf/mirrors $PKG/etc/$PRGNAM/mirrors
+
+# install rc file
+install -D -m0644 conf/rc.${PRGNAM} $PKG/etc/rc.d/rc.${PRGNAM}
+
+# install notify icon
+install -D -m0644 icon/${PRGNAM}.png $PKG/usr/share/pixmaps/${PRGNAM}.png
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README.rst ChangeLog.txt LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/desktop/sun/sun.info b/desktop/sun/sun.info
new file mode 100644
index 0000000000..75970c025a
--- /dev/null
+++ b/desktop/sun/sun.info
@@ -0,0 +1,10 @@
+PRGNAM="sun"
+VERSION="1.0.1"
+HOMEPAGE="https://github.com/dslackw/sun"
+DOWNLOAD="https://github.com/dslackw/sun/archive/v1.0.1.tar.gz"
+MD5SUM="16d5d46477d2705f670c8ff7d6bc302d"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"