summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Christoph Willing <chris.willing@iinet.net.au>2015-03-21 01:16:20 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-03-21 01:16:20 +0700
commit8b819e51b3af284f93e238d6ca109004d48982aa (patch)
treebf9282da00facbe8778ac55058e60dddb5f9a406 /development
parent9fcfabae620cc0e5e51782013a3343d99db4f5f6 (diff)
downloadslackbuilds-8b819e51b3af284f93e238d6ca109004d48982aa.tar.gz
slackbuilds-8b819e51b3af284f93e238d6ca109004d48982aa.tar.xz
development/numpy3: Added (Python extension).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/numpy3/README29
-rw-r--r--development/numpy3/numpy3.SlackBuild122
-rw-r--r--development/numpy3/numpy3.info10
-rw-r--r--development/numpy3/slack-desc19
4 files changed, 180 insertions, 0 deletions
diff --git a/development/numpy3/README b/development/numpy3/README
new file mode 100644
index 0000000000..f219a96c84
--- /dev/null
+++ b/development/numpy3/README
@@ -0,0 +1,29 @@
+NumPy is a general-purpose array-processing package designed to
+efficiently manipulate large multi-dimensional arrays of arbitrary
+records without sacrificing too much speed for small multi-dimensional
+arrays. NumPy is built on the Numeric code base and adds features
+introduced by numarray as well as an extended C-API and the ability to
+create arrays of arbitrary type which also makes NumPy suitable for
+interfacing with general-purpose data-base applications.
+
+There are also basic facilities for discrete fourier transform, basic
+linear algebra and random number generation.
+
+If you need to build numpy for debugging, set DEBUG=y. If software
+depending on numpy is having problems with the new relaxed strides
+checking, set NPY_RSC=0.
+
+It is highly recommended to install optimized BLAS and LAPACK libs
+before installing numpy. You may choose between ATLAS+LAPACK and
+OpenBLAS.
+
+IMPORTANT: The version installed by this SlackBuild does NOT include the
+ oldnumeric and numarray compatibility modules since starting with
+ version 1.9.0 these modules got removed by the numpy developers.
+ If you need these compatibility modules please consider the
+ numpy-legacy SlackBuild.
+ THUS: This SlackBuild conflicts with the numpy-legacy SlackBuild
+ which installs versions < 1.9.0!
+
+This numpy3 SlackBuild creates bindings for python3 and can be installed
+without conflict alongside the standard numpy SlackBuild.
diff --git a/development/numpy3/numpy3.SlackBuild b/development/numpy3/numpy3.SlackBuild
new file mode 100644
index 0000000000..ad074a021a
--- /dev/null
+++ b/development/numpy3/numpy3.SlackBuild
@@ -0,0 +1,122 @@
+#!/bin/sh
+
+# Slackware build script for numpy3
+
+# Copyright 2015 Christoph Willing Brisbane, Australia
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Based with thanks on original numpy scripts by
+# Aleksandar Samardzic <asamardzic@gmail.com> and Serban Udrea <S.Udrea@gsi.de>
+
+PRGNAM=numpy3
+SRCNAM=numpy
+VERSION=${VERSION:-1.9.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+PYTHON_VERSIONS="3" ;# NOTE! Could easily be PYTHON_VERSIONS="2 3"
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=${PKG:-$TMP/package-$PRGNAM}
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+cat > site.cfg <<EOF
+[amd]
+library_dirs = /usr/lib${LIBDIRSUFFIX}
+include_dirs = /usr/include/amd
+amd_libs = amd
+
+[umfpack]
+library_dirs = /usr/lib${LIBDIRSUFFIX}
+include_dirs = /usr/include/umfpack
+umfpack_libs = umfpack
+EOF
+
+
+DEBUG=${DEBUG:-no}
+
+case "$DEBUG" in
+ [yY]|[yY][eE][sS]) DEBUG="y" ;;
+ *) DEBUG="" ;;
+esac
+
+for v in $PYTHON_VERSIONS ; do
+ if [ $(which python$v 2>/dev/null) ]; then
+ if [ ! "$DEBUG" ]; then
+ NPY_RELAXED_STRIDES_CHECKING=${NPY_RSC:-1} python$v setup.py install --root $PKG
+
+ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+ else
+ NPY_RELAXED_STRIDES_CHECKING=${NPY_RSC:-1} python$v setup.py build --debug
+ python$v setup.py install --root $PKG
+ fi
+ fi
+done
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a COMPATIBILITY DEV_README.txt LICENSE.txt README.txt THANKS.txt \
+ $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc -type f -exec chmod 0644 {} \;
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/numpy3/numpy3.info b/development/numpy3/numpy3.info
new file mode 100644
index 0000000000..de8601ab5e
--- /dev/null
+++ b/development/numpy3/numpy3.info
@@ -0,0 +1,10 @@
+PRGNAM="numpy3"
+VERSION="1.9.1"
+HOMEPAGE="http://numpy.scipy.org/"
+DOWNLOAD="http://download.sourceforge.net/project/numpy/NumPy/1.9.1/numpy-1.9.1.tar.gz"
+MD5SUM="78842b73560ec378142665e712ae4ad9"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Christoph Willing"
+EMAIL="chris.willing@iinet.net.au"
diff --git a/development/numpy3/slack-desc b/development/numpy3/slack-desc
new file mode 100644
index 0000000000..54f162ff90
--- /dev/null
+++ b/development/numpy3/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+numpy3: NumPy (Python extension for scientific computing)
+numpy3:
+numpy3: NumPy is an extension to the Python programming language, adding
+numpy3: support for large, multi-dimensional arrays and matrices along
+numpy3: with a large library of high-level mathematical functions to
+numpy3: operate on these arrays.
+numpy3:
+numpy3: This packages contains NumPy for python3
+numpy3:
+numpy3: Homepage: http://numpy.scipy.org/
+numpy3: