summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2015-04-12 08:08:59 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-04-12 08:08:59 +0700
commit9c66c85ba48a8b809c93b0db3a4e893c610ef493 (patch)
treef4e2c2c510a24452572c06ace8b84dba599baad0 /development
parent15e0493775d1d4f2c4c323d7d62c8cd10cae9fc6 (diff)
downloadslackbuilds-9c66c85ba48a8b809c93b0db3a4e893c610ef493.tar.gz
slackbuilds-9c66c85ba48a8b809c93b0db3a4e893c610ef493.tar.xz
development/atasm: Added (mac/65 compatible cross-assembler).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/atasm/README6
-rw-r--r--development/atasm/atasm.SlackBuild82
-rw-r--r--development/atasm/atasm.info10
-rw-r--r--development/atasm/slack-desc19
4 files changed, 117 insertions, 0 deletions
diff --git a/development/atasm/README b/development/atasm/README
new file mode 100644
index 0000000000..f6d7f8db00
--- /dev/null
+++ b/development/atasm/README
@@ -0,0 +1,6 @@
+atasm (a mostly mac/65 compatible cross-assembler)
+
+ATasm is a 6502 command-line cross-assembler that is compatible with the
+original Mac/65 macroassembler released by OSS software. Code development
+can now be performed using modern editors and compiles with lightning
+speed.
diff --git a/development/atasm/atasm.SlackBuild b/development/atasm/atasm.SlackBuild
new file mode 100644
index 0000000000..c9e6eab134
--- /dev/null
+++ b/development/atasm/atasm.SlackBuild
@@ -0,0 +1,82 @@
+#!/bin/sh
+
+# Slackware build script for atasm
+
+# Written by B. Watson (yalhcru@gmail.com)
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+PRGNAM=atasm
+VERSION=${VERSION:-1.06}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+SRCDIR="${PRGNAM}${VERSION/./}"
+ZIPFILE="$SRCDIR.zip"
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCDIR
+unzip $CWD/$ZIPFILE
+cd $SRCDIR
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i "s,-O3.*,$SLKCFLAGS," src/Makefile
+mkdir -p $PKG/usr/bin $PKG/usr/man/man1 $PKG/usr/doc/$PRGNAM-$VERSION
+
+# 'make install' chokes because this file's missing:
+touch $PRGNAM.txt
+
+# N.B. nonstandard use of DESTDIR and MANDIR here.
+make -C src all install \
+ DESTDIR=$PKG/usr/bin \
+ MANDIR=$PKG/usr/man/man1 \
+ DOCDIR=$PKG/usr/doc/$PRGNAM-$VERSION
+
+strip $PKG/usr/bin/$PRGNAM
+gzip $PKG/usr/man/man1/$PRGNAM.1
+
+rm -f $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.txt
+cp -a LICENSE *.TXT docs/* examples $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/atasm/atasm.info b/development/atasm/atasm.info
new file mode 100644
index 0000000000..6f8cabb6d1
--- /dev/null
+++ b/development/atasm/atasm.info
@@ -0,0 +1,10 @@
+PRGNAM="atasm"
+VERSION="1.06"
+HOMEPAGE="http://atari.miribilist.com/atasm/"
+DOWNLOAD="http://downloads.sourceforge.net/project/atasm/atasm/atasm-1.06/atasm106.zip"
+MD5SUM="8019a72f5d27e4e563f433c9368a6c2c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"
diff --git a/development/atasm/slack-desc b/development/atasm/slack-desc
new file mode 100644
index 0000000000..14c7483c37
--- /dev/null
+++ b/development/atasm/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+atasm: atasm (a mostly mac/65 compatible cross-assembler)
+atasm:
+atasm: ATasm is a 6502 command-line cross-assembler that is compatible with
+atasm: the original Mac/65 macroassembler released by OSS software. Code
+atasm: development can now be performed using modern editors and compiles
+atasm: with lightning speed.
+atasm:
+atasm:
+atasm:
+atasm:
+atasm: