summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-02-05 04:58:12 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-02-05 06:47:42 +0700
commitdbb797aa873ce96f3d106a0e53679c3341f4492a (patch)
tree91d479ba0618eb4b6c1c24e44ae7e291af4e274b /development
parent00a0ee8f79b5a1a49ca49f7f385d4aceced9f1ee (diff)
downloadslackbuilds-dbb797aa873ce96f3d106a0e53679c3341f4492a.tar.gz
slackbuilds-dbb797aa873ce96f3d106a0e53679c3341f4492a.tar.xz
development/django: Removed (replaced with python-django).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/django/README9
-rw-r--r--development/django/django.SlackBuild69
-rw-r--r--development/django/django.info10
-rw-r--r--development/django/slack-desc19
4 files changed, 0 insertions, 107 deletions
diff --git a/development/django/README b/development/django/README
deleted file mode 100644
index 270c05d9d1..0000000000
--- a/development/django/README
+++ /dev/null
@@ -1,9 +0,0 @@
-Django is a high-level Python web framework that encourages rapid
-development and clean, pragmatic design. It includes a template
-engine, and an object-relational mapper.
-
-Although Django can be used without database functionality, it is
-especially useful with database support. Various databases are
-supported through Python database bindings. Due to the dynamic
-nature of Python software, database bindings are not required
-when Django is built and can be installed later.
diff --git a/development/django/django.SlackBuild b/development/django/django.SlackBuild
deleted file mode 100644
index 08852591c4..0000000000
--- a/development/django/django.SlackBuild
+++ /dev/null
@@ -1,69 +0,0 @@
-#!/bin/sh
-
-# SlackBuild for Django
-
-# Copyright 2009-2011 Carlos Corbacho <carlos@strangeworlds.co.uk>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=django
-VERSION=${VERSION:-1.3.1}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-SRCNAM=Django
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
-cd $SRCNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
-
-python setup.py install --prefix=/usr --root="$PKG"
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a AUTHORS LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/django/django.info b/development/django/django.info
deleted file mode 100644
index 84112eb243..0000000000
--- a/development/django/django.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="django"
-VERSION="1.3.1"
-HOMEPAGE="http://www.djangoproject.com/"
-DOWNLOAD="http://pypi.python.org/packages/source/D/Django/Django-1.3.1.tar.gz"
-MD5SUM="62d8642fd06b9a0bf8544178f8500767"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES=""
-MAINTAINER="Carlos Corbacho"
-EMAIL="carlos@strangeworlds.co.uk"
diff --git a/development/django/slack-desc b/development/django/slack-desc
deleted file mode 100644
index 235530464a..0000000000
--- a/development/django/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-django: django (Python web framework)
-django:
-django: Django is a high-level Python Web framework that encourages rapid
-django: development and clean, pragmatic design.
-django:
-django: Home Page: http://www.djangoproject.com
-django:
-django:
-django:
-django:
-django: