summaryrefslogtreecommitdiffstats
path: root/development
diff options
context:
space:
mode:
author Ryan P.C. McQuen <ryan.q@linux.com>2015-01-25 09:46:47 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-01-27 06:42:41 +0700
commitdef4b8b1fd743b26ca85473472a4a100da73982e (patch)
treec0d721cce2adbde907949364cd441c50134cb810 /development
parent89cda4f7dab9d8ceba60c948d8475ed896f39277 (diff)
downloadslackbuilds-def4b8b1fd743b26ca85473472a4a100da73982e.tar.gz
slackbuilds-def4b8b1fd743b26ca85473472a4a100da73982e.tar.xz
development/enki: Added (a text editor for programmers).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'development')
-rw-r--r--development/enki/README10
-rw-r--r--development/enki/enki.SlackBuild89
-rw-r--r--development/enki/enki.info10
-rw-r--r--development/enki/slack-desc19
4 files changed, 128 insertions, 0 deletions
diff --git a/development/enki/README b/development/enki/README
new file mode 100644
index 0000000000..89cc6214a3
--- /dev/null
+++ b/development/enki/README
@@ -0,0 +1,10 @@
+Enki is a text editor for programmers. It is:
+
+ User friendly. Intuitive interface. Works out of the box. You don’t have to read a lot of docs
+ Hacker friendly. Work as quickly as possible. You don’t need your mouse for coding.
+ Lighweight. Some IDEs show splashscreen. Enki will never do it. It just starts quickly.
+ Advanced. You invent software. An editor helps you to do a routine job.
+ Extensible. Operating systems are designed for running applications. Enki is designed for running plugins.
+ Cross platform. Use your habitual editor on any OS. Currently has beeen tested on Linux, MacOS X, Windows.
+ High quality. No long list of fancy features. But, what is done, is done well.
+ Open source. In GitHub we trust.
diff --git a/development/enki/enki.SlackBuild b/development/enki/enki.SlackBuild
new file mode 100644
index 0000000000..196e648e2b
--- /dev/null
+++ b/development/enki/enki.SlackBuild
@@ -0,0 +1,89 @@
+#!/bin/sh
+# Slackware build script for enki
+# Ryan P.C. McQuen | Everett, WA | ryan.q@linux.com
+
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version, with the following exception:
+# the text of the GPL license may be omitted.
+
+# This program is distributed in the hope that it will be useful, but
+# without any warranty; without even the implied warranty of
+# merchantability or fitness for a particular purpose. Compiling,
+# interpreting, executing or merely reading the text of the program
+# may result in lapses of consciousness and/or very being, up to and
+# including the end of all existence and the Universe as we know it.
+# See the GNU General Public License for more details.
+
+# You may have received a copy of the GNU General Public License along
+# with this program (most likely, a file named COPYING). If not, see
+# <http://www.gnu.org/licenses/>.
+
+PRGNAM=enki
+VERSION=${VERSION:-14.07.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+DOCS="ChangeLog LICENSE.GPL2 README.md doc/"
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+if [ -e $CWD/v$VERSION.tar.gz ]; then
+ tar xvf $CWD/v$VERSION.tar.gz
+else
+ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+fi
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/development/enki/enki.info b/development/enki/enki.info
new file mode 100644
index 0000000000..9f1679eb0c
--- /dev/null
+++ b/development/enki/enki.info
@@ -0,0 +1,10 @@
+PRGNAM="enki"
+VERSION="14.07.2"
+HOMEPAGE="https://github.com/hlamer/enki"
+DOWNLOAD="https://github.com/hlamer/enki/archive/v14.07.2.tar.gz"
+MD5SUM="d5881aa4b91c33f79843eb0f996c2968"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pyparsing qutepart"
+MAINTAINER="Ryan P.C. McQuen"
+EMAIL="ryan.q@linux.com"
diff --git a/development/enki/slack-desc b/development/enki/slack-desc
new file mode 100644
index 0000000000..6517965006
--- /dev/null
+++ b/development/enki/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+enki: enki (a text editor for programmers)
+enki:
+enki: Enki is a text editor for programmers.
+enki:
+enki:
+enki:
+enki:
+enki:
+enki: https://github.com/hlamer/enki
+enki:
+enki: