summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2014-04-18 08:53:43 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-04-23 07:51:42 +0700
commit6234dabd2741a19fb07e72f04c32e4c9e884e1a8 (patch)
treebde0970b36529a35f503f81466a2041831107070 /games
parent733a1b108fe1b49e168d8f25cabff664d54f2860 (diff)
downloadslackbuilds-6234dabd2741a19fb07e72f04c32e4c9e884e1a8.tar.gz
slackbuilds-6234dabd2741a19fb07e72f04c32e4c9e884e1a8.tar.xz
games/penguin-command: Added (Missile Command clone).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/penguin-command/README11
-rw-r--r--games/penguin-command/doinst.sh3
-rw-r--r--games/penguin-command/penguin-command.SlackBuild98
-rw-r--r--games/penguin-command/penguin-command.desktop8
-rw-r--r--games/penguin-command/penguin-command.info10
-rw-r--r--games/penguin-command/penguin-command.pngbin0 -> 2168 bytes
-rw-r--r--games/penguin-command/slack-desc19
-rw-r--r--games/penguin-command/windowed_default.diff28
8 files changed, 177 insertions, 0 deletions
diff --git a/games/penguin-command/README b/games/penguin-command/README
new file mode 100644
index 0000000000..01f232300e
--- /dev/null
+++ b/games/penguin-command/README
@@ -0,0 +1,11 @@
+penguin-command (Missile Command clone)
+
+This is a clone of the classic "Missile Command" Game, but it has better
+graphics and music. The gameplay has only been slightly modified. Penguin
+Command is licensed under the GPL.
+
+By default, the game runs fullscreen unless you pass it the -w option. If
+you want to patch the code so the game starts in a window by default,
+set WINDOWED=yes in the SlackBuild script's environment. This only
+changes the default, it will still be possible to use the -f option to
+get fullscreen mode, or press Alt-Enter to toggle fullscreen mode.
diff --git a/games/penguin-command/doinst.sh b/games/penguin-command/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/games/penguin-command/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/games/penguin-command/penguin-command.SlackBuild b/games/penguin-command/penguin-command.SlackBuild
new file mode 100644
index 0000000000..f69b373b2c
--- /dev/null
+++ b/games/penguin-command/penguin-command.SlackBuild
@@ -0,0 +1,98 @@
+#!/bin/sh
+
+# Slackware build script for penguin-command
+
+# Written by B. Watson (yalhcru@gmail.com)
+
+# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+
+PRGNAM=penguin-command
+VERSION=${VERSION:-1.6.11}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# I included this optional patch because the game doesn't store a
+# fullscreen/windowed preference in its config file, and because on
+# one of my test boxes, the game crashes if run fullscreen (on the other
+# text box, it's fine, so your mileage may vary).
+if [ "${WINDOWED:-no}" = "yes" ]; then
+ patch -p1 < $CWD/windowed_default.diff
+fi
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+./configure \
+ --bindir=/usr/games \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --build=$ARCH-slackware-linux
+
+make
+make install-strip DESTDIR=$PKG
+
+gzip $PKG/usr/man/man6/*.6
+
+# .desktop based on penguin-command.spec
+mkdir -p $PKG/usr/share/applications
+cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
+
+# icon converted from data/gfx/icon.xpm
+mkdir -p $PKG/usr/share/pixmaps
+cat $CWD/$PRGNAM.png > $PKG/usr/share/pixmaps/$PRGNAM.png
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS COPYING ChangeLog NEWS README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/games/penguin-command/penguin-command.desktop b/games/penguin-command/penguin-command.desktop
new file mode 100644
index 0000000000..54a06a9866
--- /dev/null
+++ b/games/penguin-command/penguin-command.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Name=Penguin-Command
+Type=Application
+Comment=Missile Attack game
+Exec=penguin-command
+Icon=penguin-command
+Terminal=false
+Categories=Game;ArcadeGame;
diff --git a/games/penguin-command/penguin-command.info b/games/penguin-command/penguin-command.info
new file mode 100644
index 0000000000..6eceae7f0b
--- /dev/null
+++ b/games/penguin-command/penguin-command.info
@@ -0,0 +1,10 @@
+PRGNAM="penguin-command"
+VERSION="1.6.11"
+HOMEPAGE="http://www.linux-games.com/penguin-command/"
+DOWNLOAD="http://downloads.sourceforge.net/project/penguin-command/penguin-command/1.6.11/penguin-command-1.6.11.tar.gz"
+MD5SUM="4dcf0073d62f28e47af18a922a1badc3"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="B. Watson"
+EMAIL="yalhcru@gmail.com"
diff --git a/games/penguin-command/penguin-command.png b/games/penguin-command/penguin-command.png
new file mode 100644
index 0000000000..de182fb5fe
--- /dev/null
+++ b/games/penguin-command/penguin-command.png
Binary files differ
diff --git a/games/penguin-command/slack-desc b/games/penguin-command/slack-desc
new file mode 100644
index 0000000000..da80fca194
--- /dev/null
+++ b/games/penguin-command/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+penguin-command: penguin-command (Missile Command clone)
+penguin-command:
+penguin-command: This is a clone of the classic "Missile Command" Game, but it has
+penguin-command: better graphics and music. The gameplay has only been slightly
+penguin-command: modified. Penguin Command is licensed under the GPL.
+penguin-command:
+penguin-command:
+penguin-command:
+penguin-command:
+penguin-command:
+penguin-command:
diff --git a/games/penguin-command/windowed_default.diff b/games/penguin-command/windowed_default.diff
new file mode 100644
index 0000000000..1e7d60dc11
--- /dev/null
+++ b/games/penguin-command/windowed_default.diff
@@ -0,0 +1,28 @@
+diff -Naur penguin-command-1.6.11/penguin-command.6 penguin-command-1.6.11.patched/penguin-command.6
+--- penguin-command-1.6.11/penguin-command.6 2007-03-18 11:21:13.000000000 -0400
++++ penguin-command-1.6.11.patched/penguin-command.6 2014-04-17 19:15:48.000000000 -0400
+@@ -16,10 +16,10 @@
+ .SH OPTIONS
+ .TP
+ .B \-\-fullscreen, \-f
+-Run in fullscreen mode (default).
++Run in fullscreen mode.
+ .TP
+ .B \-\-windowed, \-w
+-Run in windowed mode.
++Run in windowed mode (default).
+ .TP
+ .B \-\-nosound, \-s
+ Run without sound.
+diff -Naur penguin-command-1.6.11/src/main.c penguin-command-1.6.11.patched/src/main.c
+--- penguin-command-1.6.11/src/main.c 2007-03-18 11:21:13.000000000 -0400
++++ penguin-command-1.6.11.patched/src/main.c 2014-04-17 19:15:05.000000000 -0400
+@@ -32,7 +32,7 @@
+ #endif
+
+
+- int fullscreen=1, CityDestroyed[6]={0,0,0,0,0,0},
++ int fullscreen=0, CityDestroyed[6]={0,0,0,0,0,0},
+ CannonDestroyed[3]={0,0,0}, Score=0, HWCursor=0, NoAlpha=0, ArcadeMode=0, MusicVol=10, SoundVol=10;
+ //images
+ SDL_Surface *ShotPic,*CityPic,*BackPic,*CityHitPic,*Cannon[21],*Font,