summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2014-04-22 07:37:13 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-04-23 07:51:56 +0700
commit6de96aac5fe7da68f7b806c840848a40ab951b4b (patch)
tree4877f3b4813cf17f285bde57717e95df9da83717 /games
parentd7d1327dc1a3c5d88d6b4294cb27c419bb185af4 (diff)
downloadslackbuilds-6de96aac5fe7da68f7b806c840848a40ab951b4b.tar.gz
slackbuilds-6de96aac5fe7da68f7b806c840848a40ab951b4b.tar.xz
games/BeastieWorker: Added (3D sokoban-like game).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/BeastieWorker/BeastieWorker.SlackBuild112
-rw-r--r--games/BeastieWorker/BeastieWorker.desktop10
-rw-r--r--games/BeastieWorker/BeastieWorker.info10
-rw-r--r--games/BeastieWorker/BeastieWorker.sh3
-rw-r--r--games/BeastieWorker/Makefile.patch13
-rw-r--r--games/BeastieWorker/Makefile_x64.patch13
-rw-r--r--games/BeastieWorker/README2
-rw-r--r--games/BeastieWorker/doinst.sh3
-rw-r--r--games/BeastieWorker/slack-desc19
9 files changed, 185 insertions, 0 deletions
diff --git a/games/BeastieWorker/BeastieWorker.SlackBuild b/games/BeastieWorker/BeastieWorker.SlackBuild
new file mode 100644
index 0000000000..9e09f319b8
--- /dev/null
+++ b/games/BeastieWorker/BeastieWorker.SlackBuild
@@ -0,0 +1,112 @@
+#!/bin/sh
+
+# Slackware build script for BeastieWorker
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=BeastieWorker
+VERSION=${VERSION:-0.4}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+if [ "$ARCH" = "x86_64" ]; then
+ patch -p1 < $CWD/Makefile_x64.patch
+else
+ patch -p1 < $CWD/Makefile.patch
+fi
+
+make -C src
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+SRCDIRS="levels model sounds textures"
+
+for i in $SRCDIRS; do
+ mkdir -p $PKG/usr/share/games/$PRGNAM/$i
+ cp -rf $i $PKG/usr/share/games/$PRGNAM
+done
+
+mkdir -p $PKG/usr/bin
+install -D -m0755 $PRGNAM $PKG/usr/share/games/$PRGNAM/$PRGNAM
+install -D -m0755 $CWD/$PRGNAM.sh $PKG/usr/bin/$PRGNAM
+
+mkdir -p $PKG/usr/share/applications
+install -D -m644 $CWD/$PRGNAM.desktop $PKG/usr/share/applications/$PRGNAM.desktop
+
+# converted bmp icon to png file
+convert textures/beasty.bmp $PRGNAM.png
+
+mkdir -p $PKG/usr/share/pixmaps/
+install -D -m644 $PRGNAM.png $PKG/usr/share/pixmaps/$PRGNAM.png
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/games/BeastieWorker/BeastieWorker.desktop b/games/BeastieWorker/BeastieWorker.desktop
new file mode 100644
index 0000000000..7feedafdbf
--- /dev/null
+++ b/games/BeastieWorker/BeastieWorker.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name= BeastieWorker
+Name[he]= BeastieWorker
+Comment= BeastieWorker is 3D sokoban-like game
+Exec=BeastieWorker
+Icon=BeastieWorker
+Terminal=false
+Type=Application
+Categories=Game;Puzzle;
+GenericName=Game
diff --git a/games/BeastieWorker/BeastieWorker.info b/games/BeastieWorker/BeastieWorker.info
new file mode 100644
index 0000000000..c7701eb219
--- /dev/null
+++ b/games/BeastieWorker/BeastieWorker.info
@@ -0,0 +1,10 @@
+PRGNAM="BeastieWorker"
+VERSION="0.4"
+HOMEPAGE="http://beastieworker.sourceforge.net"
+DOWNLOAD="http://sourceforge.net/projects/beastieworker/files/beastieworker/0.4/BeastieWorker-0.4.tar.gz"
+MD5SUM="cdb838c8cb38652d81fda81fd0787ee0"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/games/BeastieWorker/BeastieWorker.sh b/games/BeastieWorker/BeastieWorker.sh
new file mode 100644
index 0000000000..4495af2c81
--- /dev/null
+++ b/games/BeastieWorker/BeastieWorker.sh
@@ -0,0 +1,3 @@
+#!/bin/sh
+cd /usr/share/games/BeastieWorker
+./BeastieWorker
diff --git a/games/BeastieWorker/Makefile.patch b/games/BeastieWorker/Makefile.patch
new file mode 100644
index 0000000000..56e2a0017f
--- /dev/null
+++ b/games/BeastieWorker/Makefile.patch
@@ -0,0 +1,13 @@
+--- BeastieWorker-0.4/src/Makefile.original 2014-04-21 12:16:55.317087746 +0300
++++ BeastieWorker-0.4/src/Makefile 2014-04-21 13:35:23.362229082 +0300
+@@ -3,8 +3,8 @@
+ DEL=rm
+
+ LFLAGS= -O2 -pthread
+-INCS= -I/usr/local/include/SDL11 -I/usr/X11R6/include/
+-LIBS= -L/usr/local/lib -lSDL-1.1 -L/usr/X11R6/lib -lGL -lGLU
++INCS= -I/usr/include/SDL -I/usr/X11R6/include/
++LIBS= -L/usr/lib -lSDL -L/usr/X11R6/lib -lGL -lGLU
+ OBJS= cursor.o font.o main.o matrixmath.o menu.o model3d.o player.o scene.o sound.o strings.o texture.o sky.o
+ MAIN= BeastieWorker
+
diff --git a/games/BeastieWorker/Makefile_x64.patch b/games/BeastieWorker/Makefile_x64.patch
new file mode 100644
index 0000000000..8d7e0058fb
--- /dev/null
+++ b/games/BeastieWorker/Makefile_x64.patch
@@ -0,0 +1,13 @@
+--- BeastieWorker-0.4/src/Makefile.original 2014-04-21 12:16:55.317087746 +0300
++++ BeastieWorker-0.4/src/Makefile 2014-04-21 12:27:11.491384507 +0300
+@@ -3,8 +3,8 @@
+ DEL=rm
+
+ LFLAGS= -O2 -pthread
+-INCS= -I/usr/local/include/SDL11 -I/usr/X11R6/include/
+-LIBS= -L/usr/local/lib -lSDL-1.1 -L/usr/X11R6/lib -lGL -lGLU
++INCS= -I/usr/include/SDL -I/usr/X11R6/include/
++LIBS= -L/usr/lib64 -lSDL -L/usr/X11R6/lib64 -lGL -lGLU
+ OBJS= cursor.o font.o main.o matrixmath.o menu.o model3d.o player.o scene.o sound.o strings.o texture.o sky.o
+ MAIN= BeastieWorker
+
diff --git a/games/BeastieWorker/README b/games/BeastieWorker/README
new file mode 100644
index 0000000000..8e7d671993
--- /dev/null
+++ b/games/BeastieWorker/README
@@ -0,0 +1,2 @@
+BeastieWorker is 3D game. New realization of the known game
+"sokoban".
diff --git a/games/BeastieWorker/doinst.sh b/games/BeastieWorker/doinst.sh
new file mode 100644
index 0000000000..5fb28930db
--- /dev/null
+++ b/games/BeastieWorker/doinst.sh
@@ -0,0 +1,3 @@
+if [ -x /usr/bin/update-desktop-database ]; then
+ /usr/bin/update-desktop-database -q usr/share/applications >/dev/null 2>&1
+fi
diff --git a/games/BeastieWorker/slack-desc b/games/BeastieWorker/slack-desc
new file mode 100644
index 0000000000..44bf41bf8c
--- /dev/null
+++ b/games/BeastieWorker/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+BeastieWorker: BeastieWorker (3D sokoban-like game)
+BeastieWorker:
+BeastieWorker: BeastieWorker is 3D game. New realization of the known game
+BeastieWorker: "sokoban".
+BeastieWorker:
+BeastieWorker: Homepage: http://beastieworker.sourceforge.net
+BeastieWorker:
+BeastieWorker:
+BeastieWorker:
+BeastieWorker:
+BeastieWorker: