summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author Larry Hajali <larryhaja@gmail.com>2014-05-18 23:36:40 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-05-18 23:36:40 +0700
commit93ef5a231b5699f1866779050e28dd26c5ce570f (patch)
tree48797e49f86fbdcadef9e556101c42c21ba3e5d1 /games
parent329f10a6ec1acc0e6fb96c0a16b55b75f800e14e (diff)
downloadslackbuilds-93ef5a231b5699f1866779050e28dd26c5ce570f.tar.gz
slackbuilds-93ef5a231b5699f1866779050e28dd26c5ce570f.tar.xz
games/dolphin-emu: Updated for version 4.0.2.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/dolphin-emu/README6
-rw-r--r--games/dolphin-emu/dolphin-emu.141
-rw-r--r--games/dolphin-emu/dolphin-emu.SlackBuild15
-rw-r--r--games/dolphin-emu/dolphin-emu.info8
4 files changed, 55 insertions, 15 deletions
diff --git a/games/dolphin-emu/README b/games/dolphin-emu/README
index 10d3a9a98c..0afc8b8d0d 100644
--- a/games/dolphin-emu/README
+++ b/games/dolphin-emu/README
@@ -6,5 +6,7 @@ lesser known titles can be hit or miss. Triforce compatibility is
currently limited to a couple of games - others require more of the
Triforce-specific peripheral devices to be emulated.
-Optional dependencies are SFML, OpenAL, portaudio, pulseaudio, soil,
-SDL2, miniupnpc, soundtouch and ffmpeg.
+Optional dependencies: are SFML, OpenAL, portaudio, pulseaudio, soil,
+SDL2, miniupnpc, soundtouch and ffmpeg
+
+Optional dependencies not on SBo: wayland and polarssl
diff --git a/games/dolphin-emu/dolphin-emu.1 b/games/dolphin-emu/dolphin-emu.1
new file mode 100644
index 0000000000..43f2844c22
--- /dev/null
+++ b/games/dolphin-emu/dolphin-emu.1
@@ -0,0 +1,41 @@
+.TH DOLPHIN-EMU 1 "December 10, 2010"
+.SH NAME
+dolphin-emu \- A Gamecube, Wii and Triforce (the arcade machine based on the
+Gamecube) emulator.
+.SH SYNOPSIS
+.B dolphin-emu
+.RI [ options ]
+.SH DESCRIPTION
+.B dolphin-emu
+is a Gamecube, Wii and Triforce (the arcade machine based on the
+Gamecube) emulator.
+.P
+Gamecube compatibility is okay - lots of games work, many games don't work.
+.P
+Wii compatibility is also good - a lot of games do work. Wii emulation
+generally requires a bit more computing power than Gamecube emulation, though.
+.P
+Triforce compatibility is not really known yet, but at least one game runs,
+with minor glitches.
+.SH OPTIONS
+.TP
+.BI "\-A, \-\-audio-plugin="plugin
+Specify an audio plugin
+.TP
+.B \-b, \-\-batch
+Exit application when emulator closes
+.TP
+.B \-d, \-\-debugger
+Open the debugger
+.TP
+.BI "\-e, \-\-exec="file
+Loads the specified file (DOL, ELF, WAD, GCM, ISO)
+.TP
+.B \-l, \-\-logger
+Open the logger
+.TP
+.BI "\-V, \-\-video-plugin="plugin
+Specify a video plugin
+.SH AUTHOR
+This manual page was written by Glenn Rice <glennricster@gmail.com>,
+for the Debian system (but may be used by others).
diff --git a/games/dolphin-emu/dolphin-emu.SlackBuild b/games/dolphin-emu/dolphin-emu.SlackBuild
index 8adfd02898..ec37ed1a0d 100644
--- a/games/dolphin-emu/dolphin-emu.SlackBuild
+++ b/games/dolphin-emu/dolphin-emu.SlackBuild
@@ -23,7 +23,7 @@
# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=dolphin-emu
-VERSION=${VERSION:-4.0}
+VERSION=${VERSION:-4.0.2}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -59,9 +59,9 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM
-unzip $CWD/${PRGNAM/-*/}-$VERSION-src.zip
-cd $PRGNAM
+rm -rf ${PRGNAM/-*/}-$VERSION
+tar xvf $CWD/${PRGNAM/-*/}-$VERSION.tar.gz || tar xvf $CWD/$VERSION.tar.gz
+cd ${PRGNAM/-*/}-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
@@ -69,10 +69,6 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Force dolphin-emu to use internal polarssl. Dolphin-emu fails to build
-# when polarssl >= 1.3.x is installed.
-sed -i 's|include(FindPolarSSL)|#&|' CMakeLists.txt
-
mkdir build
cd build
cmake -G "Unix Makefiles" \
@@ -98,7 +94,8 @@ for i in 16 32 48 64 128; do
done
# Remove unnecessary files/directories.
-rm -rf $PKG/usr/share/pixmaps $PKG/usr/lib${LIBDIRSUFFIX}/libpolarssl.a
+rm -rf $PKG/usr/lib${LIBDIRSUFFIX}/libpolarssl.a
+find $PKG -type d -empty -delete
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a license.txt Readme.txt $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/games/dolphin-emu/dolphin-emu.info b/games/dolphin-emu/dolphin-emu.info
index 0b52181861..b7a379cb42 100644
--- a/games/dolphin-emu/dolphin-emu.info
+++ b/games/dolphin-emu/dolphin-emu.info
@@ -1,10 +1,10 @@
PRGNAM="dolphin-emu"
-VERSION="4.0"
+VERSION="4.0.2"
HOMEPAGE="http://dolphin-emu.org/"
-DOWNLOAD="https://dolphin-emu.googlecode.com/files/dolphin-4.0-src.zip"
-MD5SUM="ff91b3efadbdaedd24eec70cc2828557"
+DOWNLOAD="https://github.com/dolphin-emu/dolphin/archive/4.0.2.tar.gz"
+MD5SUM="95436ade64fc8ed2fe4b2ed5306dc879"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="%README% nvidia-cg-toolkit"
+REQUIRES="nvidia-cg-toolkit"
MAINTAINER="Larry Hajali"
EMAIL="larryhaja[at]gmail[dot]com"