summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author Larry Hajali <larryhaja@gmail.com>2014-11-12 08:00:31 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-11-12 08:19:54 +0700
commita548727b296be8f78a21dea7c3c313c72d45bfe1 (patch)
tree268a85da1b4fed9ab070e6107c37974c7018f276 /games
parent24b74620acc47456dac02e212b4c7eea386cd389 (diff)
downloadslackbuilds-a548727b296be8f78a21dea7c3c313c72d45bfe1.tar.gz
slackbuilds-a548727b296be8f78a21dea7c3c313c72d45bfe1.tar.xz
games/dolphin-emu: Update DEPS and README.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/dolphin-emu/README15
-rw-r--r--games/dolphin-emu/dolphin-emu-4.0-gtk3.patch33
-rw-r--r--games/dolphin-emu/dolphin-emu.SlackBuild14
-rw-r--r--games/dolphin-emu/dolphin-emu.desktop11
4 files changed, 54 insertions, 19 deletions
diff --git a/games/dolphin-emu/README b/games/dolphin-emu/README
index 0afc8b8d0d..a7c19a0922 100644
--- a/games/dolphin-emu/README
+++ b/games/dolphin-emu/README
@@ -7,6 +7,17 @@ currently limited to a couple of games - others require more of the
Triforce-specific peripheral devices to be emulated.
Optional dependencies: are SFML, OpenAL, portaudio, pulseaudio, soil,
-SDL2, miniupnpc, soundtouch and ffmpeg
+SDL2, miniupnpc, soundtouch, ffmpeg and wxGTK3
-Optional dependencies not on SBo: wayland and polarssl
+Optional dependencies (not used): wayland and polarssl (version < 1.3)
+
+Note: Wayland support is not enabled even if it is installed. Dolphin
+requires mesa to be rebuilt with Wayland support using the following
+configure parameters.
+
+ --with-egl-platforms=x11,drm,wayland
+
+In addition to adding Wayland support to mesa, libxkbcommon needs to
+be installed (version >= 0.4.0) that also requires xcb >= 1.10.
+
+Note: polarssl is not use as the version at SBo is too new.
diff --git a/games/dolphin-emu/dolphin-emu-4.0-gtk3.patch b/games/dolphin-emu/dolphin-emu-4.0-gtk3.patch
new file mode 100644
index 0000000000..9f0b3aa9f3
--- /dev/null
+++ b/games/dolphin-emu/dolphin-emu-4.0-gtk3.patch
@@ -0,0 +1,33 @@
+diff -rupN dolphin-emu-2879cbd2b564-orig/CMakeLists.txt dolphin-emu-2879cbd2b564/CMakeLists.txt
+--- dolphin-emu-2879cbd2b564-orig/CMakeLists.txt 2014-03-07 20:10:55.185158971 -0500
++++ dolphin-emu-2879cbd2b564/CMakeLists.txt 2014-03-07 20:16:00.388691555 -0500
+@@ -707,13 +707,11 @@ if(NOT DISABLE_WX AND NOT ANDROID)
+ OUTPUT_VARIABLE DIST_NAME
+ ERROR_QUIET OUTPUT_STRIP_TRAILING_WHITESPACE)
+ if(${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}.${CMAKE_PATCH_VERSION}
+- VERSION_EQUAL 2.8.2 OR "${DIST_NAME}" STREQUAL "natty")
+- check_lib(GTK2 gtk+-2.0 gtk.h REQUIRED)
++ VERSION_EQUAL 2.8.12 OR "${DIST_NAME}" STREQUAL "natty")
++ check_lib(GTK3 gtk+-3.0 gtk.h REQUIRED)
+ else()
+- include(FindGTK2)
+- if(GTK2_FOUND)
+- include_directories(${GTK2_INCLUDE_DIRS})
+- endif()
++ include(FindGTK)
++ include_directories(${GTK3_INCLUDE_DIRS})
+ endif()
+ endif()
+
+diff -rupN dolphin-emu-2879cbd2b564-orig/Source/Core/DolphinWX/CMakeLists.txt dolphin-emu-2879cbd2b564/Source/Core/DolphinWX/CMakeLists.txt
+--- dolphin-emu-2879cbd2b564-orig/Source/Core/DolphinWX/CMakeLists.txt 2014-03-07 20:10:55.186158963 -0500
++++ dolphin-emu-2879cbd2b564/Source/Core/DolphinWX/CMakeLists.txt 2014-03-07 20:18:55.977272101 -0500
+@@ -11,7 +11,7 @@ set(LIBS core
+ audiocommon
+ z
+ sfml-network
+- ${GTK2_LIBRARIES})
++ ${GTK3_LIBRARIES})
+
+ if(NOT ANDROID)
+ if(USE_X11)
diff --git a/games/dolphin-emu/dolphin-emu.SlackBuild b/games/dolphin-emu/dolphin-emu.SlackBuild
index ec37ed1a0d..c5c4f0c005 100644
--- a/games/dolphin-emu/dolphin-emu.SlackBuild
+++ b/games/dolphin-emu/dolphin-emu.SlackBuild
@@ -2,7 +2,7 @@
# Slackware build script for dolphin-emu
-# Copyright 2013 Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2013-2014 Larry Hajali <larryhaja[at]gmail[dot]com>
# All rights reserved.
#
# Redistribution and use of this script, with or without modification, is
@@ -24,7 +24,7 @@
PRGNAM=dolphin-emu
VERSION=${VERSION:-4.0.2}
-BUILD=${BUILD:-1}
+BUILD=${BUILD:-2}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -64,10 +64,12 @@ tar xvf $CWD/${PRGNAM/-*/}-$VERSION.tar.gz || tar xvf $CWD/$VERSION.tar.gz
cd ${PRGNAM/-*/}-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+patch -p1 < $CWD/dolphin-emu-4.0-gtk3.patch
mkdir build
cd build
diff --git a/games/dolphin-emu/dolphin-emu.desktop b/games/dolphin-emu/dolphin-emu.desktop
deleted file mode 100644
index 96317d168b..0000000000
--- a/games/dolphin-emu/dolphin-emu.desktop
+++ /dev/null
@@ -1,11 +0,0 @@
-[Desktop Entry]
-Version=1.0
-Type=Application
-Name=Dolphin
-Categories=Game;Emulator;GTK;
-GenericName=GameCube and Wii Emulator
-Comment=An emulator for the GameCube and Wii consoles
-Exec=dolphin-emu
-Icon=dolphin-emu
-StartupNotify=false
-Name[en_US]=Dolphin