summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author Ryan P.C. McQuen <ryan.q@linux.com>2014-12-11 12:45:55 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-12-12 07:49:06 +0700
commitba3664335fd5418af16ece27605441425e37a2b5 (patch)
tree086243c1723588bce42b1992ea60223277def6e4 /games
parent6b641fb4c5f80eeab2a10d80ed1b5c60f9513927 (diff)
downloadslackbuilds-ba3664335fd5418af16ece27605441425e37a2b5.tar.gz
slackbuilds-ba3664335fd5418af16ece27605441425e37a2b5.tar.xz
games/lutris: Added (Open Gaming Platform).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'games')
-rw-r--r--games/lutris/README8
-rw-r--r--games/lutris/lutris.SlackBuild71
-rw-r--r--games/lutris/lutris.info10
-rw-r--r--games/lutris/slack-desc19
4 files changed, 108 insertions, 0 deletions
diff --git a/games/lutris/README b/games/lutris/README
new file mode 100644
index 0000000000..9208d86053
--- /dev/null
+++ b/games/lutris/README
@@ -0,0 +1,8 @@
+Lutris is an open gaming platform for Linux.
+
+It helps you install and manage your games in a unified interface.
+
+Our goal is to support every game which runs on Linux,
+from native to Windows games (via Wine) to emulators and
+browser games. The desktop application and the website
+are libre software, your contributions are welcome!
diff --git a/games/lutris/lutris.SlackBuild b/games/lutris/lutris.SlackBuild
new file mode 100644
index 0000000000..42b31e005c
--- /dev/null
+++ b/games/lutris/lutris.SlackBuild
@@ -0,0 +1,71 @@
+#!/bin/sh
+# Slackware build script for lutris
+# Ryan P.C. McQuen | Everett, WA | ryan.q@linux.com
+
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version, with the following exception:
+# the text of the GPL license may be omitted.
+
+# This program is distributed in the hope that it will be useful, but
+# without any warranty; without even the implied warranty of
+# merchantability or fitness for a particular purpose. Compiling,
+# interpreting, executing or merely reading the text of the program
+# may result in lapses of consciousness and/or very being, up to and
+# including the end of all existence and the Universe as we know it.
+# See the GNU General Public License for more details.
+
+# You may have received a copy of the GNU General Public License along
+# with this program (most likely, a file named COPYING). If not, see
+# <http://www.gnu.org/licenses/>.
+
+PRGNAM=lutris
+VERSION=${VERSION:-0.3.6.3}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=${PKG:-$TMP/package-$PRGNAM}
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM
+tar xvf $CWD/$PRGNAM\_$VERSION.tar.gz
+cd $PRGNAM
+
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root $PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a AUTHORS CHANGELOG COPYING INSTALL INSTALL.rst README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+find $PKG/usr/doc -type f -exec chmod 0644 {} \;
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/games/lutris/lutris.info b/games/lutris/lutris.info
new file mode 100644
index 0000000000..5fa1bec413
--- /dev/null
+++ b/games/lutris/lutris.info
@@ -0,0 +1,10 @@
+PRGNAM="lutris"
+VERSION="0.3.6.3"
+HOMEPAGE="https://lutris.net/"
+DOWNLOAD="http://lutris.net/releases/lutris_0.3.6.3.tar.gz"
+MD5SUM="f2453a7974182493339edd1901d8f88b"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="PyYAML pygobject3 pyxdg"
+MAINTAINER="Ryan P.C. McQuen"
+EMAIL="ryan.q@linux.com"
diff --git a/games/lutris/slack-desc b/games/lutris/slack-desc
new file mode 100644
index 0000000000..335a02d3a7
--- /dev/null
+++ b/games/lutris/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+lutris: Lutris (Open Gaming Platform)
+lutris:
+lutris: Lutris is an open gaming platform for Linux. It helps you install
+lutris: and manage your games in a unified interface.
+lutris: Our goal is to support every game which runs on Linux, from native to
+lutris: Windows games (via Wine) to emulators and browser games.
+lutris:
+lutris:
+lutris:
+lutris: https://lutris.net/
+lutris: