summaryrefslogtreecommitdiffstats
path: root/games
diff options
context:
space:
mode:
author B. Watson <yalhcru@gmail.com>2015-05-10 22:28:39 -0400
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-05-17 23:45:48 +0700
commite172861c4043d986d0a128c69c2c4f1692834140 (patch)
treeb0a868fa8ef59c04da642aef30770d363fb2493a /games
parent7d8d1ac062eb54409c419607db82fa6092a6e717 (diff)
downloadslackbuilds-e172861c4043d986d0a128c69c2c4f1692834140.tar.gz
slackbuilds-e172861c4043d986d0a128c69c2c4f1692834140.tar.xz
games/oblige: Updated for version 6.20.
Diffstat (limited to 'games')
-rw-r--r--games/oblige/Makefile.unixy215
-rw-r--r--games/oblige/oblige.6326
-rw-r--r--games/oblige/oblige.SlackBuild29
-rw-r--r--games/oblige/oblige.desktop8
-rw-r--r--games/oblige/oblige.info6
-rw-r--r--games/oblige/oblige.pngbin15879 -> 0 bytes
-rw-r--r--games/oblige/oblige.pod92
-rw-r--r--games/oblige/oblige.rst115
8 files changed, 259 insertions, 532 deletions
diff --git a/games/oblige/Makefile.unixy b/games/oblige/Makefile.unixy
deleted file mode 100644
index 52bd4fe636..0000000000
--- a/games/oblige/Makefile.unixy
+++ /dev/null
@@ -1,215 +0,0 @@
-#----------------------------------------------------------------
-# OBLIGE
-#----------------------------------------------------------------
-#
-# GNU Makefile for Unix/Linux with system-wide install
-#
-# Using this makefile (make, make install) will place the
-# executable, script and data files in standard Unixy places.
-# The script and data files can be overridden by files in the
-# $HOME/.oblige directory.
-#
-# NOTE: a system-wide FLTK library is assumed
-#
-
-PROGRAM=oblige
-
-# prefix choices: /usr /usr/local /opt
-INSTALL_PREFIX=/usr/local
-
-SCRIPT_DIR=$(INSTALL_PREFIX)/share/oblige
-
-CXX=g++
-
-LIB_LOC=lib_linux
-OBJ_DIR=obj_linux
-
-OPTIMISE=-O2
-
-# operating system choices: UNIX WIN32
-OS=UNIX
-
-
-#--- Internal stuff from here -----------------------------------
-
-# assumes system-wide FLTK installation
-FLTK_CONFIG=fltk-config
-FLTK_FLAGS=$(shell $(FLTK_CONFIG) --cflags)
-FLTK_LIBS=$(shell $(FLTK_CONFIG) --use-images --ldflags)
-
-CXXFLAGS=$(OPTIMISE) -Wall -D$(OS) -Ilua_src -Iglbsp_src -Iajpoly_src $(FLTK_FLAGS)
-LDFLAGS=-L/usr/X11R6/lib
-LIBS=-lm -lz $(FLTK_LIBS)
-
-CXXFLAGS += -DFHS_INSTALL
-
-
-#----- OBLIGE Objects ----------------------------------------------
-
-OBJS= $(OBJ_DIR)/main.o \
- $(OBJ_DIR)/m_about.o \
- $(OBJ_DIR)/m_cookie.o \
- $(OBJ_DIR)/m_console.o \
- $(OBJ_DIR)/m_dialog.o \
- $(OBJ_DIR)/m_lua.o \
- $(OBJ_DIR)/m_manage.o \
- $(OBJ_DIR)/m_options.o \
- $(OBJ_DIR)/m_spots.o \
- $(OBJ_DIR)/lib_argv.o \
- $(OBJ_DIR)/lib_file.o \
- $(OBJ_DIR)/lib_signal.o \
- $(OBJ_DIR)/lib_util.o \
- $(OBJ_DIR)/lib_grp.o \
- $(OBJ_DIR)/lib_pak.o \
- $(OBJ_DIR)/lib_wad.o \
- $(OBJ_DIR)/lib_zip.o \
- $(OBJ_DIR)/sys_assert.o \
- $(OBJ_DIR)/sys_debug.o \
- $(OBJ_DIR)/img_bolt.o \
- $(OBJ_DIR)/img_pill.o \
- $(OBJ_DIR)/img_carve.o \
- $(OBJ_DIR)/img_relief.o \
- $(OBJ_DIR)/img_font1.o \
- \
- $(OBJ_DIR)/csg_bsp.o \
- $(OBJ_DIR)/csg_clip.o \
- $(OBJ_DIR)/csg_main.o \
- $(OBJ_DIR)/csg_doom.o \
- $(OBJ_DIR)/csg_nukem.o \
- $(OBJ_DIR)/csg_quake.o \
- $(OBJ_DIR)/csg_shade.o \
- $(OBJ_DIR)/dm_extra.o \
- $(OBJ_DIR)/dm_prefab.o \
- $(OBJ_DIR)/g_doom.o \
- $(OBJ_DIR)/g_nukem.o \
- $(OBJ_DIR)/g_quake.o \
- $(OBJ_DIR)/g_quake2.o \
- $(OBJ_DIR)/g_wolf.o \
- $(OBJ_DIR)/q_common.o \
- $(OBJ_DIR)/q_light.o \
- $(OBJ_DIR)/q_tjuncs.o \
- $(OBJ_DIR)/q_vis.o \
- $(OBJ_DIR)/vis_buffer.o \
- $(OBJ_DIR)/vis_occlude.o \
- \
- $(OBJ_DIR)/twister.o \
- $(OBJ_DIR)/tx_forge.o \
- $(OBJ_DIR)/tx_skies.o \
- $(OBJ_DIR)/ui_build.o \
- $(OBJ_DIR)/ui_game.o \
- $(OBJ_DIR)/ui_hyper.o \
- $(OBJ_DIR)/ui_level.o \
- $(OBJ_DIR)/ui_map.o \
- $(OBJ_DIR)/ui_module.o \
- $(OBJ_DIR)/ui_rchoice.o \
- $(OBJ_DIR)/ui_play.o \
- $(OBJ_DIR)/ui_window.o \
- \
- $(OBJ_DIR)/zf_menu.o
-
-$(OBJ_DIR)/%.o: gui/%.cc
- $(CXX) $(CXXFLAGS) -o $@ -c $<
-
-
-#----- LUA Objects --------------------------------------------------
-
-LUA_OBJS=\
- $(OBJ_DIR)/lua/lapi.o \
- $(OBJ_DIR)/lua/lcode.o \
- $(OBJ_DIR)/lua/ldebug.o \
- $(OBJ_DIR)/lua/ldo.o \
- $(OBJ_DIR)/lua/ldump.o \
- $(OBJ_DIR)/lua/lfunc.o \
- $(OBJ_DIR)/lua/lgc.o \
- $(OBJ_DIR)/lua/llex.o \
- $(OBJ_DIR)/lua/lmem.o \
- $(OBJ_DIR)/lua/lobject.o \
- $(OBJ_DIR)/lua/lopcodes.o \
- $(OBJ_DIR)/lua/lparser.o \
- $(OBJ_DIR)/lua/lstate.o \
- $(OBJ_DIR)/lua/lstring.o \
- $(OBJ_DIR)/lua/ltable.o \
- $(OBJ_DIR)/lua/ltm.o \
- $(OBJ_DIR)/lua/lundump.o \
- $(OBJ_DIR)/lua/lvm.o \
- $(OBJ_DIR)/lua/lzio.o \
- \
- $(OBJ_DIR)/lua/lauxlib.o \
- $(OBJ_DIR)/lua/lbaselib.o \
- $(OBJ_DIR)/lua/ldblib.o \
- $(OBJ_DIR)/lua/liolib.o \
- $(OBJ_DIR)/lua/lmathlib.o \
- $(OBJ_DIR)/lua/loslib.o \
- $(OBJ_DIR)/lua/ltablib.o \
- $(OBJ_DIR)/lua/lstrlib.o \
- $(OBJ_DIR)/lua/loadlib.o \
- $(OBJ_DIR)/lua/linit.o
-
-LUA_CXXFLAGS=$(OPTIMISE) -Wall -DLUA_ANSI
-
-$(OBJ_DIR)/lua/%.o: lua_src/%.cc
- $(CXX) $(LUA_CXXFLAGS) -o $@ -c $<
-
-
-#----- glBSP Objects ------------------------------------------------
-
-GLBSP_OBJS= \
- $(OBJ_DIR)/glbsp/analyze.o \
- $(OBJ_DIR)/glbsp/blockmap.o \
- $(OBJ_DIR)/glbsp/glbsp.o \
- $(OBJ_DIR)/glbsp/level.o \
- $(OBJ_DIR)/glbsp/node.o \
- $(OBJ_DIR)/glbsp/reject.o \
- $(OBJ_DIR)/glbsp/seg.o \
- $(OBJ_DIR)/glbsp/system.o \
- $(OBJ_DIR)/glbsp/util.o \
- $(OBJ_DIR)/glbsp/wad.o
-
-GLBSP_CXXFLAGS=$(OPTIMISE) -Wall -DINLINE_G=inline
-
-$(OBJ_DIR)/glbsp/%.o: glbsp_src/%.cc
- $(CXX) $(GLBSP_CXXFLAGS) -o $@ -c $<
-
-#----- AJ-Polygonator Objects --------------------------------------
-
-AJPOLY_OBJS= \
- $(OBJ_DIR)/ajpoly/pl_map.o \
- $(OBJ_DIR)/ajpoly/pl_poly.o \
- $(OBJ_DIR)/ajpoly/pl_util.o \
- $(OBJ_DIR)/ajpoly/pl_wad.o
-
-AJPOLY_CXXFLAGS=$(OPTIMISE) -Wall
-
-$(OBJ_DIR)/ajpoly/%.o: ajpoly_src/%.cc
- $(CXX) $(AJPOLY_CXXFLAGS) -o $@ -c $<
-
-
-#----- Targets ----------------------------------------------------
-
-all: $(PROGRAM)
-
-clean:
- rm -f $(PROGRAM) $(OBJ_DIR)/*.o ERRS
- rm -f $(OBJ_DIR)/lua/*.o
- rm -f $(OBJ_DIR)/glbsp/*.o
-
-$(PROGRAM): $(OBJS) $(LUA_OBJS) $(GLBSP_OBJS) $(AJPOLY_OBJS)
- $(CXX) $^ -o $@ $(LDFLAGS) $(LIBS)
-
-stripped: $(PROGRAM)
- strip --strip-unneeded $(PROGRAM)
-
-install: stripped
- install -o root -m 755 $(PROGRAM) $(INSTALL_PREFIX)/bin/
- mkdir -p $(SCRIPT_DIR)
- cp -r scripts/ data/ games/ engines/ modules/ $(SCRIPT_DIR)
- find $(SCRIPT_DIR) -type f -print0 | xargs -0 chmod 644
-
-uninstall:
- rm -v $(INSTALL_PREFIX)/bin/$(PROGRAM)
- rm -Rv $(SCRIPT_DIR)
-
-.PHONY: all clean stripped install uninstall
-
-#--- editor settings ------------
-# vi:ts=8:sw=8:noexpandtab
diff --git a/games/oblige/oblige.6 b/games/oblige/oblige.6
index c71d9c9bd3..0c70b2891a 100644
--- a/games/oblige/oblige.6
+++ b/games/oblige/oblige.6
@@ -1,210 +1,134 @@
-.\" Automatically generated by Pod::Man 2.27 (Pod::Simple 3.28)
-.\"
-.\" Standard preamble:
-.\" ========================================================================
-.de Sp \" Vertical space (when we can't use .PP)
-.if t .sp .5v
-.if n .sp
-..
-.de Vb \" Begin verbatim text
-.ft CW
-.nf
-.ne \\$1
-..
-.de Ve \" End verbatim text
-.ft R
-.fi
+.\" Man page generated from reStructuredText.
+.
+.TH OBLIGE 6 "2015-05-10" "6.20" "SlackBuilds.org"
+.SH NAME
+oblige \- random level generator for Doom and Doom II
+.
+.nr rst2man-indent-level 0
+.
+.de1 rstReportMargin
+\\$1 \\n[an-margin]
+level \\n[rst2man-indent-level]
+level margin: \\n[rst2man-indent\\n[rst2man-indent-level]]
+-
+\\n[rst2man-indent0]
+\\n[rst2man-indent1]
+\\n[rst2man-indent2]
..
-.\" Set up some character translations and predefined strings. \*(-- will
-.\" give an unbreakable dash, \*(PI will give pi, \*(L" will give a left
-.\" double quote, and \*(R" will give a right double quote. \*(C+ will
-.\" give a nicer C++. Capital omega is used to do unbreakable dashes and
-.\" therefore won't be available. \*(C` and \*(C' expand to `' in nroff,
-.\" nothing in troff, for use with C<>.
-.tr \(*W-
-.ds C+ C\v'-.1v'\h'-1p'\s-2+\h'-1p'+\s0\v'.1v'\h'-1p'
-.ie n \{\
-. ds -- \(*W-
-. ds PI pi
-. if (\n(.H=4u)&(1m=24u) .ds -- \(*W\h'-12u'\(*W\h'-12u'-\" diablo 10 pitch
-. if (\n(.H=4u)&(1m=20u) .ds -- \(*W\h'-12u'\(*W\h'-8u'-\" diablo 12 pitch
-. ds L" ""
-. ds R" ""
-. ds C` ""
-. ds C' ""
-'br\}
-.el\{\
-. ds -- \|\(em\|
-. ds PI \(*p
-. ds L" ``
-. ds R" ''
-. ds C`
-. ds C'
-'br\}
-.\"
-.\" Escape single quotes in literal strings from groff's Unicode transform.
-.ie \n(.g .ds Aq \(aq
-.el .ds Aq '
-.\"
-.\" If the F register is turned on, we'll generate index entries on stderr for
-.\" titles (.TH), headers (.SH), subsections (.SS), items (.Ip), and index
-.\" entries marked with X<> in POD. Of course, you'll have to process the
-.\" output yourself in some meaningful fashion.
-.\"
-.\" Avoid warning from groff about undefined register 'F'.
-.de IX
+.de1 INDENT
+.\" .rstReportMargin pre:
+. RS \\$1
+. nr rst2man-indent\\n[rst2man-indent-level] \\n[an-margin]
+. nr rst2man-indent-level +1
+.\" .rstReportMargin post:
..
-.nr rF 0
-.if \n(.g .if rF .nr rF 1
-.if (\n(rF:(\n(.g==0)) \{
-. if \nF \{
-. de IX
-. tm Index:\\$1\t\\n%\t"\\$2"
+.de UNINDENT
+. RE
+.\" indent \\n[an-margin]
+.\" old: \\n[rst2man-indent\\n[rst2man-indent-level]]
+.nr rst2man-indent-level -1
+.\" new: \\n[rst2man-indent\\n[rst2man-indent-level]]
+.in \\n[rst2man-indent\\n[rst2man-indent-level]]u
..
-. if !\nF==2 \{
-. nr % 0
-. nr F 2
-. \}
-. \}
-.\}
-.rr rF
-.\"
-.\" Accent mark definitions (@(#)ms.acc 1.5 88/02/08 SMI; from UCB 4.2).
-.\" Fear. Run. Save yourself. No user-serviceable parts.
-. \" fudge factors for nroff and troff
-.if n \{\
-. ds #H 0
-. ds #V .8m
-. ds #F .3m
-. ds #[ \f1
-. ds #] \fP
-.\}
-.if t \{\
-. ds #H ((1u-(\\\\n(.fu%2u))*.13m)
-. ds #V .6m
-. ds #F 0
-. ds #[ \&
-. ds #] \&
-.\}
-. \" simple accents for nroff and troff
-.if n \{\
-. ds ' \&
-. ds ` \&
-. ds ^ \&
-. ds , \&
-. ds ~ ~
-. ds /
-.\}
-.if t \{\
-. ds ' \\k:\h'-(\\n(.wu*8/10-\*(#H)'\'\h"|\\n:u"
-. ds ` \\k:\h'-(\\n(.wu*8/10-\*(#H)'\`\h'|\\n:u'
-. ds ^ \\k:\h'-(\\n(.wu*10/11-\*(#H)'^\h'|\\n:u'
-. ds , \\k:\h'-(\\n(.wu*8/10)',\h'|\\n:u'
-. ds ~ \\k:\h'-(\\n(.wu-\*(#H-.1m)'~\h'|\\n:u'
-. ds / \\k:\h'-(\\n(.wu*8/10-\*(#H)'\z\(sl\h'|\\n:u'
-.\}
-. \" troff and (daisy-wheel) nroff accents
-.ds : \\k:\h'-(\\n(.wu*8/10-\*(#H+.1m+\*(#F)'\v'-\*(#V'\z.\h'.2m+\*(#F'.\h'|\\n:u'\v'\*(#V'
-.ds 8 \h'\*(#H'\(*b\h'-\*(#H'
-.ds o \\k:\h'-(\\n(.wu+\w'\(de'u-\*(#H)/2u'\v'-.3n'\*(#[\z\(de\v'.3n'\h'|\\n:u'\*(#]
-.ds d- \h'\*(#H'\(pd\h'-\w'~'u'\v'-.25m'\f2\(hy\fP\v'.25m'\h'-\*(#H'
-.ds D- D\\k:\h'-\w'D'u'\v'-.11m'\z\(hy\v'.11m'\h'|\\n:u'
-.ds th \*(#[\v'.3m'\s+1I\s-1\v'-.3m'\h'-(\w'I'u*2/3)'\s-1o\s+1\*(#]
-.ds Th \*(#[\s+2I\s-2\h'-\w'I'u*3/5'\v'-.3m'o\v'.3m'\*(#]
-.ds ae a\h'-(\w'a'u*4/10)'e
-.ds Ae A\h'-(\w'A'u*4/10)'E
-. \" corrections for vroff
-.if v .ds ~ \\k:\h'-(\\n(.wu*9/10-\*(#H)'\s-2\u~\d\s+2\h'|\\n:u'
-.if v .ds ^ \\k:\h'-(\\n(.wu*10/11-\*(#H)'\v'-.4m'^\v'.4m'\h'|\\n:u'
-. \" for low resolution devices (crt and lpr)
-.if \n(.H>23 .if \n(.V>19 \
-\{\
-. ds : e
-. ds 8 ss
-. ds o a
-. ds d- d\h'-1'\(ga
-. ds D- D\h'-1'\(hy
-. ds th \o'bp'
-. ds Th \o'LP'
-. ds ae ae
-. ds Ae AE
-.\}
-.rm #[ #] #H #V #F C
-.\" ========================================================================
-.\"
-.IX Title "OBLIGE 6"
-.TH OBLIGE 6 "2014-09-16" "6.10" "SlackBuilds.org"
-.\" For nroff, turn off justification. Always turn off hyphenation; it makes
-.\" way too many mistakes in technical documents.
-.if n .ad l
-.nh
-.SH "NAME"
-oblige \- random level generator for Doom and Doom II
-.SH "SYNOPSIS"
-.IX Header "SYNOPSIS"
-\&\fBoblige\fR [\-options]
-.SH "DESCRIPTION"
-.IX Header "DESCRIPTION"
-\&\fBoblige\fR creates a patch \s-1WAD\s0 file for use with Doom or Doom \s-1II,\s0
-containing one or more randomly-generated levels. The generated \s-1WAD\s0
-files are ready to play (no separate node-building pass is needed).
-.PP
-Normally, \fBoblige\fR is controlled by its \s-1GUI,\s0 but it can be used
-noninteractively (see the \fB\-b\fR option below).
-.SH "OPTIONS"
-.IX Header "OPTIONS"
-.IP "\fB\-\-home\fR <dir>" 4
-.IX Item "--home <dir>"
-Home directory, where \fBoblige\fR looks for its config file, and creates
-temporary files. Default is \fI~/.oblige\fR.
-.IP "\fB\-\-install\fR <dir>" 4
-.IX Item "--install <dir>"
-Installation directory, where \fBoblige\fR looks for lua scripts and other
-data. Default is \fI/usr/share/oblige\fR.
-.IP "\fB\-\-config\fR <file>" 4
-.IX Item "--config <file>"
-Config file to use. Default is \fI~/.oblige/CONFIG.txt\fR. Not used in
-\&\fB\-\-batch\fR mode.
-.IP "\fB\-b,\-\-batch\fR <output>" 4
-.IX Item "-b,--batch <output>"
-Batch mode (no \s-1GUI\s0). Uses built-in default config (never reads the
-normal config file used by the \s-1GUI\s0), but the \fB\-\-load\fR option can be
-used to override the defaults. \fIoutput\fR will be a \s-1PWAD\s0 file and will
+.\" RST source for oblige(6) man page. Convert with:
+.
+.\" rst2man.py oblige.rst > oblige.6
+.
+.\" rst2man.py comes from the SBo development/docutils package.
+.
+.SH SYNOPSIS
+.sp
+oblige [\fI\-options\fP]
+.SH DESCRIPTION
+.sp
+\fBoblige\fP creates a patch WAD file for use with Doom or Doom II,
+containing one or more randomly\-generated levels. The generated WAD
+files are ready to play (no separate node\-building pass is needed).
+.sp
+Normally, \fBoblige\fP is controlled by its GUI, but it can be used
+noninteractively (see the \fB\-b\fP option below).
+.SH OPTIONS
+.INDENT 0.0
+.TP
+.BI \-\-home \ <dir>
+Home directory, where B<oblige> looks for its config file, and creates
+temporary files. Default is \fI~/.oblige\fP\&.
+.TP
+.BI \-\-install \ <dir>
+Installation directory, where \fBoblige\fP looks for lua scripts and other
+data. Default is \fI/usr/share/oblige\fP\&.
+.TP
+.BI \-\-config \ <file>
+Config file to use. Default is \fI~/.oblige/CONFIG.txt\fP\&. Not used in
+\fB\-\-batch\fP mode.
+.UNINDENT
+.INDENT 0.0
+.TP
+.B \-\-batch, \fB\-b\fP \fI<output>\fP
+Batch mode (no GUI). Uses built\-in default config (never reads the
+normal config file used by the GUI), but the \fB\-\-load\fP option can be
+used to override the defaults. \fIoutput\fP will be a PWAD file and will
be overwritten without prompting if it exists.
-.IP "\fB\-l,\-\-load\fR <file>" 4
-.IX Item "-l,--load <file>"
+.TP
+.B \-\-load, \fB\-l\fP \fI<file>\fP
Load settings from a file. This is in the same format as
-\&\fI~/.oblige/CONFIG.txt\fR, and any settings in the loaded file will override
-the ones there. In \fB\-\-batch\fR mode, "\fB\-\-load ~/.oblige/CONFIG.txt\fR"
-will generate levels according to the settings configured by the \s-1GUI.\s0
-.IP "\fB\-k,\-\-keep\fR" 4
-.IX Item "-k,--keep"
+\fI~/.oblige/CONFIG.txt\fP, and any settings in the loaded file will override
+the ones there. In \fB\-\-batch\fP mode, "\fB\-\-load ~/.oblige/CONFIG.txt\fP"
+will generate levels according to the settings configured by the GUI.
+.UNINDENT
+.INDENT 0.0
+.TP
+.B \-\-keep\fP,\fB \-k
Keep random seed from loaded settings. Normally the seed stored in the
config file is ignored, and a new seed is generated.
-.IP "\fB\-d,\-\-debug\fR" 4
-.IX Item "-d,--debug"
+.TP
+.B \-\-debug\fP,\fB \-d
Enable verbose debugging messages in log.
-.IP "\fB\-t,\-\-terminal\fR" 4
-.IX Item "-t,--terminal"
-Print log messages to stdout (rather than \fI~/.oblige/LIGS.txt\fR). Disabled
-by default, unless in \fB\-\-batch\fR mode.
-.IP "\fB\-h,\-\-help\fR" 4
-.IX Item "-h,--help"
-Show built-in help message.
-.SH "SEE ALSO"
-.IX Header "SEE ALSO"
-\&\fBoblige\-legacy4\fR(6), an older version of \fBoblige\fR with a simpler
-level-generation algorithm and support for other games including Heretic,
+.TP
+.B \-\-terminal\fP,\fB \-t
+Print log messages to stdout (rather than \fI~/.oblige/LIGS.txt\fP). Disabled
+by default, unless in \fB\-\-batch\fP mode.
+.TP
+.B \-\-help\fP,\fB \-h
+Show built\-in help message.
+.UNINDENT
+.\" other sections we might want, uncomment as needed.
+.
+.\" FILES
+.
+.\" =====
+.
+.\" ENVIRONMENT
+.
+.\" ===========
+.
+.\" EXIT STATUS
+.
+.\" ===========
+.
+.\" BUGS
+.
+.\" ====
+.
+.\" EXAMPLES
+.
+.\" ========
+.
+.SH COPYRIGHT
+.sp
+See the file /usr/doc/oblige\-6.20/GPL.txt for license information.
+.SH AUTHORS
+.sp
+\fBoblige\fP is (c) 2006\-2015 by Andrew Apted.
+.sp
+This man page written for the SlackBuilds.org project
+by B. Watson, and is licensed under the WTFPL.
+.SH SEE ALSO
+.sp
+\fIoblige\-legacy4(6)\fP, an older version of \fBoblige\fP with a simpler
+level\-generation algorithm and support for other games including Heretic,
Hexen, and Quake.
-.PP
-The \fBoblige\fR home page: \fIhttp://oblige.sourceforge.net\fR
-.SH "LICENSE"
-.IX Header "LICENSE"
-This program is free software, under the terms of the \s-1GNU\s0 General Public
-License, and comes with \s-1ABSOLUTELY NO WARRANTY. \s0 See the documentation
-for more details, or visit http://www.gnu.org/licenses/gpl\-2.0.txt
-.SH "AUTHOR"
-.IX Header "AUTHOR"
-\&\fBoblige\fR is (c) 2006\-2014 by Andrew Apted.
-.PP
-This man page created by B. Watson, for the SlackBuilds.org project.
+.sp
+The \fBoblige\fP home page: \fI\%http://oblige.sourceforge.net\fP
+.\" Generated by docutils manpage writer.
+.
diff --git a/games/oblige/oblige.SlackBuild b/games/oblige/oblige.SlackBuild
index 384ff93a02..a6c5e65318 100644
--- a/games/oblige/oblige.SlackBuild
+++ b/games/oblige/oblige.SlackBuild
@@ -6,6 +6,12 @@
# Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
+# 20150510 bkw:
+# - version bump to 6.20
+# - use upstream's .desktop and icon
+# - get rid of hacked-up Makefile.unixy, use upstream's Makefile
+# - convert POD man page source to RST
+
# 20140916 bkw: bump BUILD to 2.
# add man page.
@@ -19,8 +25,8 @@
# in /usr/share.
PRGNAM=oblige
-VERSION=${VERSION:-6.10}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-6.20}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -59,7 +65,7 @@ rm -rf $PKG
mkdir -p $TMP $PKG/usr/bin $PKG/usr/share/$PRGNAM $OUTPUT
cd $TMP
rm -rf ${SRCNAM}-${VERSION}-source
-unzip $CWD/$PRGNAM-$SRCVER-source.zip
+tar xvf $CWD/$PRGNAM-$SRCVER-source.tar.gz
cd ${SRCNAM}-${VERSION}-source
chown -R root:root .
find -L . \
@@ -68,23 +74,20 @@ find -L . \
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
-exec chmod 644 {} \;
-# Makefile.unixy originally came from the oblige author, I've hacked
-# it up to make it work with oblige 6.x and SBo's fltk13.
-cp $CWD/Makefile.unixy Makefile
-
-# Fix a missing include
-sed -i '1i#include <unistd.h>' gui/lib_util.cc
+# 'make install' would install the .desktop and icon to /usr, not PREFIX.
+sed -i '/xdg-/d' Makefile
-make INSTALL_PREFIX=/usr OPTIMISE="$SLKCFLAGS" FLTK_CONFIG=fltk13-config
-make install INSTALL_PREFIX=$PKG/usr
+make PREFIX=/usr OPTIMISE="$SLKCFLAGS" FLTK_CONFIG=fltk13-config
+make install PREFIX=$PKG/usr
# man page written for this build (based on --help output)
mkdir -p $PKG/usr/man/man6
gzip -9c < $CWD/$PRGNAM.6 > $PKG/usr/man/man6/$PRGNAM.6.gz
+# Starting with 6.20, upstream includes a .desktop and icon.
mkdir -p $PKG/usr/share/pixmaps $PKG/usr/share/applications
-cat $CWD/$PRGNAM.png > $PKG/usr/share/pixmaps/$PRGNAM.png
-cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
+cat misc/icon_128x128.png > $PKG/usr/share/pixmaps/$PRGNAM.png
+cat misc/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp *.txt doc/*.txt $PKG/usr/doc/$PRGNAM-$VERSION
diff --git a/games/oblige/oblige.desktop b/games/oblige/oblige.desktop
deleted file mode 100644
index eaf1178bfc..0000000000
--- a/games/oblige/oblige.desktop
+++ /dev/null
@@ -1,8 +0,0 @@
-[Desktop Entry]
-Type=Application
-Name=Oblige
-GenericName=Doom Level Generator
-Icon=oblige
-Exec=oblige %f
-Terminal=false
-Categories=Game;ActionGame;Utility;
diff --git a/games/oblige/oblige.info b/games/oblige/oblige.info
index f633776f55..2696f00979 100644
--- a/games/oblige/oblige.info
+++ b/games/oblige/oblige.info
@@ -1,8 +1,8 @@
PRGNAM="oblige"
-VERSION="6.10"
+VERSION="6.20"
HOMEPAGE="http://oblige.sourceforge.net/"
-DOWNLOAD="http://sourceforge.net/projects/oblige/files/Oblige/6.10/oblige-610-source.zip"
-MD5SUM="a826aa76d573b74bce59440dd3232e5a"
+DOWNLOAD="http://sourceforge.net/projects/oblige/files/Oblige/6.20/oblige-620-source.tar.gz"
+MD5SUM="cae46a6381b4a36b1b0169999f8ff428"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES="fltk13"
diff --git a/games/oblige/oblige.png b/games/oblige/oblige.png
deleted file mode 100644
index 7d6b6a0f66..0000000000
--- a/games/oblige/oblige.png
+++ /dev/null
Binary files differ
diff --git a/games/oblige/oblige.pod b/games/oblige/oblige.pod
deleted file mode 100644
index 00d977c7e3..0000000000
--- a/games/oblige/oblige.pod
+++ /dev/null
@@ -1,92 +0,0 @@
-# pod source for oblige man page. convert with:
-# pod2man --stderr -s6 -cSlackBuilds.org -r6.10 oblige.pod > oblige.6
-
-=head1 NAME
-
-oblige - random level generator for Doom and Doom II
-
-=head1 SYNOPSIS
-
-B<oblige> [-options]
-
-=head1 DESCRIPTION
-
-B<oblige> creates a patch WAD file for use with Doom or Doom II,
-containing one or more randomly-generated levels. The generated WAD
-files are ready to play (no separate node-building pass is needed).
-
-Normally, B<oblige> is controlled by its GUI, but it can be used
-noninteractively (see the B<-b> option below).
-
-=head1 OPTIONS
-
-=over 4
-
-=item B<--home> <dir>
-
-Home directory, where B<oblige> looks for its config file, and creates
-temporary files. Default is I<~/.oblige>.
-
-=item B<--install> <dir>
-
-Installation directory, where B<oblige> looks for lua scripts and other
-data. Default is I</usr/share/oblige>.
-
-=item B<--config> <file>
-
-Config file to use. Default is I<~/.oblige/CONFIG.txt>. Not used in
-B<--batch> mode.
-
-=item B<-b,--batch> <output>
-
-Batch mode (no GUI). Uses built-in default config (never reads the
-normal config file used by the GUI), but the B<--load> option can be
-used to override the defaults. I<output> will be a PWAD file and will
-be overwritten without prompting if it exists.
-
-=item B<-l,--load> <file>
-
-Load settings from a file. This is in the same format as
-I<~/.oblige/CONFIG.txt>, and any settings in the loaded file will override
-the ones there. In B<--batch> mode, "B<--load ~/.oblige/CONFIG.txt>"
-will generate levels according to the settings configured by the GUI.
-
-=item B<-k,--keep>
-
-Keep random seed from loaded settings. Normally the seed stored in the
-config file is ignored, and a new seed is generated.
-
-=item B<-d,--debug>
-
-Enable verbose debugging messages in log.
-
-=item B<-t,--terminal>
-
-Print log messages to stdout (rather than I<~/.oblige/LIGS.txt>). Disabled
-by default, unless in B<--batch> mode.
-
-=item B<-h,--help>
-
-Show built-in help message.
-
-=back
-
-=head1 SEE ALSO
-
-B<oblige-legacy4>(6), an older version of B<oblige> with a simpler
-level-generation algorithm and support for other games including Heretic,
-Hexen, and Quake.
-
-The B<oblige> home page: I<http://oblige.sourceforge.net>
-
-=head1 LICENSE
-
-This program is free software, under the terms of the GNU General Public
-License, and comes with ABSOLUTELY NO WARRANTY. See the documentation
-for more details, or visit http://www.gnu.org/licenses/gpl-2.0.txt
-
-=head1 AUTHOR
-
-B<oblige> is (c) 2006-2014 by Andrew Apted.
-
-This man page created by B. Watson, for the SlackBuilds.org project.
diff --git a/games/oblige/oblige.rst b/games/oblige/oblige.rst
new file mode 100644
index 0000000000..1ba0a68f37
--- /dev/null
+++ b/games/oblige/oblige.rst
@@ -0,0 +1,115 @@
+.. RST source for oblige(6) man page. Convert with:
+.. rst2man.py oblige.rst > oblige.6
+.. rst2man.py comes from the SBo development/docutils package.
+
+.. |version| replace:: 6.20
+.. |date| date::
+
+======
+oblige
+======
+
+-------------------------------------------
+random level generator for Doom and Doom II
+-------------------------------------------
+
+:Manual section: 6
+:Manual group: SlackBuilds.org
+:Date: |date|
+:Version: |version|
+
+SYNOPSIS
+========
+
+oblige [*-options*]
+
+DESCRIPTION
+===========
+
+**oblige** creates a patch WAD file for use with Doom or Doom II,
+containing one or more randomly-generated levels. The generated WAD
+files are ready to play (no separate node-building pass is needed).
+
+Normally, **oblige** is controlled by its GUI, but it can be used
+noninteractively (see the **-b** option below).
+
+OPTIONS
+=======
+
+--home <dir>
+ Home directory, where B<oblige> looks for its config file, and creates
+ temporary files. Default is *~/.oblige*.
+
+--install <dir>
+ Installation directory, where **oblige** looks for lua scripts and other
+ data. Default is */usr/share/oblige*.
+
+--config <file>
+
+ Config file to use. Default is *~/.oblige/CONFIG.txt*. Not used in
+ **--batch** mode.
+
+--batch, **-b** *<output>*
+ Batch mode (no GUI). Uses built-in default config (never reads the
+ normal config file used by the GUI), but the **--load** option can be
+ used to override the defaults. *output* will be a PWAD file and will
+ be overwritten without prompting if it exists.
+
+--load, **-l** *<file>*
+ Load settings from a file. This is in the same format as
+ *~/.oblige/CONFIG.txt*, and any settings in the loaded file will override
+ the ones there. In **--batch** mode, "**--load ~/.oblige/CONFIG.txt**"
+ will generate levels according to the settings configured by the GUI.
+
+--keep, -k
+ Keep random seed from loaded settings. Normally the seed stored in the
+ config file is ignored, and a new seed is generated.
+
+--debug, -d
+ Enable verbose debugging messages in log.
+
+--terminal, -t
+ Print log messages to stdout (rather than *~/.oblige/LIGS.txt*). Disabled
+ by default, unless in **--batch** mode.
+
+--help, -h
+ Show built-in help message.
+
+.. other sections we might want, uncomment as needed.
+
+.. FILES
+.. =====
+
+.. ENVIRONMENT
+.. ===========
+
+.. EXIT STATUS
+.. ===========
+
+.. BUGS
+.. ====
+
+.. EXAMPLES
+.. ========
+
+COPYRIGHT
+=========
+
+See the file /usr/doc/oblige-|version|/GPL.txt for license information.
+
+AUTHORS
+=======
+
+**oblige** is (c) 2006-2015 by Andrew Apted.
+
+This man page written for the SlackBuilds.org project
+by B. Watson, and is licensed under the WTFPL.
+
+SEE ALSO
+========
+
+`oblige-legacy4(6)`, an older version of **oblige** with a simpler
+level-generation algorithm and support for other games including Heretic,
+Hexen, and Quake.
+
+The **oblige** home page: http://oblige.sourceforge.net