summaryrefslogtreecommitdiffstats
path: root/gis
diff options
context:
space:
mode:
author Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-04-12 03:23:06 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-04-12 03:23:06 +0700
commit15e0493775d1d4f2c4c323d7d62c8cd10cae9fc6 (patch)
tree3b002f37f9489bf496d2fe0cd64c1d38fcb861c5 /gis
parent869a410d23185ce27e100b621cd2213c0461b136 (diff)
downloadslackbuilds-15e0493775d1d4f2c4c323d7d62c8cd10cae9fc6.tar.gz
slackbuilds-15e0493775d1d4f2c4c323d7d62c8cd10cae9fc6.tar.xz
gis/geogit: Removed (replaced by geogig-py).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'gis')
-rw-r--r--gis/geogit-py/README3
-rw-r--r--gis/geogit-py/geogit-py.SlackBuild85
-rw-r--r--gis/geogit-py/geogit-py.info10
-rw-r--r--gis/geogit-py/slack-desc19
4 files changed, 0 insertions, 117 deletions
diff --git a/gis/geogit-py/README b/gis/geogit-py/README
deleted file mode 100644
index 9ca505fbf0..0000000000
--- a/gis/geogit-py/README
+++ /dev/null
@@ -1,3 +0,0 @@
-geogit-py is a Python library to use GeoGit designed to provide access to all
-GeoGit functionality, so it can be used to script tasks or as the base library
-for a GeoGit client.
diff --git a/gis/geogit-py/geogit-py.SlackBuild b/gis/geogit-py/geogit-py.SlackBuild
deleted file mode 100644
index 58559bf870..0000000000
--- a/gis/geogit-py/geogit-py.SlackBuild
+++ /dev/null
@@ -1,85 +0,0 @@
-#!/bin/sh
-
-# Slackware build script for geogit-py
-
-# Copyright 2014 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
-# All rights reserved.
-#
-# Redistribution and use of this script, with or without modification, is
-# permitted provided that the following conditions are met:
-#
-# 1. Redistributions of this script must retain the above copyright
-# notice, this list of conditions and the following disclaimer.
-#
-# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
-# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
-# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
-# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
-# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
-# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
-# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
-# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
-# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
-# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
-
-PRGNAM=geogit-py
-VERSION=${VERSION:-0.10}
-BUILD=${BUILD:-1}
-TAG=${TAG:-_SBo}
-
-if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
-fi
-
-CWD=$(pwd)
-TMP=${TMP:-/tmp/SBo}
-PKG=$TMP/package-$PRGNAM
-OUTPUT=${OUTPUT:-/tmp}
-
-if [ "$ARCH" = "i486" ]; then
- SLKCFLAGS="-O2 -march=i486 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
-elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
-else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
-fi
-
-set -e
-
-rm -rf $PKG
-mkdir -p $TMP $PKG $OUTPUT
-cd $TMP
-rm -rf $PRGNAM-$VERSION
-unzip $CWD/$PRGNAM-$VERSION.zip
-cd $PRGNAM-$VERSION
-chown -R root:root .
-find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-
-python setup.py install --root=$PKG
-
-find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
- grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
-
-mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a README $PKG/usr/doc/$PRGNAM-$VERSION
-cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
-
-mkdir -p $PKG/install
-cat $CWD/slack-desc > $PKG/install/slack-desc
-
-cd $PKG
-/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/gis/geogit-py/geogit-py.info b/gis/geogit-py/geogit-py.info
deleted file mode 100644
index 58f2fee039..0000000000
--- a/gis/geogit-py/geogit-py.info
+++ /dev/null
@@ -1,10 +0,0 @@
-PRGNAM="geogit-py"
-VERSION="0.10"
-HOMEPAGE="https://github.com/boundlessgeo/geogit-py"
-DOWNLOAD="https://pypi.python.org/packages/source/g/geogit-py/geogit-py-0.10.zip"
-MD5SUM="6e37b025fa312b1f21e03b1a24017329"
-DOWNLOAD_x86_64=""
-MD5SUM_x86_64=""
-REQUIRES="geogit geojson py4j Shapely"
-MAINTAINER="Benjamin Trigona-Harany"
-EMAIL="slackbuilds@jaxartes.net"
diff --git a/gis/geogit-py/slack-desc b/gis/geogit-py/slack-desc
deleted file mode 100644
index 520ef5bbf3..0000000000
--- a/gis/geogit-py/slack-desc
+++ /dev/null
@@ -1,19 +0,0 @@
-# HOW TO EDIT THIS FILE:
-# The "handy ruler" below makes it easier to edit a package description.
-# Line up the first '|' above the ':' following the base package name, and
-# the '|' on the right side marks the last column you can put a character in.
-# You must make exactly 11 lines for the formatting to be correct. It's also
-# customary to leave one space after the ':' except on otherwise blank lines.
-
- |-----handy-ruler------------------------------------------------------|
-geogit-py: geogit-py (Python library for GeoGit)
-geogit-py:
-geogit-py: geogit-py is a Python library to use GeoGit designed to provide access
-geogit-py: to all GeoGit functionality, so it can be used to script tasks or as
-geogit-py: the base library for a GeoGit client.
-geogit-py:
-geogit-py:
-geogit-py:
-geogit-py:
-geogit-py:
-geogit-py: