summaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
author Larry Hajali <larryhaja@gmail.com>2014-02-20 21:02:53 +0700
committer Erik Hanson <erik@slackbuilds.org>2014-02-21 14:41:03 -0600
commit42ef8bd55d4558299c53b1b5c4387d5353f1ffa4 (patch)
tree0ea94ec2e97f1583b78a354823ac2450ff2105f7 /graphics
parentd712c1cd56a9cbf0ba189a325bf0ff69861dd897 (diff)
downloadslackbuilds-42ef8bd55d4558299c53b1b5c4387d5353f1ffa4.tar.gz
slackbuilds-42ef8bd55d4558299c53b1b5c4387d5353f1ffa4.tar.xz
graphics/yagf: Updated for version 0.9.3.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/yagf/yagf.SlackBuild43
-rw-r--r--graphics/yagf/yagf.info8
2 files changed, 32 insertions, 19 deletions
diff --git a/graphics/yagf/yagf.SlackBuild b/graphics/yagf/yagf.SlackBuild
index b942c44f13..98b1c63b59 100644
--- a/graphics/yagf/yagf.SlackBuild
+++ b/graphics/yagf/yagf.SlackBuild
@@ -2,10 +2,28 @@
# Slackware build script for yagf
-# Written by Larry Hajali <larryhaja[at]gmail[dot]com>
+# Copyright 2009-2014 Larry Hajali <larryhaja[at]gmail[dot]com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
PRGNAM=yagf
-VERSION=${VERSION:-0.9.2}
+VERSION=${VERSION:-0.9.3}
BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
@@ -46,24 +64,20 @@ tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
cd $PRGNAM-$VERSION
chown -R root:root .
find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
# Fix desktop menu item.
-sed -i -e 's|true|false|' -e 's|OCR;|OCR;Graphics;Scanning;|' YAGF.desktop
+sed -i -e '/\[lt\]/,/\[pl\]/d' -e 's|OCR;|OCR;Graphics;Scanning;|' YAGF.desktop
+# Turn on tiff support.
+sed -i 's|MPTIFF_SUPPORT false|MPTIFF_SUPPORT true|' CMakeLists.txt
mkdir -p build
cd build
cmake -G "Unix Makefiles" \
-DCMAKE_INSTALL_PREFIX:PATH=/usr \
- -DLIB_PATH_SUFFIX="$LIBDIRSUFFIX" \
- -DCPACK_BINARY_TGZ=ON \
- -DCPACK_BINARY_TZ=ON \
- -DCPACK_BINARY_TBZ2=ON \
- -DCPACK_SOURCE_TBZ2=ON \
- -DCPACK_SOURCE_TZ=ON \
-DCMAKE_SKIP_RPATH:BOOL=YES \
-DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
-DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
@@ -77,8 +91,7 @@ find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
-cp -a \
- AUTHORS ChangeLog COPYING DESCRIPTION README \
+cp -a AUTHORS ChangeLog COPYING DESCRIPTION README \
$PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
diff --git a/graphics/yagf/yagf.info b/graphics/yagf/yagf.info
index 406c988efc..e6395adafa 100644
--- a/graphics/yagf/yagf.info
+++ b/graphics/yagf/yagf.info
@@ -1,10 +1,10 @@
PRGNAM="yagf"
-VERSION="0.9.2"
+VERSION="0.9.3"
HOMEPAGE="http://symmetrica.net/cuneiform-linux/yagf-en.html"
-DOWNLOAD="http://symmetrica.net/cuneiform-linux/yagf-0.9.2.tar.gz"
-MD5SUM="13592e52006d20f71c0094aafb13ed0e"
+DOWNLOAD="http://symmetrica.net/cuneiform-linux/yagf-0.9.3.tar.gz"
+MD5SUM="54549f1daef831ca88532b450a9cf1d9"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
-REQUIRES="%README%"
+REQUIRES="%README% cuneiform"
MAINTAINER="Larry Hajali"
EMAIL="larryhaja[at]gmail[dot]com"