summaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
author Dimitris Zlatanidis <d.zlatanidis@gmail.com>2014-02-17 17:59:12 +0700
committer Erik Hanson <erik@slackbuilds.org>2014-02-18 14:59:55 -0600
commit7b26cf6776878d03e4b9e0b1f8c5f7e6e96c749c (patch)
tree4123b9e808a72e093a6eca3d258811b8b41befdb /graphics
parentd911864590493d736141ddbb4b012b19506bfdbe (diff)
downloadslackbuilds-7b26cf6776878d03e4b9e0b1f8c5f7e6e96c749c.tar.gz
slackbuilds-7b26cf6776878d03e4b9e0b1f8c5f7e6e96c749c.tar.xz
graphics/CreateCloudMap: Added (cloud map for xplanet).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/CreateCloudMap/CreateCloudMap.SlackBuild85
-rw-r--r--graphics/CreateCloudMap/CreateCloudMap.info10
-rw-r--r--graphics/CreateCloudMap/README5
-rw-r--r--graphics/CreateCloudMap/slack-desc19
4 files changed, 119 insertions, 0 deletions
diff --git a/graphics/CreateCloudMap/CreateCloudMap.SlackBuild b/graphics/CreateCloudMap/CreateCloudMap.SlackBuild
new file mode 100644
index 0000000000..014aed7baf
--- /dev/null
+++ b/graphics/CreateCloudMap/CreateCloudMap.SlackBuild
@@ -0,0 +1,85 @@
+#!/bin/sh
+
+# Slackware build script for CreateCloudMap
+
+# Copyright 2014 Dimitris Zlatanidis Greece-Orestiada
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=CreateCloudMap
+VERSION=${VERSION:-0.3.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a LICENSE PKG-INFO README.rst $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/graphics/CreateCloudMap/CreateCloudMap.info b/graphics/CreateCloudMap/CreateCloudMap.info
new file mode 100644
index 0000000000..ea9bd6dfa6
--- /dev/null
+++ b/graphics/CreateCloudMap/CreateCloudMap.info
@@ -0,0 +1,10 @@
+PRGNAM="CreateCloudMap"
+VERSION="0.3.0"
+HOMEPAGE="https://github.com/jmozmoz/cloudmap"
+DOWNLOAD="https://pypi.python.org/packages/source/C/CreateCloudMap/CreateCloudMap-0.3.0.tar.gz"
+MD5SUM="d738e33f5a12ed89a4fa938d77437d9e"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pyresample scipy python-requests DateTime ConfigParser %README%"
+MAINTAINER="Dimitris Zlatanidis"
+EMAIL="d.zlatanidis@gmail.com"
diff --git a/graphics/CreateCloudMap/README b/graphics/CreateCloudMap/README
new file mode 100644
index 0000000000..f38ad22afa
--- /dev/null
+++ b/graphics/CreateCloudMap/README
@@ -0,0 +1,5 @@
+Python script to create a cloud map for xplanet using satellite images from the
+Dundee Satellite Receiving Station, Dundee University, UK.
+
+Optional :
+xplanet can use a cloud map to make the earth look more pretty.
diff --git a/graphics/CreateCloudMap/slack-desc b/graphics/CreateCloudMap/slack-desc
new file mode 100644
index 0000000000..07404c420e
--- /dev/null
+++ b/graphics/CreateCloudMap/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+CreateCloudMap: CreateCloudMap (cloud map for xplanet)
+CreateCloudMap:
+CreateCloudMap: Python script to create a cloud map for xplanet using satellite
+CreateCloudMap: images from the Dundee Satellite Receiving Station, Dundee
+CreateCloudMap: University, UK.
+CreateCloudMap:
+CreateCloudMap: Homepage: https://github.com/jmozmoz/cloudmap
+CreateCloudMap:
+CreateCloudMap:
+CreateCloudMap:
+CreateCloudMap: