summaryrefslogtreecommitdiffstats
path: root/graphics
diff options
context:
space:
mode:
author klaatu <klaatu@straightedgelinux.com>2014-09-06 18:49:34 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-09-06 18:51:33 +0700
commitde31d778afaad7193155c802d369c20de155635a (patch)
treea709c937172fd093c1d766ff070324802b55fb7b /graphics
parent53963669f2d3052458d9eaddcf59ffc48966f3d5 (diff)
downloadslackbuilds-de31d778afaad7193155c802d369c20de155635a.tar.gz
slackbuilds-de31d778afaad7193155c802d369c20de155635a.tar.xz
graphics/xcalib: Added (color profile manager).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'graphics')
-rw-r--r--graphics/xcalib/README34
-rw-r--r--graphics/xcalib/slack-desc19
-rw-r--r--graphics/xcalib/xcalib.SlackBuild86
-rw-r--r--graphics/xcalib/xcalib.info10
4 files changed, 149 insertions, 0 deletions
diff --git a/graphics/xcalib/README b/graphics/xcalib/README
new file mode 100644
index 0000000000..0dbba5c9a5
--- /dev/null
+++ b/graphics/xcalib/README
@@ -0,0 +1,34 @@
+Xcalib is a simple application to set ICC color profiles.
+This is frequently required in professional graphic and VFX
+environments to maintain consistent color throughout the production pipeline.
+
+
+BUILDING
+========
+By deault, this SlackBuild script builds the 'xcalib' target,
+suitable for Intel and Nvidia graphic processors.
+
+If you want to build xcalib for use with AMD proprietary
+FGLRX drivers, start the build script with a leading variable:
+
+GPU=fglrx ./xcalib.SlackBuild
+
+** Not having access to an AMD GPU, this is UNTESTED.
+
+
+ICC PROFILES
+============
+Sample ICC profiles are included with this build, but you should use an
+ICC profile for your monitor created by a spectrometer.
+An open source spectrometer is available from http://www.hughski.com/
+
+Common industry ICC profiles from Adobe and the ECC are available
+in the iccprofiles package here on SlackBuilds.org
+
+
+USAGE
+=======
+Using xcalib is as simple as:
+xcalib display :0 /usr/share/color/icc/foo.icc
+
+To make that automatic, add that line to your .xinitrc file.
diff --git a/graphics/xcalib/slack-desc b/graphics/xcalib/slack-desc
new file mode 100644
index 0000000000..9a0cd3e98d
--- /dev/null
+++ b/graphics/xcalib/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+xcalib: xcalib (color profile manager)
+xcalib:
+xcalib: xcalib is an open-source monitor calibration loader for applying the
+xcalib: calibration stored in ICC color profiles to a Linux system.
+xcalib:
+xcalib: http://xcalib.sourceforge.net
+xcalib:
+xcalib:
+xcalib:
+xcalib:
+xcalib:
diff --git a/graphics/xcalib/xcalib.SlackBuild b/graphics/xcalib/xcalib.SlackBuild
new file mode 100644
index 0000000000..390e121df3
--- /dev/null
+++ b/graphics/xcalib/xcalib.SlackBuild
@@ -0,0 +1,86 @@
+#!/bin/sh
+# Slackware build script for xcalib
+# Copyright 2014 klaatu @member.fsf.org
+
+# GNU All-Permissive License
+# Copying and distribution of this file, with or without modification,
+# are permitted in any medium without royalty provided the copyright
+# notice and this notice are preserved. This file is offered as-is,
+# without any warranty.
+
+PRGNAM=xcalib
+VERSION=${VERSION:-0.8}
+BUILD=${BUILD:-1}
+GPU=${GPU:-xcalib}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ LIBDIRSUFFIX="64"
+else
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG/usr/local/bin $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-source-$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+sed -i "s|usr/local/bin|usr/bin|" Makefile
+mkdir -p $PKG/usr/bin
+rm -rf $PKG/usr/local
+
+if [ "${GPU}" != "xcalib" ]; then
+ make $GPU_xcalib
+else
+ make $GPU
+fi
+
+# patch out a bizarre permission line
+# in makefile that renders this application
+# non executable
+sed -i '/chmod/d' ./Makefile
+
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a README README.profilers COPYING $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/usr/share/color/icc
+cp -a gamma*icc AdobeGammaTest.icm $PKG/usr/share/color/icc/
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/graphics/xcalib/xcalib.info b/graphics/xcalib/xcalib.info
new file mode 100644
index 0000000000..96c70d0f1b
--- /dev/null
+++ b/graphics/xcalib/xcalib.info
@@ -0,0 +1,10 @@
+PRGNAM="xcalib"
+VERSION="0.8"
+HOMEPAGE="http://xcalib.sourceforge.net"
+DOWNLOAD="http://colocrossing.dl.sourceforge.net/project/xcalib/xcalib/0.8/xcalib-source-0.8.tar.gz"
+MD5SUM="1fbcae44ad8d754512fdd1e5f1b3a7e7"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="klaatu"
+EMAIL="klaatu@member.fsf.org"