summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Euan Thoms <euan@potensol.com>2014-08-15 18:04:22 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2014-08-15 23:21:33 +0700
commit3026bf827ebfa8a3d9645a99d08b0e01d0e57fb4 (patch)
treeccabe2d25c5eab3829db05c36591ae214b269f9e /libraries
parentb1e258732ea485dd4feb6d25dd2ae3f636dbfaef (diff)
downloadslackbuilds-3026bf827ebfa8a3d9645a99d08b0e01d0e57fb4.tar.gz
slackbuilds-3026bf827ebfa8a3d9645a99d08b0e01d0e57fb4.tar.xz
libraries/belle-sip: Added (A Voice-over-IP phone).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/belle-sip/README1
-rw-r--r--libraries/belle-sip/belle-sip.SlackBuild116
-rw-r--r--libraries/belle-sip/belle-sip.info12
-rw-r--r--libraries/belle-sip/slack-desc19
4 files changed, 148 insertions, 0 deletions
diff --git a/libraries/belle-sip/README b/libraries/belle-sip/README
new file mode 100644
index 0000000000..61035eedc4
--- /dev/null
+++ b/libraries/belle-sip/README
@@ -0,0 +1 @@
+Belle-sip is a C object oriented SIP Stack.
diff --git a/libraries/belle-sip/belle-sip.SlackBuild b/libraries/belle-sip/belle-sip.SlackBuild
new file mode 100644
index 0000000000..304669c753
--- /dev/null
+++ b/libraries/belle-sip/belle-sip.SlackBuild
@@ -0,0 +1,116 @@
+#!/bin/sh
+
+# Slackware build script for ccrtp
+# Was written by Euan Thoms <euan at potensol dot com>
+
+# Copyright 2014 Euan Thoms United Kingdom
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=belle-sip
+VERSION=${VERSION:-1.3.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+DOCS="AUTHORS COPYING INSTALL NEWS README $CWD/$PRGNAM.SlackBuild"
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cp $CWD/antlr-*-complete.jar $PRGNAM-$VERSION/antlr.jar
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+# Ammend configure.ac for 64bit support and direct it to build dep antlr.jar
+cp configure.ac configure.ac.orig
+sed -i \
+ -e "s|/lib\"|/lib${LIBDIRSUFFIX}\"|g" \
+ -e "/^antlr_java_prefixes=/s|=.*$|=\"$(pwd)\"|g" \
+ configure.ac
+autoreconf -ivf
+
+CFLAGS="$SLKCFLAGS" \
+CXXFLAGS="$SLKCFLAGS" \
+CPPFLAGS="${CPPFLAGS} -I/usr/include/antlr3" \
+./configure \
+ --prefix=/usr \
+ --libdir=/usr/lib${LIBDIRSUFFIX} \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --mandir=/usr/man \
+ --infodir=/usr/info \
+ --docdir=/usr/doc/$PRGNAM-$VERSION \
+ --disable-silent-rules \
+ --disable-static \
+ --disable-tests \
+ --with-antlr=/usr \
+ --build=$ARCH-slackware-linux
+
+make
+make install DESTDIR=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
+chown -R root:root $PKG/usr/doc/$PRGNAM-$VERSION
+chmod 0644 $PKG/usr/doc/$PRGNAM-$VERSION/*
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/belle-sip/belle-sip.info b/libraries/belle-sip/belle-sip.info
new file mode 100644
index 0000000000..d2d00e225c
--- /dev/null
+++ b/libraries/belle-sip/belle-sip.info
@@ -0,0 +1,12 @@
+PRGNAM="belle-sip"
+VERSION="1.3.0"
+HOMEPAGE="http://www.linphone.org/technical-corner/belle-sip.html"
+DOWNLOAD="http://download.savannah.gnu.org/releases/linphone/belle-sip/belle-sip-1.3.0.tar.gz \
+ https://github.com/antlr/website-antlr3/raw/gh-pages/download/antlr-3.4-complete.jar"
+MD5SUM="ae9e8be12f62552a5376edd66b0265d9 \
+ 1b91dea1c7d480b3223f7c8a9aa0e172"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="libantlr3c polarssl jdk"
+MAINTAINER="Euan Thoms"
+EMAIL="euan at potensol dot com"
diff --git a/libraries/belle-sip/slack-desc b/libraries/belle-sip/slack-desc
new file mode 100644
index 0000000000..b764e7816e
--- /dev/null
+++ b/libraries/belle-sip/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+belle-sip: belle-sip (A Voice-over-IP phone)
+belle-sip:
+belle-sip: Belle-sip is a C object oriented SIP Stack.
+belle-sip:
+belle-sip: http://www.linphone.org/
+belle-sip:
+belle-sip:
+belle-sip:
+belle-sip:
+belle-sip:
+belle-sip: