summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Edinaldo P. Silva <edps.mundognu@gmail.com>2015-11-21 09:17:22 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-11-21 09:17:22 +0700
commit3b4067483c1480dcebe4b33c057f61360aeeddcb (patch)
treeda7b96b4908728f1a4e7bee5bd4bf9a43ff01a56 /libraries
parent0ce249c55f427884377c909d3f46f9a1b63e7c8b (diff)
downloadslackbuilds-3b4067483c1480dcebe4b33c057f61360aeeddcb.tar.gz
slackbuilds-3b4067483c1480dcebe4b33c057f61360aeeddcb.tar.xz
libraries/python3-PyYAML: Added (YAML parser and emitter).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/python3-PyYAML/README8
-rw-r--r--libraries/python3-PyYAML/python3-PyYAML.SlackBuild88
-rw-r--r--libraries/python3-PyYAML/python3-PyYAML.info10
-rw-r--r--libraries/python3-PyYAML/slack-desc19
4 files changed, 125 insertions, 0 deletions
diff --git a/libraries/python3-PyYAML/README b/libraries/python3-PyYAML/README
new file mode 100644
index 0000000000..ea05ab9eee
--- /dev/null
+++ b/libraries/python3-PyYAML/README
@@ -0,0 +1,8 @@
+pyyaml (YAML parser and emitter for Python)
+
+YAML is a data serialization format designed for human readability
+and interaction with scripting languages. PyYAML is a YAML parser and
+emitter for Python.
+
+This builds the python3 version of PyYAML. It is safe to install this
+on a system that has the SBo's PyYAML (python2) package installed.
diff --git a/libraries/python3-PyYAML/python3-PyYAML.SlackBuild b/libraries/python3-PyYAML/python3-PyYAML.SlackBuild
new file mode 100644
index 0000000000..455d8dfb10
--- /dev/null
+++ b/libraries/python3-PyYAML/python3-PyYAML.SlackBuild
@@ -0,0 +1,88 @@
+#!/bin/sh
+
+# Slackware build script for python-PyYAML
+# Copyright 2010 David Woodfall <dave@dawoodfall.net>
+# Copyright 2015 Jeremy Hansen <jebrhansen+SBo -at- gmail.com>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Adapted for python3-PyYAML by Jeremy Hansen <jebrhansen+SBo -at- gmail.com>
+
+PRGNAM=python3-PyYAML
+SRCNAM=PyYAML
+VERSION=${VERSION:-3.11}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+python3 setup.py install --root=$PKG
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGES LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/python3-PyYAML/python3-PyYAML.info b/libraries/python3-PyYAML/python3-PyYAML.info
new file mode 100644
index 0000000000..2a7773edc6
--- /dev/null
+++ b/libraries/python3-PyYAML/python3-PyYAML.info
@@ -0,0 +1,10 @@
+PRGNAM="python3-PyYAML"
+VERSION="3.11"
+HOMEPAGE="http://pyyaml.org"
+DOWNLOAD="http://pyyaml.org/download/pyyaml/PyYAML-3.11.tar.gz"
+MD5SUM="f50e08ef0fe55178479d3a618efe21db"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="python3"
+MAINTAINER="Jeremy Hansen"
+EMAIL="jebrhansen+SBo -at- gmail.com"
diff --git a/libraries/python3-PyYAML/slack-desc b/libraries/python3-PyYAML/slack-desc
new file mode 100644
index 0000000000..3e68405826
--- /dev/null
+++ b/libraries/python3-PyYAML/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+python3-PyYAML: python3-PyYAML (YAML parser and emitter for Python)
+python3-PyYAML:
+python3-PyYAML: YAML is a data serialization format designed for human readability
+python3-PyYAML: and interaction with scripting languages. PyYAML is a YAML parser
+python3-PyYAML: and emitter for Python.
+python3-PyYAML:
+python3-PyYAML: Homepage: http://pyyaml.org
+python3-PyYAML:
+python3-PyYAML: This builds the python3 version of PyYAML. It is safe to install this
+python3-PyYAML: on a system that has the SBo's PyYAML (python2) package installed.
+python3-PyYAML: