summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Marcel Saegebarth <marc@mos6581.de>2015-01-24 00:22:37 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-01-24 00:22:54 +0700
commit3d95b52e6fe5de688f54f74173645b87fd889696 (patch)
treebfde63af8dcc677532636affaed5fd96de7e2958 /libraries
parentc638929834ccd79ea4225706ac54ec00d5feb044 (diff)
downloadslackbuilds-3d95b52e6fe5de688f54f74173645b87fd889696.tar.gz
slackbuilds-3d95b52e6fe5de688f54f74173645b87fd889696.tar.xz
libraries/libwebsocketpp: Updated for version 0.5.0.
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/libwebsocketpp/README8
-rw-r--r--libraries/libwebsocketpp/libwebsocketpp.SlackBuild37
-rw-r--r--libraries/libwebsocketpp/libwebsocketpp.info6
-rw-r--r--libraries/libwebsocketpp/libwebsocketpp.patch10
-rw-r--r--libraries/libwebsocketpp/slack-desc12
5 files changed, 38 insertions, 35 deletions
diff --git a/libraries/libwebsocketpp/README b/libraries/libwebsocketpp/README
index 1690b1cb86..44fa644199 100644
--- a/libraries/libwebsocketpp/README
+++ b/libraries/libwebsocketpp/README
@@ -1,3 +1,5 @@
-WebSocket++ is a full featured C++/Boost ASIO implementation of RFC6455, the
-WebSocket protocol which can be used to build applications that feature
-WebSocket client and server functionality.
+WebSocket++ is a header only C++ library that implements RFC6455
+The WebSocket Protocol. It allows integrating WebSocket client and
+server functionality into C++ programs. It uses interchangeable
+network transport modules including one based on C++ iostreams and
+one based on Boost Asio.
diff --git a/libraries/libwebsocketpp/libwebsocketpp.SlackBuild b/libraries/libwebsocketpp/libwebsocketpp.SlackBuild
index a6cddb99e2..03c4b11982 100644
--- a/libraries/libwebsocketpp/libwebsocketpp.SlackBuild
+++ b/libraries/libwebsocketpp/libwebsocketpp.SlackBuild
@@ -1,8 +1,8 @@
#!/bin/sh
-# SlackBuild script for "libwebsocketpp".
+# Slackware build script for "libwebsocketpp".
-# Copyright 2012 Marcel Saegebarth <marc@mos6581.de>
+# Copyright 2013-2015 Marcel Saegebarth <marc@mos6581.de>
# All rights reserved.
#
# Redistribution and use in source and binary forms, with or without
@@ -24,9 +24,10 @@
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+SRCNAM=websocketpp
PRGNAM=libwebsocketpp
-VERSION=${VERSION:-20120917}
-BUILD=${BUILD:-2}
+VERSION=${VERSION:-0.5.0}
+BUILD=${BUILD:-1}
TAG=${TAG:-_SBo}
if [ -z "$ARCH" ]; then
@@ -61,25 +62,35 @@ set -e
rm -rf $PKG
mkdir -p $TMP $PKG $OUTPUT
cd $TMP
-rm -rf $PRGNAM-$VERSION
-tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
-cd $PRGNAM-$VERSION
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$VERSION.tar.gz || tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
chown -R root:root .
find -L . \
\( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
-o -perm 511 \) -exec chmod 755 {} \; -o \
\( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
-patch -p0 < $CWD/libwebsocketpp.patch
+sed -i "s|lib/cmake/websocketpp|lib${LIBDIRSUFFIX}/cmake/websocketpp|" CMakeLists.txt
-make -j1 CXXFLAGS="$SLKCFLAGS"
-make -j1 install prefix=$PKG/usr libdir=lib$LIBDIRSUFFIX SHARED=1
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DMAN_INSTALL_DIR=/usr/man \
+ -DCMAKE_BUILD_TYPE=Release ..
+make
+make install DESTDIR=$PKG
+cd ..
mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
cp -a \
- dependencies.txt readme.txt license.txt todo.txt \
- $PKG/usr/doc/$PRGNAM-$VERSION
+ COPYING changelog.md readme.md roadmap.md \
+ $PKG/usr/doc/$PRGNAM-$VERSION
cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
mkdir -p $PKG/install
diff --git a/libraries/libwebsocketpp/libwebsocketpp.info b/libraries/libwebsocketpp/libwebsocketpp.info
index ff0da7f24b..b3d859ce5b 100644
--- a/libraries/libwebsocketpp/libwebsocketpp.info
+++ b/libraries/libwebsocketpp/libwebsocketpp.info
@@ -1,8 +1,8 @@
PRGNAM="libwebsocketpp"
-VERSION="20120917"
+VERSION="0.5.0"
HOMEPAGE="https://github.com/zaphoyd/websocketpp/"
-DOWNLOAD="http://mos6581.de/static/slackbuilds.org/sources/libwebsocketpp-20120917.tar.gz"
-MD5SUM="ddb8cf172cabe770251f4f9ef2340a47"
+DOWNLOAD="https://github.com/zaphoyd/websocketpp/archive/0.5.0.tar.gz"
+MD5SUM="87cc20feea0692fd2dcda04af31fc60f"
DOWNLOAD_x86_64=""
MD5SUM_x86_64=""
REQUIRES=""
diff --git a/libraries/libwebsocketpp/libwebsocketpp.patch b/libraries/libwebsocketpp/libwebsocketpp.patch
deleted file mode 100644
index d37329f950..0000000000
--- a/libraries/libwebsocketpp/libwebsocketpp.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/messages/data.hpp.orig 2013-11-14 18:45:48.006935510 +0700
-+++ src/messages/data.hpp 2013-11-14 18:46:11.851588339 +0700
-@@ -36,6 +36,7 @@
- #include <boost/enable_shared_from_this.hpp>
- #include <boost/function.hpp>
- #include <boost/intrusive_ptr.hpp>
-+#include <boost/thread/locks.hpp>
- #include <boost/thread/mutex.hpp>
- #include <boost/utility.hpp>
-
diff --git a/libraries/libwebsocketpp/slack-desc b/libraries/libwebsocketpp/slack-desc
index 8fca7fbed3..cb465ca6fb 100644
--- a/libraries/libwebsocketpp/slack-desc
+++ b/libraries/libwebsocketpp/slack-desc
@@ -6,14 +6,14 @@
# customary to leave one space after the ':' except on otherwise blank lines.
|-----handy-ruler------------------------------------------------------|
-libwebsocketpp: libwebsocketpp (C++/Boost ASIO implementation of RFC6455)
+libwebsocketpp: libwebsocketpp (Header only C++ library)
libwebsocketpp:
-libwebsocketpp: WebSocket++ is a full featured C++/Boost ASIO implementation of
-libwebsocketpp: RFC6455, the WebSocket protocol which can be used to build
-libwebsocketpp: applications that feature WebSocket client and server functionality.
+libwebsocketpp: WebSocket++ is a header only C++ library that implements RFC6455
+libwebsocketpp: The WebSocket Protocol. It allows integrating WebSocket client and
+libwebsocketpp: server functionality into C++ programs. It uses interchangeable
+libwebsocketpp: network transport modules including one based on C++ iostreams and
+libwebsocketpp: one based on Boost Asio.
libwebsocketpp:
libwebsocketpp: Homepage: https://github.com/zaphoyd/websocketpp/
libwebsocketpp:
libwebsocketpp:
-libwebsocketpp:
-libwebsocketpp: