summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Peter Wang <novalazy@gmail.com>2015-06-14 22:07:53 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-06-14 22:09:01 +0700
commit4689b00db89248843d64c4d2ccb86424c74d4148 (patch)
tree78bf342fd55839b7871ab794973705c0e5e14789 /libraries
parent6e5a0ff4fd0a105e3c91e56ed3755514dacbb8e6 (diff)
downloadslackbuilds-4689b00db89248843d64c4d2ccb86424c74d4148.tar.gz
slackbuilds-4689b00db89248843d64c4d2ccb86424c74d4148.tar.xz
libraries/allegro4: Added (game programming library).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/allegro4/README20
-rw-r--r--libraries/allegro4/allegro4.SlackBuild116
-rw-r--r--libraries/allegro4/allegro4.info10
-rw-r--r--libraries/allegro4/build-dir.diff13
-rw-r--r--libraries/allegro4/doinst.sh14
-rw-r--r--libraries/allegro4/slack-desc19
6 files changed, 192 insertions, 0 deletions
diff --git a/libraries/allegro4/README b/libraries/allegro4/README
new file mode 100644
index 0000000000..57ec716406
--- /dev/null
+++ b/libraries/allegro4/README
@@ -0,0 +1,20 @@
+The Allegro library provides C/C++ programmers low level routines commonly
+needed in game programming, such as input, graphics, midi, sound effects, and
+timing. It is cross platform and works with many different compilers.
+Originally developed by Shawn Hargreaves, it is now a group project with
+contributions from all over the world! Some of its key features include:
+ * Ease of Use - comes with comprehensive documentation and examples
+ * Extensibility - if the built-in functionality isn't enough, there
+ are many add-ons available
+ * Cross Platform - without changing a single line of code, you can
+ create versions for Windows, OS X, Linux, DOS, and others! Works
+ with many compilers, including DJGPP and VC++
+ * Open Source - anyone can contribute, including you!
+ * Free - it won't cost you a dime, and there are no restrictions on
+ its usage
+
+Allegro 4 can make use of sound patches like 'eawpats' for MIDI playback.
+If 'eawpats' is installed first then this SlackBuild will create a
+patches.dat from it.
+
+NOTE: This package conflict with Allegro (5.x). Do not install both.
diff --git a/libraries/allegro4/allegro4.SlackBuild b/libraries/allegro4/allegro4.SlackBuild
new file mode 100644
index 0000000000..aac456a624
--- /dev/null
+++ b/libraries/allegro4/allegro4.SlackBuild
@@ -0,0 +1,116 @@
+#!/bin/sh
+#
+# Slackware build script for allegro
+#
+# Copyright 2009-2015 Erik W. Hanson, Minneapolis, MN, USA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+# Updated by Peter Wang
+
+PRGNAM=allegro4
+SRCNAM=allegro
+VERSION=${VERSION:-4.4.2}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -ue
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $SRCNAM-$VERSION
+tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
+cd $SRCNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+patch -p1 < $CWD/build-dir.diff
+
+mkdir -p build
+cd build
+ cmake \
+ -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DLIB_SUFFIX=${LIBDIRSUFFIX} \
+ -DCMAKE_BUILD_TYPE=Release ..
+ make VERBOSE=1
+ make install DESTDIR=$PKG
+cd ..
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/share/allegro
+cp language.dat keyboard.dat $PKG/usr/share/allegro
+mkdir -p $PKG/etc
+cp allegro.cfg $PKG/etc/allegro.cfg.new
+gzip -9 $PKG/usr/info/*.info*
+
+# 20140512 bkw: if eawpats is installed, create a patches.dat so Allegro
+# MIDI playback works.
+if [ -e /usr/share/sounds/eawpats/default.cfg ]; then
+ LD_LIBRARY_PATH=$PKG/usr/lib$LIBDIRSUFFIX \
+ $PKG/usr/bin/pat2dat \
+ /usr/share/sounds/eawpats/default.cfg \
+ $PKG/usr/share/$SRCNAM/patches.dat
+fi
+
+mkdir -p $PKG/usr/doc/$SRCNAM-$VERSION
+cp -a readme.txt todo.txt AUTHORS CHANGES THANKS $PKG/usr/doc/$SRCNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$SRCNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+cat $CWD/doinst.sh > $PKG/install/doinst.sh
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/allegro4/allegro4.info b/libraries/allegro4/allegro4.info
new file mode 100644
index 0000000000..0994d02643
--- /dev/null
+++ b/libraries/allegro4/allegro4.info
@@ -0,0 +1,10 @@
+PRGNAM="allegro4"
+VERSION="4.4.2"
+HOMEPAGE="http://www.allegro.cc/"
+DOWNLOAD="http://downloads.sourceforge.net/alleg/allegro-4.4.2.tar.gz"
+MD5SUM="4db71b0460fc99926ae91d223199c2e6"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Peter Wang"
+EMAIL="novalazy@gmail.com"
diff --git a/libraries/allegro4/build-dir.diff b/libraries/allegro4/build-dir.diff
new file mode 100644
index 0000000000..ebf13df196
--- /dev/null
+++ b/libraries/allegro4/build-dir.diff
@@ -0,0 +1,13 @@
+diff --git a/docs/CMakeLists.txt b/docs/CMakeLists.txt
+index 32ed053..7a429e8 100644
+--- a/docs/CMakeLists.txt
++++ b/docs/CMakeLists.txt
+@@ -72,7 +72,7 @@ foreach(page ${DOC_SRCS})
+ string(REPLACE "._tx" "" basename ${basename})
+
+ set(page ${CMAKE_CURRENT_SOURCE_DIR}/${page})
+- if(${page} MATCHES "/build/")
++ if(${page} MATCHES "/build/[^/]*[.]_tx$")
+ set(txt_out ${CMAKE_CURRENT_BINARY_DIR}/build/${basename}.txt)
+ set(html_out ${CMAKE_CURRENT_BINARY_DIR}/build/${basename}.html)
+ else()
diff --git a/libraries/allegro4/doinst.sh b/libraries/allegro4/doinst.sh
new file mode 100644
index 0000000000..5e444b85f3
--- /dev/null
+++ b/libraries/allegro4/doinst.sh
@@ -0,0 +1,14 @@
+config() {
+ NEW="$1"
+ OLD="$(dirname $NEW)/$(basename $NEW .new)"
+ # If there's no config file by that name, mv it over:
+ if [ ! -r $OLD ]; then
+ mv $NEW $OLD
+ elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
+ # toss the redundant copy
+ rm $NEW
+ fi
+ # Otherwise, we leave the .new copy for the admin to consider...
+}
+
+config etc/allegro.cfg.new
diff --git a/libraries/allegro4/slack-desc b/libraries/allegro4/slack-desc
new file mode 100644
index 0000000000..811f43af8d
--- /dev/null
+++ b/libraries/allegro4/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+allegro4: allegro4 (game programming library)
+allegro4:
+allegro4: The Allegro library provides C/C++ programmers low level routines
+allegro4: commonly needed in game programing, such as input, graphics, midi,
+allegro4: sound effects, and timing.
+allegro4:
+allegro4: http://www.allegro.cc/
+allegro4:
+allegro4:
+allegro4:
+allegro4: