summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Kent Fritz <fritz.kent@gmail.com>2015-04-17 07:50:19 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-04-17 07:50:19 +0700
commit502fb49e377bcd1b381e22ebad2d77182fa94e2a (patch)
tree0ab262b113da8471163ee1951c7d5a749e5585d5 /libraries
parent6f94460476aeba0ad7f37027069547348c4d8f73 (diff)
downloadslackbuilds-502fb49e377bcd1b381e22ebad2d77182fa94e2a.tar.gz
slackbuilds-502fb49e377bcd1b381e22ebad2d77182fa94e2a.tar.xz
libraries/hiredis: Added (Minimalistic C client for Redis).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/hiredis/Makefile.patch21
-rw-r--r--libraries/hiredis/README3
-rw-r--r--libraries/hiredis/hiredis.SlackBuild88
-rw-r--r--libraries/hiredis/hiredis.info10
-rw-r--r--libraries/hiredis/slack-desc19
5 files changed, 141 insertions, 0 deletions
diff --git a/libraries/hiredis/Makefile.patch b/libraries/hiredis/Makefile.patch
new file mode 100644
index 0000000000..28d399625a
--- /dev/null
+++ b/libraries/hiredis/Makefile.patch
@@ -0,0 +1,21 @@
+--- Makefile.orig 2015-04-03 15:07:16.975046819 -0700
++++ Makefile 2015-04-03 15:08:21.383052670 -0700
+@@ -150,15 +150,15 @@ INSTALL?= cp -a
+ $(PKGCONFNAME): hiredis.h
+ @echo "Generating $@ for pkgconfig..."
+ @echo prefix=$(PREFIX) > $@
+- @echo exec_prefix=$${prefix} >> $@
++ @echo exec_prefix=\$${prefix} >> $@
+ @echo libdir=$(INSTALL_LIBRARY_PATH) >> $@
+ @echo includedir=$(INSTALL_INCLUDE_PATH) >> $@
+ @echo >> $@
+ @echo Name: hiredis >> $@
+ @echo Description: Minimalistic C client library for Redis. >> $@
+ @echo Version: $(HIREDIS_MAJOR).$(HIREDIS_MINOR).$(HIREDIS_PATCH) >> $@
+- @echo Libs: -L$${libdir} -lhiredis >> $@
+- @echo Cflags: -I$${includedir} -D_FILE_OFFSET_BITS=64 >> $@
++ @echo Libs: -L\$${libdir} -lhiredis >> $@
++ @echo Cflags: -I\$${includedir} -D_FILE_OFFSET_BITS=64 >> $@
+
+ install: $(DYLIBNAME) $(STLIBNAME)
+ mkdir -p $(INSTALL_INCLUDE_PATH) $(INSTALL_LIBRARY_PATH)
diff --git a/libraries/hiredis/README b/libraries/hiredis/README
new file mode 100644
index 0000000000..691167f815
--- /dev/null
+++ b/libraries/hiredis/README
@@ -0,0 +1,3 @@
+hiredis (Minimalistic C client for Redis)
+
+Hiredis is a minimalistic C client library for the Redis database.
diff --git a/libraries/hiredis/hiredis.SlackBuild b/libraries/hiredis/hiredis.SlackBuild
new file mode 100644
index 0000000000..39c9cdf13f
--- /dev/null
+++ b/libraries/hiredis/hiredis.SlackBuild
@@ -0,0 +1,88 @@
+#!/bin/sh
+
+# Slackware build script for hiredis
+
+# Copyright 2015 Kent Fritz, Mountain View, CA
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=hiredis
+VERSION=${VERSION:-0.12.1}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=$TMP/package-$PRGNAM
+OUTPUT=${OUTPUT:-/tmp}
+
+if [ "$ARCH" = "i486" ]; then
+ SLKCFLAGS="-O2 -march=i486 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "i686" ]; then
+ SLKCFLAGS="-O2 -march=i686 -mtune=i686"
+ LIBDIRSUFFIX=""
+elif [ "$ARCH" = "x86_64" ]; then
+ SLKCFLAGS="-O2 -fPIC"
+ LIBDIRSUFFIX="64"
+else
+ SLKCFLAGS="-O2"
+ LIBDIRSUFFIX=""
+fi
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+tar xvf $CWD/$PRGNAM-$VERSION.tar.gz || tar xvf $CWD/v$VERSION.tar.gz
+cd $PRGNAM-$VERSION
+patch < $CWD/Makefile.patch
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
+ -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
+
+make OPTIMIZATION="" DEBUG="" CFLAGS="$SLKCFLAGS" \
+ PREFIX=/usr LIBRARY_PATH=lib${LIBDIRSUFFIX}
+make install DESTDIR=$PKG PREFIX=/usr LIBRARY_PATH=lib${LIBDIRSUFFIX}
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
+cp -a CHANGELOG.md COPYING README.md $PKG/usr/doc/$PRGNAM-$VERSION
+cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/hiredis/hiredis.info b/libraries/hiredis/hiredis.info
new file mode 100644
index 0000000000..9f210e9300
--- /dev/null
+++ b/libraries/hiredis/hiredis.info
@@ -0,0 +1,10 @@
+PRGNAM="hiredis"
+VERSION="0.12.1"
+HOMEPAGE="https://github.com/redis/hiredis"
+DOWNLOAD="https://github.com/redis/hiredis/archive/v0.12.1.tar.gz"
+MD5SUM="914e4aa8ab4a3f60d5739d2106e50502"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES=""
+MAINTAINER="Kent Fritz"
+EMAIL="fritz.kent@gmail.com"
diff --git a/libraries/hiredis/slack-desc b/libraries/hiredis/slack-desc
new file mode 100644
index 0000000000..533d301024
--- /dev/null
+++ b/libraries/hiredis/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+hiredis: hiredis (Minimalistic C client for Redis)
+hiredis:
+hiredis: Hiredis is a minimalistic C client library for the Redis database.
+hiredis:
+hiredis:
+hiredis:
+hiredis:
+hiredis:
+hiredis:
+hiredis:
+hiredis: