summaryrefslogtreecommitdiffstats
path: root/libraries
diff options
context:
space:
mode:
author Philip Lacroix <philnx at posteo dot de>2015-02-07 09:26:05 +0700
committer Willy Sudiarto Raharjo <willysr@slackbuilds.org>2015-02-07 09:26:05 +0700
commit6a12363518b57d1ec24add40d0fd8620bc21b1cf (patch)
tree937c1768f597a0ed89a8df462038c3b86cd0c373 /libraries
parentb799bc281afce3829df109a51f286e85b01450e6 (diff)
downloadslackbuilds-6a12363518b57d1ec24add40d0fd8620bc21b1cf.tar.gz
slackbuilds-6a12363518b57d1ec24add40d0fd8620bc21b1cf.tar.xz
libraries/batinfo: Added (Battery Information Library).
Signed-off-by: Willy Sudiarto Raharjo <willysr@slackbuilds.org>
Diffstat (limited to 'libraries')
-rw-r--r--libraries/batinfo/README3
-rw-r--r--libraries/batinfo/batinfo.SlackBuild88
-rw-r--r--libraries/batinfo/batinfo.info10
-rw-r--r--libraries/batinfo/slack-desc19
4 files changed, 120 insertions, 0 deletions
diff --git a/libraries/batinfo/README b/libraries/batinfo/README
new file mode 100644
index 0000000000..de5bb67514
--- /dev/null
+++ b/libraries/batinfo/README
@@ -0,0 +1,3 @@
+Batinfo is a simple Python library to retrieve battery information on
+Linux-based operating systems. No ACPI or external software are needed:
+only the Linux kernel and its /sys/class/power_supply folder.
diff --git a/libraries/batinfo/batinfo.SlackBuild b/libraries/batinfo/batinfo.SlackBuild
new file mode 100644
index 0000000000..3105466b7d
--- /dev/null
+++ b/libraries/batinfo/batinfo.SlackBuild
@@ -0,0 +1,88 @@
+#!/bin/sh
+
+# Slackware build script for Batinfo
+
+# Copyright 2015 Philip Lacroix <philnx at posteo dot de>
+# All rights reserved.
+#
+# Redistribution and use of this script, with or without modification, is
+# permitted provided that the following conditions are met:
+#
+# 1. Redistributions of this script must retain the above copyright
+# notice, this list of conditions and the following disclaimer.
+#
+# THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
+# WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
+# MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
+# EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
+# PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
+# OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
+# WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
+# OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
+# ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+PRGNAM=batinfo
+VERSION=${VERSION:-2.0}
+BUILD=${BUILD:-1}
+TAG=${TAG:-_SBo}
+
+if [ -z "$ARCH" ]; then
+ case "$( uname -m )" in
+ i?86) ARCH=i486 ;;
+ arm*) ARCH=arm ;;
+ *) ARCH=$( uname -m ) ;;
+ esac
+fi
+
+CWD=$(pwd)
+TMP=${TMP:-/tmp/SBo}
+PKG=${PKG:-$TMP/package-$PRGNAM}
+OUTPUT=${OUTPUT:-/tmp}
+
+set -e
+
+rm -rf $PKG
+mkdir -p $TMP $PKG $OUTPUT
+cd $TMP
+rm -rf $PRGNAM-$VERSION
+
+# The upstream tarball will be named differently, depending on the file being
+# downloaded manually (web browser) or with wget.
+if [ -e $CWD/v$VERSION.tar.gz ]; then
+ tar xvzf $CWD/v$VERSION.tar.gz
+else
+ tar xvzf $CWD/$PRGNAM-$VERSION.tar.gz
+fi
+
+cd $PRGNAM-$VERSION
+chown -R root:root .
+find -L . \
+ \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
+ -o -perm 511 \) -exec chmod 755 {} \; -o \
+ \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 \
+ -o -perm 400 \) -exec chmod 644 {} \;
+
+PRGUSR=$PKG/usr
+PRGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
+
+python setup.py install --root=$PKG
+
+# Python 3 support.
+if $(python3 -c 'import sys' 2>/dev/null); then
+ python3 setup.py install --root=$PKG
+fi
+
+find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
+ | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
+
+mkdir -p $PRGDOC
+mv $PRGUSR/share/doc/$PRGNAM/* $PRGDOC/
+rm -rf $PRGUSR/share
+cat $CWD/$PRGNAM.SlackBuild > $PRGDOC/$PRGNAM.SlackBuild
+
+mkdir -p $PKG/install
+cat $CWD/slack-desc > $PKG/install/slack-desc
+
+cd $PKG
+/sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.${PKGTYPE:-tgz}
diff --git a/libraries/batinfo/batinfo.info b/libraries/batinfo/batinfo.info
new file mode 100644
index 0000000000..1074a6b5f5
--- /dev/null
+++ b/libraries/batinfo/batinfo.info
@@ -0,0 +1,10 @@
+PRGNAM="batinfo"
+VERSION="2.0"
+HOMEPAGE="https://github.com/nicolargo/batinfo"
+DOWNLOAD="https://github.com/nicolargo/batinfo/archive/v2.0.tar.gz"
+MD5SUM="8141dd80df7e71de0396818142ecc39c"
+DOWNLOAD_x86_64=""
+MD5SUM_x86_64=""
+REQUIRES="pysetuptools"
+MAINTAINER="Philip Lacroix"
+EMAIL="philnx at posteo dot de"
diff --git a/libraries/batinfo/slack-desc b/libraries/batinfo/slack-desc
new file mode 100644
index 0000000000..0673c31dd8
--- /dev/null
+++ b/libraries/batinfo/slack-desc
@@ -0,0 +1,19 @@
+# HOW TO EDIT THIS FILE:
+# The "handy ruler" below makes it easier to edit a package description.
+# Line up the first '|' above the ':' following the base package name, and
+# the '|' on the right side marks the last column you can put a character in.
+# You must make exactly 11 lines for the formatting to be correct. It's also
+# customary to leave one space after the ':' except on otherwise blank lines.
+
+ |-----handy-ruler------------------------------------------------------|
+batinfo: Batinfo (Python library to retrieve battery information)
+batinfo:
+batinfo: Batinfo is a simple Python library to retrieve battery information
+batinfo: on Linux-based operating systems. No ACPI or external software are
+batinfo: needed: only the Linux kernel and its /sys/class/power_supply folder.
+batinfo:
+batinfo: Homepage: https://github.com/nicolargo/batinfo
+batinfo:
+batinfo:
+batinfo:
+batinfo: